Unverified Commit 317d548e authored by Zeke Mostov's avatar Zeke Mostov Committed by GitHub
Browse files

Merge branch 'master' into dependabot/npm_and_yarn/types/jest-26.0.20

parents fc0c0070 5269566a
......@@ -20,7 +20,7 @@
"test": "jest"
},
"dependencies": {
"@polkadot/api": "3.3.1",
"@polkadot/api": "3.3.2",
"memoizee": "^0.4.14"
},
"devDependencies": {
......
......@@ -509,36 +509,36 @@
"@nodelib/fs.scandir" "2.1.4"
fastq "^1.6.0"
"@polkadot/api-derive@3.3.1":
version "3.3.1"
resolved "https://registry.yarnpkg.com/@polkadot/api-derive/-/api-derive-3.3.1.tgz#a091556074caa80bd941711eb1c3c4b6102c6cf9"
integrity sha512-q31gxAitW9XKTBpGxJ2pywtQ9QddRZJzgj4mpBAIXVF+CHsOtmM+nvwHtZRE4FiaVQAhvgoWij3ARLfH5eRV2g==
"@polkadot/api-derive@3.3.2":
version "3.3.2"
resolved "https://registry.yarnpkg.com/@polkadot/api-derive/-/api-derive-3.3.2.tgz#4c9d6c6801dda71a18d511fabb890779471f9a70"
integrity sha512-Zp7SuRfgjsGUGmMaSJLaXH3PcCLfieo3rhiwajcgZm6/ZBoX5eQlADpAuAhAcugrr60a0LTiiHgt6a2MsqsX6w==
dependencies:
"@babel/runtime" "^7.12.5"
"@polkadot/api" "3.3.1"
"@polkadot/rpc-core" "3.3.1"
"@polkadot/types" "3.3.1"
"@polkadot/api" "3.3.2"
"@polkadot/rpc-core" "3.3.2"
"@polkadot/types" "3.3.2"
"@polkadot/util" "^5.2.3"
"@polkadot/util-crypto" "^5.2.3"
"@polkadot/x-rxjs" "3.3.1"
"@polkadot/x-rxjs" "3.3.2"
bn.js "^4.11.9"
"@polkadot/api@3.3.1":
version "3.3.1"
resolved "https://registry.yarnpkg.com/@polkadot/api/-/api-3.3.1.tgz#4ccf614033a684633ac6abf5390eb0e2120659ba"
integrity sha512-52n7ZSOBD/JNEaKqtI4+G4PCMbrrVzl/sQZhjEV+OCdx0XMwf3Zm7f2X6zukLSo0zoHrBYBKWekN+xR2GHH1Tg==
"@polkadot/api@3.3.2":
version "3.3.2"
resolved "https://registry.yarnpkg.com/@polkadot/api/-/api-3.3.2.tgz#c5d244fa1312c04a147322a14bc6eb43f93b8829"
integrity sha512-GUzuNFberFQjeqZq513sH8BMDx5Ez8JbgRF24HUJeWjpBZAwEgVr6mK+eUCnqE2P+PW7n971353nCUyfsixCxQ==
dependencies:
"@babel/runtime" "^7.12.5"
"@polkadot/api-derive" "3.3.1"
"@polkadot/api-derive" "3.3.2"
"@polkadot/keyring" "^5.2.3"
"@polkadot/metadata" "3.3.1"
"@polkadot/rpc-core" "3.3.1"
"@polkadot/rpc-provider" "3.3.1"
"@polkadot/types" "3.3.1"
"@polkadot/types-known" "3.3.1"
"@polkadot/metadata" "3.3.2"
"@polkadot/rpc-core" "3.3.2"
"@polkadot/rpc-provider" "3.3.2"
"@polkadot/types" "3.3.2"
"@polkadot/types-known" "3.3.2"
"@polkadot/util" "^5.2.3"
"@polkadot/util-crypto" "^5.2.3"
"@polkadot/x-rxjs" "3.3.1"
"@polkadot/x-rxjs" "3.3.2"
bn.js "^4.11.9"
eventemitter3 "^4.0.7"
......@@ -551,14 +551,14 @@
"@polkadot/util" "5.2.3"
"@polkadot/util-crypto" "5.2.3"
"@polkadot/metadata@3.3.1":
version "3.3.1"
resolved "https://registry.yarnpkg.com/@polkadot/metadata/-/metadata-3.3.1.tgz#255b8a0b62378c755fa7eb8452499a0cca86ed92"
integrity sha512-Ebzm+ctbp1mzol1e6C8ECG7NdLzeL4gQKxa1ilKF+wm2kiFwvzrxV21tYmvNI7I3IKMeHT0+X3pRlzUFyfXjSw==
"@polkadot/metadata@3.3.2":
version "3.3.2"
resolved "https://registry.yarnpkg.com/@polkadot/metadata/-/metadata-3.3.2.tgz#7654b9a612cace41fb87b5c6e508912f194c6eaa"
integrity sha512-+dIgGghwEl88uiRLZhEwlKyK0OX3TPGsXbyATWT6u8C388vNAyV2Her//Kluie/tESLVpjXzEeeqqvd9xm+RrA==
dependencies:
"@babel/runtime" "^7.12.5"
"@polkadot/types" "3.3.1"
"@polkadot/types-known" "3.3.1"
"@polkadot/types" "3.3.2"
"@polkadot/types-known" "3.3.2"
"@polkadot/util" "^5.2.3"
"@polkadot/util-crypto" "^5.2.3"
bn.js "^4.11.9"
......@@ -570,25 +570,25 @@
dependencies:
"@babel/runtime" "^7.12.5"
"@polkadot/rpc-core@3.3.1":
version "3.3.1"
resolved "https://registry.yarnpkg.com/@polkadot/rpc-core/-/rpc-core-3.3.1.tgz#60233fea680483a76af0d68d618eb2095b53e562"
integrity sha512-OBQZl1PNlLTMG1vte6YXwfC7HJqqyQSGLaxS1xJUFJVdIN9txwbsrrqbhgYwWfsWdacFZ11r/rB0HfZ89zdqDg==
"@polkadot/rpc-core@3.3.2":
version "3.3.2"
resolved "https://registry.yarnpkg.com/@polkadot/rpc-core/-/rpc-core-3.3.2.tgz#6d915afc75ca09f2a68c79129e42e27c324d1e2a"
integrity sha512-1f167jRxbsCoxzeG3Dq/bc3ZgtLWbbxO/RDJbAlUc/AWpP/pDLEMh/JuqossYtWzrByq0+t0y5aq+zEabhlYpw==
dependencies:
"@babel/runtime" "^7.12.5"
"@polkadot/metadata" "3.3.1"
"@polkadot/rpc-provider" "3.3.1"
"@polkadot/types" "3.3.1"
"@polkadot/metadata" "3.3.2"
"@polkadot/rpc-provider" "3.3.2"
"@polkadot/types" "3.3.2"
"@polkadot/util" "^5.2.3"
"@polkadot/x-rxjs" "3.3.1"
"@polkadot/x-rxjs" "3.3.2"
"@polkadot/rpc-provider@3.3.1":
version "3.3.1"
resolved "https://registry.yarnpkg.com/@polkadot/rpc-provider/-/rpc-provider-3.3.1.tgz#5120b67bbd054804b13092cfe20abbc3479b376b"
integrity sha512-uniicLPOWGOr0mEgr3KO56ryUTcu+6Fe6vhTpklguB3J7uO2/hIaMpCPN3Yb1xUQ5buQIkp16YVr7SF3pL4PWQ==
"@polkadot/rpc-provider@3.3.2":
version "3.3.2"
resolved "https://registry.yarnpkg.com/@polkadot/rpc-provider/-/rpc-provider-3.3.2.tgz#cb23bb63c9998b4ffca4470cfb1c9297b37b5ee0"
integrity sha512-yNtffX2DkCOsgw2pks8C5XP2P458FRyMhIOJsYwushbCHpa3iHTeUHSRqpKz2JiTp3SIKPtcTA0+SSmgsZ+Kzg==
dependencies:
"@babel/runtime" "^7.12.5"
"@polkadot/types" "3.3.1"
"@polkadot/types" "3.3.2"
"@polkadot/util" "^5.2.3"
"@polkadot/util-crypto" "^5.2.3"
"@polkadot/x-fetch" "^5.2.3"
......@@ -596,26 +596,26 @@
bn.js "^4.11.9"
eventemitter3 "^4.0.7"
"@polkadot/types-known@3.3.1":
version "3.3.1"
resolved "https://registry.yarnpkg.com/@polkadot/types-known/-/types-known-3.3.1.tgz#ef5ee5c46cefdb9c050726e1b1072c0510dc52b0"
integrity sha512-foOt/NgYqerqvs7PNlfyNWYKym0CQvrDuF7SkZewW5Y1XF4Ulx60A3pXOfUNwCRHuN9PB/JI/D3g9Fth3Tr0eg==
"@polkadot/types-known@3.3.2":
version "3.3.2"
resolved "https://registry.yarnpkg.com/@polkadot/types-known/-/types-known-3.3.2.tgz#7618e96d977ba630ed6ecca969df2c21c4dc272f"
integrity sha512-PpvHrJD7SWZMTvvOTv8mq3uwZvspDbYQBGfUvDwG3sY6IeD8KBY00FM2atGFPcDW07SgX5pnsR+uMAZfOBErSQ==
dependencies:
"@babel/runtime" "^7.12.5"
"@polkadot/types" "3.3.1"
"@polkadot/types" "3.3.2"
"@polkadot/util" "^5.2.3"
bn.js "^4.11.9"
"@polkadot/types@3.3.1":
version "3.3.1"
resolved "https://registry.yarnpkg.com/@polkadot/types/-/types-3.3.1.tgz#bd94296b1f116ef52e531c1d7d5130626116b099"
integrity sha512-Qba8dqyTAZLbep1hCq9gkXmzOp28BXc6fsD7X5+9kibv3/L0ZKHbmKmoDDM4OsBX5Ar04AuxKomR77FJR1FymQ==
"@polkadot/types@3.3.2":
version "3.3.2"
resolved "https://registry.yarnpkg.com/@polkadot/types/-/types-3.3.2.tgz#5cae028994435b332da19cd67f7915b4bbe2a93f"
integrity sha512-QF18+OdhV06Xa1IhzQARRUTo1Hqkb7X4ACuUGOM463epekcPE4HkW0h/fa21wGjmEFYm/2ur76BVNuvXuIuL3A==
dependencies:
"@babel/runtime" "^7.12.5"
"@polkadot/metadata" "3.3.1"
"@polkadot/metadata" "3.3.2"
"@polkadot/util" "^5.2.3"
"@polkadot/util-crypto" "^5.2.3"
"@polkadot/x-rxjs" "3.3.1"
"@polkadot/x-rxjs" "3.3.2"
"@types/bn.js" "^4.11.6"
bn.js "^4.11.9"
......@@ -692,10 +692,10 @@
dependencies:
"@babel/runtime" "^7.12.5"
"@polkadot/x-rxjs@3.3.1":
version "3.3.1"
resolved "https://registry.yarnpkg.com/@polkadot/x-rxjs/-/x-rxjs-3.3.1.tgz#e1ff305b5c96b1a696c632c49561bafb6b4ceb21"
integrity sha512-nmvAikDWSkChlqFzTHR5PX2wANVz8IepN9zO4QrgO4PmX3wT/ZykehsLtTXrVsOe95iuoZY4Qyvi9fcnNw0PTQ==
"@polkadot/x-rxjs@3.3.2":
version "3.3.2"
resolved "https://registry.yarnpkg.com/@polkadot/x-rxjs/-/x-rxjs-3.3.2.tgz#b29829f1c3df3ae63e2fcf70cefd477829ca8929"
integrity sha512-ktc78M7QCCykHYKGN1LMVkFhXiLkORYMC4d7+K1t/bM+oR7UQ6WXA6v2C7Zm10rPW5uS0O1JrAKjk+nxUPp5AQ==
dependencies:
"@babel/runtime" "^7.12.5"
rxjs "^6.6.3"
......@@ -2010,7 +2010,7 @@ error-ex@^1.2.0, error-ex@^1.3.1:
dependencies:
is-arrayish "^0.2.1"
es5-ext@^0.10.35, es5-ext@^0.10.45, es5-ext@^0.10.46, es5-ext@^0.10.50, es5-ext@~0.10.14, es5-ext@~0.10.2, es5-ext@~0.10.46:
es5-ext@^0.10.35, es5-ext@^0.10.46, es5-ext@^0.10.50, es5-ext@^0.10.53, es5-ext@~0.10.14, es5-ext@~0.10.2, es5-ext@~0.10.46:
version "0.10.53"
resolved "https://registry.yarnpkg.com/es5-ext/-/es5-ext-0.10.53.tgz#93c5a3acfdbef275220ad72644ad02ee18368de1"
integrity sha512-Xs2Stw6NiNHWypzRTY1MtaG/uJlwCk8kH81920ma8mvN8Xq1gsfhZvpkImLQArw8AHnv8MT2I45J3c0R8slE+Q==
......@@ -2036,7 +2036,7 @@ es6-symbol@^3.1.1, es6-symbol@~3.1.3:
d "^1.0.1"
ext "^1.1.2"
es6-weak-map@^2.0.2:
es6-weak-map@^2.0.3:
version "2.0.3"
resolved "https://registry.yarnpkg.com/es6-weak-map/-/es6-weak-map-2.0.3.tgz#b6da1f16cc2cc0d9be43e6bdbfc5e7dfcdf31d53"
integrity sha512-p5um32HOTO1kP+w7PRnB+5lQ43Z6muuMuIMffvDN8ZB4GcnjLBV6zGStpbASIMk4DCAvEaamhe2zhyCb/QXXsA==
......@@ -3051,7 +3051,7 @@ is-potential-custom-element-name@^1.0.0:
resolved "https://registry.yarnpkg.com/is-potential-custom-element-name/-/is-potential-custom-element-name-1.0.0.tgz#0c52e54bcca391bb2c494b21e8626d7336c6e397"
integrity sha1-DFLlS8yjkbssSUsh6GJtczbG45c=
is-promise@^2.1:
is-promise@^2.2.2:
version "2.2.2"
resolved "https://registry.yarnpkg.com/is-promise/-/is-promise-2.2.2.tgz#39ab959ccbf9a774cf079f7b40c7a26f763135f1"
integrity sha512-+lP4/6lKUBfQjZ2pdxThZvLUAafmZb8OAxFb8XXtiQmS35INgr85hdOGoEs124ez1FCnZJt6jau/T+alh58QFQ==
......@@ -3811,7 +3811,7 @@ lru-cache@^6.0.0:
dependencies:
yallist "^4.0.0"
lru-queue@0.1:
lru-queue@^0.1.0:
version "0.1.0"
resolved "https://registry.yarnpkg.com/lru-queue/-/lru-queue-0.1.0.tgz#2738bd9f0d3cf4f84490c5736c48699ac632cda3"
integrity sha1-Jzi9nw089PhEkMVzbEhpmsYyzaM=
......@@ -3884,18 +3884,18 @@ md5.js@^1.3.4:
safe-buffer "^5.1.2"
memoizee@^0.4.14:
version "0.4.14"
resolved "https://registry.yarnpkg.com/memoizee/-/memoizee-0.4.14.tgz#07a00f204699f9a95c2d9e77218271c7cd610d57"
integrity sha512-/SWFvWegAIYAO4NQMpcX+gcra0yEZu4OntmUdrBaWrJncxOqAziGFlHxc7yjKVK2uu3lpPW27P27wkR82wA8mg==
version "0.4.15"
resolved "https://registry.yarnpkg.com/memoizee/-/memoizee-0.4.15.tgz#e6f3d2da863f318d02225391829a6c5956555b72"
integrity sha512-UBWmJpLZd5STPm7PMUlOw/TSy972M+z8gcyQ5veOnSDRREz/0bmpyTfKt3/51DhEBqCZQn1udM/5flcSPYhkdQ==
dependencies:
d "1"
es5-ext "^0.10.45"
es6-weak-map "^2.0.2"
d "^1.0.1"
es5-ext "^0.10.53"
es6-weak-map "^2.0.3"
event-emitter "^0.3.5"
is-promise "^2.1"
lru-queue "0.1"
next-tick "1"
timers-ext "^0.1.5"
is-promise "^2.2.2"
lru-queue "^0.1.0"
next-tick "^1.1.0"
timers-ext "^0.1.7"
meow@^3.3.0:
version "3.7.0"
......@@ -4098,7 +4098,7 @@ neo-async@^2.6.0:
resolved "https://registry.yarnpkg.com/neo-async/-/neo-async-2.6.2.tgz#b4aafb93e3aeb2d8174ca53cf163ab7d7308305f"
integrity sha512-Yd3UES5mWCSqR+qNT93S3UoYUkqAZ9lLg8a7g9rimsWmYGK8cVToA4/sF3RrshdyV3sAGMXVUmpMYOw+dLpOuw==
next-tick@1:
next-tick@1, next-tick@^1.1.0:
version "1.1.0"
resolved "https://registry.yarnpkg.com/next-tick/-/next-tick-1.1.0.tgz#1836ee30ad56d67ef281b22bd199f709449b35eb"
integrity sha512-CXdUiJembsNjuToQvxayPZF9Vqht7hewsvy2sOWafLvi2awflj9mOC6bHIg50orX8IJvWKY9wYQ/zB2kogPslQ==
......@@ -5420,7 +5420,7 @@ through@2, "through@>=2.2.7 <3":
resolved "https://registry.yarnpkg.com/through/-/through-2.3.8.tgz#0dd4c9ffaabc357960b1b724115d7e0e86a2e1f5"
integrity sha1-DdTJ/6q8NXlgsbckEV1+Doai4fU=
timers-ext@^0.1.5:
timers-ext@^0.1.7:
version "0.1.7"
resolved "https://registry.yarnpkg.com/timers-ext/-/timers-ext-0.1.7.tgz#6f57ad8578e07a3fb9f91d9387d65647555e25c6"
integrity sha512-b85NUNzTSdodShTIbky6ZF02e8STtVVfD+fu4aXXShEELpozH+bCpJLYMPZbsABN2wDH7fJpqIoXxJpzbf0NqQ==
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment