Unverified Commit 4d9e046c authored by Hanwen Cheng's avatar Hanwen Cheng Committed by GitHub
Browse files

chore: update polkadot genesisHash (#626)

* update polkadot genesisHash

* bump version

* add polkadot metadata
parent 38808f50
Pipeline #94191 failed with stages
in 3 minutes and 45 seconds
......@@ -134,8 +134,8 @@ android {
minSdkVersion 18
missingDimensionStrategy 'react-native-camera', 'general'
targetSdkVersion 28
versionCode 4206
versionName "4.2.6"
versionCode 4207
versionName "4.2.7"
ndk {
abiFilters 'armeabi-v7a','arm64-v8a','x86','x86_64'
}
......
......@@ -17,11 +17,11 @@
<key>CFBundlePackageType</key>
<string>APPL</string>
<key>CFBundleShortVersionString</key>
<string>4.2.6</string>
<string>4.2.7</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleVersion</key>
<string>4206</string>
<string>4207</string>
<key>LSRequiresIPhoneOS</key>
<true/>
<key>NSAppTransportSecurity</key>
......
{
"name": "NativeSigner",
"version": "4.2.6-beta",
"version": "4.2.7-beta",
"private": true,
"license": "GPL-3.0",
"engines": {
......@@ -44,12 +44,12 @@
}
},
"dependencies": {
"@polkadot/api": "1.14.1",
"@polkadot/api": "1.16.1",
"@polkadot/reactnative-identicon": "0.53.1",
"@polkadot/types": "1.14.1",
"@polkadot/types-known": "1.14.1",
"@polkadot/util": "2.10.1",
"@polkadot/util-crypto": "2.10.1",
"@polkadot/types": "1.16.1",
"@polkadot/types-known": "1.16.1",
"@polkadot/util": "2.11.1",
"@polkadot/util-crypto": "2.11.1",
"@react-native-community/masked-view": "^0.1.6",
"@react-native-community/netinfo": "^4.1.5",
"@react-navigation/native": "^5.3.2",
......
This source diff could not be displayed because it is too large. You can view the blob instead.
......@@ -71,7 +71,8 @@ export const SubstrateNetworkKeys: {
'0xe3777fa922cafbff200cadeaea1a76bd7898ad5b89f7848999058b50e715f636',
KUSAMA_DEV:
'0x5e9679182f658e148f33d3f760f11179977398bb3da8d1f0bf7b267fe6b3ebb0',
POLKADOT: 'polkadot_reserved',
POLKADOT:
'0x0000000091b171bb158e2d3848fa23a9f1c25182fb8e20313b2c1eb49219da7a',
SUBSTRATE_DEV:
'0x0d667fd278ec412cd9fccdb066f09ed5b4cfd9c9afa9eb747213acb02b1e70bc', // substrate --dev commit ac6a2a783f0e1f4a814cf2add40275730cd41be1 hosted on wss://dev-node.substrate.dev .
WESTEND: '0x4a31f96525a77959d97e267c8fc3066ca333d9ade161720e1b7de8d35ccc6bd2'
......@@ -167,7 +168,6 @@ const substrateNetworkBase: {
title: 'Kusama Development',
unit: 'KSM'
},
//TODO genesisHash and Metadata need to be added
[SubstrateNetworkKeys.POLKADOT]: {
color: '#e7007a',
decimals: 12,
......
......@@ -45,6 +45,7 @@ import {
edgewareMetadata,
kulupuMetadata,
kusamaMetadata,
polkadotMetaData,
substrateDevMetadata,
westendMetadata
} from 'constants/networkMetadata';
......@@ -414,6 +415,8 @@ export const getMetadata = (networkKey: string): string => {
return edgewareMetadata;
case SubstrateNetworkKeys.KULUPU:
return kulupuMetadata;
case SubstrateNetworkKeys.POLKADOT:
return polkadotMetaData;
default:
return defaultMetaData;
}
......
......@@ -1458,61 +1458,61 @@
"@types/yargs" "^15.0.0"
chalk "^3.0.0"
"@polkadot/api-derive@1.14.1":
version "1.14.1"
resolved "https://registry.yarnpkg.com/@polkadot/api-derive/-/api-derive-1.14.1.tgz#3f3064af65bbb103b07a0986b97c76a40396e633"
integrity sha512-Qt+ijb+9WhDvBQM1ZJPSJKMchILY4/9pgGAMUcWZf9iC2nR9tOE8OG+OeFdzno43jspuZ8qUrkg5vapfZ/5/gQ==
"@polkadot/api-derive@1.16.1":
version "1.16.1"
resolved "https://registry.yarnpkg.com/@polkadot/api-derive/-/api-derive-1.16.1.tgz#a0560d1788fff69a1f7cdd209f40b3e37e7263b0"
integrity sha512-SLH/Wq5sIMQ9zFbQKdmB7Ne/jXMRgaA8TZ5rj0n0dp0yOqadEiJHZC5lx9hm5kR4u/DCuZc7aOFHYwd33N64qA==
dependencies:
"@babel/runtime" "^7.9.6"
"@polkadot/api" "1.14.1"
"@polkadot/rpc-core" "1.14.1"
"@polkadot/rpc-provider" "1.14.1"
"@polkadot/types" "1.14.1"
"@polkadot/util" "^2.10.1"
"@polkadot/util-crypto" "^2.10.1"
bn.js "^5.1.1"
"@polkadot/api" "1.16.1"
"@polkadot/rpc-core" "1.16.1"
"@polkadot/rpc-provider" "1.16.1"
"@polkadot/types" "1.16.1"
"@polkadot/util" "^2.11.1"
"@polkadot/util-crypto" "^2.11.1"
bn.js "^5.1.2"
memoizee "^0.4.14"
rxjs "^6.5.5"
"@polkadot/api@1.14.1":
version "1.14.1"
resolved "https://registry.yarnpkg.com/@polkadot/api/-/api-1.14.1.tgz#14ce2e9365343a8c810335473f5ae9e028313ca0"
integrity sha512-8HKrDp8khcy41jaEcTbelLircEhT+tCGc0yX9rSij2N4oulpxdY8fWWaF2ipVr2GKpE2t6fjBPiZcVMCDwpu9g==
"@polkadot/api@1.16.1":
version "1.16.1"
resolved "https://registry.yarnpkg.com/@polkadot/api/-/api-1.16.1.tgz#a0ff0e7307bae71a202a2e3be818ecce81f96c51"
integrity sha512-wNEi/9wD+5hSt7zm/dKErkJqkuHFFBJAB3vy4ZCOVQRQ6IkxVJ0OMg/7Q2xIEYxz962VmT/DDhwqOb4JBKW5qw==
dependencies:
"@babel/runtime" "^7.9.6"
"@polkadot/api-derive" "1.14.1"
"@polkadot/keyring" "^2.10.1"
"@polkadot/metadata" "1.14.1"
"@polkadot/rpc-core" "1.14.1"
"@polkadot/rpc-provider" "1.14.1"
"@polkadot/types" "1.14.1"
"@polkadot/types-known" "1.14.1"
"@polkadot/util" "^2.10.1"
"@polkadot/util-crypto" "^2.10.1"
bn.js "^5.1.1"
eventemitter3 "^4.0.1"
"@polkadot/api-derive" "1.16.1"
"@polkadot/keyring" "^2.11.1"
"@polkadot/metadata" "1.16.1"
"@polkadot/rpc-core" "1.16.1"
"@polkadot/rpc-provider" "1.16.1"
"@polkadot/types" "1.16.1"
"@polkadot/types-known" "1.16.1"
"@polkadot/util" "^2.11.1"
"@polkadot/util-crypto" "^2.11.1"
bn.js "^5.1.2"
eventemitter3 "^4.0.4"
rxjs "^6.5.5"
"@polkadot/keyring@^2.10.1":
version "2.10.1"
resolved "https://registry.yarnpkg.com/@polkadot/keyring/-/keyring-2.10.1.tgz#815c01984c6c3721e3f9454f64bf55bdac5e01d0"
integrity sha512-6Wbft7MtxbnWaHZpvg3yT8l4oQNp5xTwbqVkdaRfXmPsmhJ1YJcprFWLuKsWZE4x59cYyK7eKhnKcAvFny4HTQ==
"@polkadot/keyring@^2.11.1":
version "2.11.1"
resolved "https://registry.yarnpkg.com/@polkadot/keyring/-/keyring-2.11.1.tgz#4f3fb9f7d3cda7de743899a819cac85a0db9fc6b"
integrity sha512-nIeEiX0w7FmPJsuoAsEpDBRfy7QAgj+NTiY67mZoEDHAOJ6E9Bf6PubR24k1wzV57/0gmNEbd5FNZdI+tLSKdw==
dependencies:
"@babel/runtime" "^7.9.6"
"@polkadot/util" "2.10.1"
"@polkadot/util-crypto" "2.10.1"
"@polkadot/util" "2.11.1"
"@polkadot/util-crypto" "2.11.1"
"@polkadot/metadata@1.14.1":
version "1.14.1"
resolved "https://registry.yarnpkg.com/@polkadot/metadata/-/metadata-1.14.1.tgz#3746ab1cd43f551e1a9c64478b95baae98ac7849"
integrity sha512-nehxg81vcjSay5ScIwASNzM6Li59M0BR3g57hVkkj4uAbvu4bOEZ92dnQuGKbfzMmEQtvLfDdw/iDPqzCgxyGg==
"@polkadot/metadata@1.16.1":
version "1.16.1"
resolved "https://registry.yarnpkg.com/@polkadot/metadata/-/metadata-1.16.1.tgz#ed96227ec046e53a4a9e0ad21a9d582daa4b07fa"
integrity sha512-qQ13JoDCt5jgV6WwKs/8zj41t9kBWGCArixs0lNzVaqYf3igSsvA+p7H6t9K8yvSpWzK7rzQuzvMwnq3prlMWg==
dependencies:
"@babel/runtime" "^7.9.6"
"@polkadot/types" "1.14.1"
"@polkadot/types-known" "1.14.1"
"@polkadot/util" "^2.10.1"
"@polkadot/util-crypto" "^2.10.1"
bn.js "^5.1.1"
"@polkadot/types" "1.16.1"
"@polkadot/types-known" "1.16.1"
"@polkadot/util" "^2.11.1"
"@polkadot/util-crypto" "^2.11.1"
bn.js "^5.1.2"
"@polkadot/reactnative-identicon@0.53.1":
version "0.53.1"
......@@ -1523,55 +1523,55 @@
"@polkadot/ui-shared" "0.53.1"
react-native-svg "^12.1.0"
"@polkadot/rpc-core@1.14.1":
version "1.14.1"
resolved "https://registry.yarnpkg.com/@polkadot/rpc-core/-/rpc-core-1.14.1.tgz#b9af6102d94d4f3f993e8f5000a5a8243cfa382c"
integrity sha512-GxZlnxO4ocwaMKdfHgAc7/fvH5nLqZ1AdR9xKkqyR2t3MVjQozB2NeJi99mmZ093AhYHKvGmaBtu38CVTO8Sxg==
"@polkadot/rpc-core@1.16.1":
version "1.16.1"
resolved "https://registry.yarnpkg.com/@polkadot/rpc-core/-/rpc-core-1.16.1.tgz#be1a7e04e74092dd0c10b0ad22f8a92cd0e49aa8"
integrity sha512-DjPZOTWOPzNy0/gzrcMVWzOcYmxXvFwoGsZjRo4eD+5l+A5Zwd+3fDy6zuafVmHxRW0pcwMpbk1KmnEwyLhUtg==
dependencies:
"@babel/runtime" "^7.9.6"
"@polkadot/metadata" "1.14.1"
"@polkadot/rpc-provider" "1.14.1"
"@polkadot/types" "1.14.1"
"@polkadot/util" "^2.10.1"
"@polkadot/metadata" "1.16.1"
"@polkadot/rpc-provider" "1.16.1"
"@polkadot/types" "1.16.1"
"@polkadot/util" "^2.11.1"
memoizee "^0.4.14"
rxjs "^6.5.5"
"@polkadot/rpc-provider@1.14.1":
version "1.14.1"
resolved "https://registry.yarnpkg.com/@polkadot/rpc-provider/-/rpc-provider-1.14.1.tgz#4f243d7991fdd9fe0317aa5d42a1b29379acff1e"
integrity sha512-bp1EVLYVculRwcxKGlNxi1CWdsCEal9rtwMryOu5jw637Lpm23N1xq5vrX/pVQB2DzytvmuBJeUsf7DdgHEVAg==
"@polkadot/rpc-provider@1.16.1":
version "1.16.1"
resolved "https://registry.yarnpkg.com/@polkadot/rpc-provider/-/rpc-provider-1.16.1.tgz#7709ea14851a8c6f0ee35cfaeb8217f722cf5b68"
integrity sha512-qhqI3kfzetusollFhnsgpio6kvM8f/tMB5gROYXj5Oq2t9FcM03BzOWzqXRcBvUUQwQS1qp8eZzTYVVSf3CqnA==
dependencies:
"@babel/runtime" "^7.9.6"
"@polkadot/metadata" "1.14.1"
"@polkadot/types" "1.14.1"
"@polkadot/util" "^2.10.1"
"@polkadot/util-crypto" "^2.10.1"
bn.js "^5.1.1"
eventemitter3 "^4.0.1"
"@polkadot/metadata" "1.16.1"
"@polkadot/types" "1.16.1"
"@polkadot/util" "^2.11.1"
"@polkadot/util-crypto" "^2.11.1"
bn.js "^5.1.2"
eventemitter3 "^4.0.4"
isomorphic-fetch "^2.2.1"
websocket "^1.0.31"
"@polkadot/types-known@1.14.1":
version "1.14.1"
resolved "https://registry.yarnpkg.com/@polkadot/types-known/-/types-known-1.14.1.tgz#4bafa1159ed3ac50bd043643dce0eeb44fa31157"
integrity sha512-fqde3QavX1z+xIra1D6cObf36ATbK5rCcwG2vQU3YXV3NIHYIqQ6CO79TaybKsxx+Sv7ygy4j13G2rSdLqSuXQ==
"@polkadot/types-known@1.16.1":
version "1.16.1"
resolved "https://registry.yarnpkg.com/@polkadot/types-known/-/types-known-1.16.1.tgz#748c07c7b613e01c69fd780c71aab8583eecef63"
integrity sha512-rcANtjwGPTt3ZWVrwGtRk5UJYHTjqAvHL2JRNWn7hcedYbYWFoioCMloeIwCZgi3KZmPWeerNHHrz1SzMyF8HA==
dependencies:
"@babel/runtime" "^7.9.6"
"@polkadot/types" "1.14.1"
"@polkadot/util" "^2.10.1"
bn.js "^5.1.1"
"@polkadot/types" "1.16.1"
"@polkadot/util" "^2.11.1"
bn.js "^5.1.2"
"@polkadot/types@1.14.1":
version "1.14.1"
resolved "https://registry.yarnpkg.com/@polkadot/types/-/types-1.14.1.tgz#1854b74eec76af5ead1be6444e553c945c7c537a"
integrity sha512-Q3JIlAXMVWNGjsdWG0xnhone/1uj7R3vWFjft+cweNs40/tUalY6AbyBZ29XTU8WPEmmUspprQ5YmujhHtZg8Q==
"@polkadot/types@1.16.1":
version "1.16.1"
resolved "https://registry.yarnpkg.com/@polkadot/types/-/types-1.16.1.tgz#6f43abdaa8c037bd6f06a7dcf6e7e4ae0fcbc716"
integrity sha512-Z3RhHwV8YGG/wf5L7KeiFGt5NoAz4nS8hwIFgfMlTfPbb2obkuHEd6tEcsziwquqj5dnxM5sAfVFarInsyqD+A==
dependencies:
"@babel/runtime" "^7.9.6"
"@polkadot/metadata" "1.14.1"
"@polkadot/util" "^2.10.1"
"@polkadot/util-crypto" "^2.10.1"
"@polkadot/metadata" "1.16.1"
"@polkadot/util" "^2.11.1"
"@polkadot/util-crypto" "^2.11.1"
"@types/bn.js" "^4.11.6"
bn.js "^5.1.1"
bn.js "^5.1.2"
memoizee "^0.4.14"
rxjs "^6.5.5"
......@@ -1583,18 +1583,18 @@
"@babel/runtime" "^7.9.6"
color "^3.1.2"
"@polkadot/util-crypto@2.10.1", "@polkadot/util-crypto@^2.10.1":
version "2.10.1"
resolved "https://registry.yarnpkg.com/@polkadot/util-crypto/-/util-crypto-2.10.1.tgz#10c00a0b63d3f4005583e6aab5e9baee5234437c"
integrity sha512-sxJZwi5CWfOrytVGtvMT5gn7+rrdgCECtmiG94AouyzdCIWqr9DC+BbX95q7Rja8+kLwkm08FWAsI5pwN9oizQ==
"@polkadot/util-crypto@2.11.1", "@polkadot/util-crypto@^2.11.1":
version "2.11.1"
resolved "https://registry.yarnpkg.com/@polkadot/util-crypto/-/util-crypto-2.11.1.tgz#38bdca3b521127f82fbbfa84d6eb3716f6ebefb3"
integrity sha512-5LqSdjckKMOrdsGudeRKl2ybO0KS8n0HFTQ/zXTSUmXEOYrjlr6/XbwdJloSRwaJJvEeQcXlGrT9N4J7VousqQ==
dependencies:
"@babel/runtime" "^7.9.6"
"@polkadot/util" "2.10.1"
"@polkadot/util" "2.11.1"
"@polkadot/wasm-crypto" "^1.2.1"
base-x "^3.0.8"
bip39 "^3.0.2"
blakejs "^1.1.0"
bn.js "^5.1.1"
bn.js "^5.1.2"
bs58 "^4.0.1"
elliptic "^6.5.2"
js-sha3 "^0.8.0"
......@@ -1602,14 +1602,14 @@
tweetnacl "^1.0.3"
xxhashjs "^0.2.2"
"@polkadot/util@2.10.1", "@polkadot/util@^2.10.1":
version "2.10.1"
resolved "https://registry.yarnpkg.com/@polkadot/util/-/util-2.10.1.tgz#981e19327b49532c8b8d2f2d18e23c3548cbe969"
integrity sha512-DaIvvx3zphDlf3ZywLnlrRTngcjGIl7Dn3lbwsgHlMSyENz07TG6YG+ztr0ztUrb9BqFKAeH6XGNtGPBp0LxwA==
"@polkadot/util@2.11.1", "@polkadot/util@^2.11.1":
version "2.11.1"
resolved "https://registry.yarnpkg.com/@polkadot/util/-/util-2.11.1.tgz#be41aa56c4969e4efef755b3a648f2ee7af93ab3"
integrity sha512-JW09nmznZcM8KLfQISUQHu47/uq9mZwMfvDD/FSPVCOWBhYbwfjQknrwvslvhaJmBk/EvQsOS9hbE0/I4EoZAg==
dependencies:
"@babel/runtime" "^7.9.6"
"@types/bn.js" "^4.11.6"
bn.js "^5.1.1"
bn.js "^5.1.2"
camelcase "^5.3.1"
chalk "^4.0.0"
ip-regex "^4.1.0"
......@@ -2770,10 +2770,10 @@ bn.js@^4.0.0, bn.js@^4.1.0, bn.js@^4.1.1, bn.js@^4.4.0:
resolved "https://registry.yarnpkg.com/bn.js/-/bn.js-4.11.8.tgz#2cde09eb5ee341f484746bb0309b3253b1b1442f"
integrity sha512-ItfYfPLkWHUjckQCk8xC+LwxgK8NYcXywGigJgSwOP8Y2iyWT4f2vsZnoOXTTbo+o5yXmIUJ4gn5538SO5S3gA==
bn.js@^5.1.1:
version "5.1.1"
resolved "https://registry.yarnpkg.com/bn.js/-/bn.js-5.1.1.tgz#48efc4031a9c4041b9c99c6941d903463ab62eb5"
integrity sha512-IUTD/REb78Z2eodka1QZyyEk66pciRcP6Sroka0aI3tG/iwIdYLrBD62RsubR7vqdt3WyX8p4jxeatzmRSphtA==
bn.js@^5.1.2:
version "5.1.2"
resolved "https://registry.yarnpkg.com/bn.js/-/bn.js-5.1.2.tgz#c9686902d3c9a27729f43ab10f9d79c2004da7b0"
integrity sha512-40rZaf3bUNKTVYu9sIeeEGOg7g14Yvnj9kH7b50EiwX0Q7A6umbvfI5tvHaOERH0XigqKkfLkFQxzb4e6CIXnA==
boolbase@^1.0.0, boolbase@~1.0.0:
version "1.0.0"
......@@ -4333,7 +4333,7 @@ eventemitter3@^3.0.0:
resolved "https://registry.yarnpkg.com/eventemitter3/-/eventemitter3-3.1.2.tgz#2d3d48f9c346698fce83a85d7d664e98535df6e7"
integrity sha512-tvtQIeLVHjDkJYnzf2dgVMxfuSGJeM/7UCG17TT4EumTfNtF+0nebF/4zWOIkCreAbtNqhGEboB6BWrwqNaw4Q==
eventemitter3@^4.0.1:
eventemitter3@^4.0.4:
version "4.0.4"
resolved "https://registry.yarnpkg.com/eventemitter3/-/eventemitter3-4.0.4.tgz#b5463ace635a083d018bdc7c917b4c5f10a85384"
integrity sha512-rlaVLnVxtxvoyLsQQFBx53YmXHDxRIzzTLbdfxqi4yocpSjAxXwkU0cScM5JgSKMqEhrZpnvQ2D9gjylR0AimQ==
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment