Bump syn from 1.0.81 to 1.0.82 (#4368)

Bumps [syn](https://github.com/dtolnay/syn) from 1.0.81 to 1.0.82.
- [Release notes](https://github.com/dtolnay/syn/releases)
- [Commits](https://github.com/dtolnay/syn/compare/1.0.81...1.0.82)

---
updated-dependencies:
- dependency-name: syn
  dependency-type: direct:production
  update-type: version-update:semver-patch
...

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
28 jobs for master in 51 minutes and 59 seconds (queued for 7 seconds)
Name Stage Failure
failed
zombienet-tests-malus-dispute-valid Deploy


exit code 2
+ EXIT_STATUS=2
+ set +x

2021-11-28 01:58:07 - INFO - Exit status is 2
Cleaning up file based variables
ERROR: Job failed: command terminated with exit code 1
failed
zombienet-tests-parachains-smoke-test Deploy


exit code 1
+ EXIT_STATUS=1
+ set +x

2021-11-28 01:59:21 - INFO - Exit status is 1
Cleaning up file based variables
ERROR: Job failed: command terminated with exit code 1
failed
check-dependent-cumulus Build
    ... which satisfies dependency `async-trait = "=0.1.51"` of package `cumulus-client-collator v0.1.0 (/builds/parity/polkadot/cumulus/client/collator)`
... which satisfies path dependency `cumulus-client-collator` of package `cumulus-client-service v0.1.0 (/builds/parity/polkadot/cumulus/client/service)`
... which satisfies path dependency `cumulus-client-service` of package `cumulus-test-service v0.1.0 (/builds/parity/polkadot/cumulus/test/service)`
... which satisfies path dependency `cumulus-test-service` of package `cumulus-client-network v0.1.0 (/builds/parity/polkadot/cumulus/client/network)`
... which satisfies path dependency `cumulus-client-network` of package `parachain-template-node v0.1.0 (/builds/parity/polkadot/cumulus/parachain-template/node)`

failed to select a version for `syn` which could resolve this conflict
Cleaning up file based variables
ERROR: Job failed: exit code 1