Bump version to v0.9.12 (#4089)

* bump version

* update Cargo.lock

Co-authored-by: Andronik Ordian <write@reusable.software>
17 jobs for master in 37 minutes and 59 seconds (queued for 11 seconds)
Name Stage Failure
failed
check-dependent-cumulus Build
    Updating git repository `https://github.com/paritytech/substrate`
Updating crates.io index
Updating git repository `https://github.com/paritytech/polkadot`
error: failed to select a version for the requirement `polkadot-cli = "=0.9.11"`
candidate versions found which didn't match: 0.9.12
location searched: Git repository https://github.com/paritytech/polkadot?branch=master
required by package `parachain-template-node v0.1.0 (/builds/parity/polkadot/cumulus/parachain-template/node)`
Cleaning up file based variables
ERROR: Job failed: exit code 1