Unverified Commit ff9947da authored by thiolliere's avatar thiolliere Committed by GitHub
Browse files

Update substrate master (#411)

* in progress impl

* im_online authorityid

* fix

* fix

* use polkadot-master

* trigger CI

* trigger CI

* fix removal

* storage reorganize included

* lock version
parent 03cfa5e9
Pipeline #50730 passed with stages
in 44 minutes and 4 seconds
...@@ -819,7 +819,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index" ...@@ -819,7 +819,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]] [[package]]
name = "fork-tree" name = "fork-tree"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
] ]
...@@ -3557,7 +3557,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index" ...@@ -3557,7 +3557,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]] [[package]]
name = "sr-api-macros" name = "sr-api-macros"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"blake2-rfc 0.2.18 (registry+https://github.com/rust-lang/crates.io-index)", "blake2-rfc 0.2.18 (registry+https://github.com/rust-lang/crates.io-index)",
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)", "proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3569,7 +3569,7 @@ dependencies = [ ...@@ -3569,7 +3569,7 @@ dependencies = [
[[package]] [[package]]
name = "sr-io" name = "sr-io"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"environmental 1.0.1 (registry+https://github.com/rust-lang/crates.io-index)", "environmental 1.0.1 (registry+https://github.com/rust-lang/crates.io-index)",
"hash-db 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)", "hash-db 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3586,7 +3586,7 @@ dependencies = [ ...@@ -3586,7 +3586,7 @@ dependencies = [
[[package]] [[package]]
name = "sr-primitives" name = "sr-primitives"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"integer-sqrt 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)", "integer-sqrt 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)", "log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3604,7 +3604,7 @@ dependencies = [ ...@@ -3604,7 +3604,7 @@ dependencies = [
[[package]] [[package]]
name = "sr-staking-primitives" name = "sr-staking-primitives"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"sr-primitives 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sr-primitives 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -3614,7 +3614,7 @@ dependencies = [ ...@@ -3614,7 +3614,7 @@ dependencies = [
[[package]] [[package]]
name = "sr-std" name = "sr-std"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"rustc_version 0.2.3 (registry+https://github.com/rust-lang/crates.io-index)", "rustc_version 0.2.3 (registry+https://github.com/rust-lang/crates.io-index)",
] ]
...@@ -3622,7 +3622,7 @@ dependencies = [ ...@@ -3622,7 +3622,7 @@ dependencies = [
[[package]] [[package]]
name = "sr-version" name = "sr-version"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"impl-serde 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)", "impl-serde 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3634,7 +3634,7 @@ dependencies = [ ...@@ -3634,7 +3634,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-authorship" name = "srml-authorship"
version = "0.1.0" version = "0.1.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"sr-io 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sr-io 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -3649,7 +3649,7 @@ dependencies = [ ...@@ -3649,7 +3649,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-babe" name = "srml-babe"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"hex-literal 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)", "hex-literal 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3669,7 +3669,7 @@ dependencies = [ ...@@ -3669,7 +3669,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-balances" name = "srml-balances"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)", "safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3684,7 +3684,7 @@ dependencies = [ ...@@ -3684,7 +3684,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-collective" name = "srml-collective"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)", "safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3700,7 +3700,7 @@ dependencies = [ ...@@ -3700,7 +3700,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-democracy" name = "srml-democracy"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)", "safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3715,7 +3715,7 @@ dependencies = [ ...@@ -3715,7 +3715,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-elections" name = "srml-elections"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)", "safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3731,7 +3731,7 @@ dependencies = [ ...@@ -3731,7 +3731,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-executive" name = "srml-executive"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3745,7 +3745,7 @@ dependencies = [ ...@@ -3745,7 +3745,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-finality-tracker" name = "srml-finality-tracker"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3759,7 +3759,7 @@ dependencies = [ ...@@ -3759,7 +3759,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-grandpa" name = "srml-grandpa"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3778,7 +3778,7 @@ dependencies = [ ...@@ -3778,7 +3778,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-im-online" name = "srml-im-online"
version = "0.1.0" version = "0.1.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3796,7 +3796,7 @@ dependencies = [ ...@@ -3796,7 +3796,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-indices" name = "srml-indices"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)", "safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3813,7 +3813,7 @@ dependencies = [ ...@@ -3813,7 +3813,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-membership" name = "srml-membership"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3827,7 +3827,7 @@ dependencies = [ ...@@ -3827,7 +3827,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-metadata" name = "srml-metadata"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3838,7 +3838,7 @@ dependencies = [ ...@@ -3838,7 +3838,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-offences" name = "srml-offences"
version = "1.0.0" version = "1.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3853,7 +3853,7 @@ dependencies = [ ...@@ -3853,7 +3853,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-session" name = "srml-session"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)", "safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3871,7 +3871,7 @@ dependencies = [ ...@@ -3871,7 +3871,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-staking" name = "srml-staking"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)", "safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3885,12 +3885,13 @@ dependencies = [ ...@@ -3885,12 +3885,13 @@ dependencies = [
"srml-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "srml-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"srml-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "srml-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"substrate-keyring 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "substrate-keyring 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"substrate-phragmen 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
] ]
[[package]] [[package]]
name = "srml-sudo" name = "srml-sudo"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3905,7 +3906,7 @@ dependencies = [ ...@@ -3905,7 +3906,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-support" name = "srml-support"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"bitmask 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)", "bitmask 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
"once_cell 0.1.8 (registry+https://github.com/rust-lang/crates.io-index)", "once_cell 0.1.8 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3924,7 +3925,7 @@ dependencies = [ ...@@ -3924,7 +3925,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-support-procedural" name = "srml-support-procedural"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"proc-macro2 0.4.30 (registry+https://github.com/rust-lang/crates.io-index)", "proc-macro2 0.4.30 (registry+https://github.com/rust-lang/crates.io-index)",
"quote 0.6.13 (registry+https://github.com/rust-lang/crates.io-index)", "quote 0.6.13 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3936,7 +3937,7 @@ dependencies = [ ...@@ -3936,7 +3937,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-support-procedural-tools" name = "srml-support-procedural-tools"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)", "proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"proc-macro2 0.4.30 (registry+https://github.com/rust-lang/crates.io-index)", "proc-macro2 0.4.30 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3948,7 +3949,7 @@ dependencies = [ ...@@ -3948,7 +3949,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-support-procedural-tools-derive" name = "srml-support-procedural-tools-derive"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"proc-macro2 0.4.30 (registry+https://github.com/rust-lang/crates.io-index)", "proc-macro2 0.4.30 (registry+https://github.com/rust-lang/crates.io-index)",
"quote 0.6.13 (registry+https://github.com/rust-lang/crates.io-index)", "quote 0.6.13 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3958,7 +3959,7 @@ dependencies = [ ...@@ -3958,7 +3959,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-system" name = "srml-system"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)", "safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3974,7 +3975,7 @@ dependencies = [ ...@@ -3974,7 +3975,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-timestamp" name = "srml-timestamp"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3988,7 +3989,7 @@ dependencies = [ ...@@ -3988,7 +3989,7 @@ dependencies = [
[[package]] [[package]]
name = "srml-treasury" name = "srml-treasury"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4074,7 +4075,7 @@ dependencies = [ ...@@ -4074,7 +4075,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-application-crypto" name = "substrate-application-crypto"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4097,7 +4098,7 @@ dependencies = [ ...@@ -4097,7 +4098,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-cli" name = "substrate-cli"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"ansi_term 0.11.0 (registry+https://github.com/rust-lang/crates.io-index)", "ansi_term 0.11.0 (registry+https://github.com/rust-lang/crates.io-index)",
"app_dirs 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)", "app_dirs 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4132,7 +4133,7 @@ dependencies = [ ...@@ -4132,7 +4133,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-client" name = "substrate-client"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)", "derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
"fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)", "fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4160,7 +4161,7 @@ dependencies = [ ...@@ -4160,7 +4161,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-client-db" name = "substrate-client-db"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"hash-db 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)", "hash-db 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"kvdb 0.1.0 (git+https://github.com/paritytech/parity-common?rev=b0317f649ab2c665b7987b8475878fc4d2e1f81d)", "kvdb 0.1.0 (git+https://github.com/paritytech/parity-common?rev=b0317f649ab2c665b7987b8475878fc4d2e1f81d)",
...@@ -4183,7 +4184,7 @@ dependencies = [ ...@@ -4183,7 +4184,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-consensus-babe" name = "substrate-consensus-babe"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"fork-tree 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "fork-tree 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"futures 0.1.28 (registry+https://github.com/rust-lang/crates.io-index)", "futures 0.1.28 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4218,7 +4219,7 @@ dependencies = [ ...@@ -4218,7 +4219,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-consensus-babe-primitives" name = "substrate-consensus-babe-primitives"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"schnorrkel 0.8.4 (registry+https://github.com/rust-lang/crates.io-index)", "schnorrkel 0.8.4 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4232,7 +4233,7 @@ dependencies = [ ...@@ -4232,7 +4233,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-consensus-common" name = "substrate-consensus-common"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)", "derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-preview 0.3.0-alpha.17 (registry+https://github.com/rust-lang/crates.io-index)", "futures-preview 0.3.0-alpha.17 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4251,7 +4252,7 @@ dependencies = [ ...@@ -4251,7 +4252,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-consensus-slots" name = "substrate-consensus-slots"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"futures-preview 0.3.0-alpha.17 (registry+https://github.com/rust-lang/crates.io-index)", "futures-preview 0.3.0-alpha.17 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-timer 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)", "futures-timer 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4269,7 +4270,7 @@ dependencies = [ ...@@ -4269,7 +4270,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-consensus-uncles" name = "substrate-consensus-uncles"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)", "log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"sr-primitives 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sr-primitives 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -4283,7 +4284,7 @@ dependencies = [ ...@@ -4283,7 +4284,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-executor" name = "substrate-executor"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"byteorder 1.3.2 (registry+https://github.com/rust-lang/crates.io-index)", "byteorder 1.3.2 (registry+https://github.com/rust-lang/crates.io-index)",
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)", "derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4307,7 +4308,7 @@ dependencies = [ ...@@ -4307,7 +4308,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-finality-grandpa" name = "substrate-finality-grandpa"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"finality-grandpa 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)", "finality-grandpa 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"fork-tree 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "fork-tree 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -4335,7 +4336,7 @@ dependencies = [ ...@@ -4335,7 +4336,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-finality-grandpa-primitives" name = "substrate-finality-grandpa-primitives"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.98 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4348,7 +4349,7 @@ dependencies = [ ...@@ -4348,7 +4349,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-inherents" name = "substrate-inherents"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)", "parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4359,7 +4360,7 @@ dependencies = [ ...@@ -4359,7 +4360,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-keyring" name = "substrate-keyring"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"lazy_static 1.3.0 (registry+https://github.com/rust-lang/crates.io-index)", "lazy_static 1.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sr-primitives 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sr-primitives 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -4371,7 +4372,7 @@ dependencies = [ ...@@ -4371,7 +4372,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-keystore" name = "substrate-keystore"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"derive_more 0.15.0 (registry+https://github.com/rust-lang/crates.io-index)", "derive_more 0.15.0 (registry+https://github.com/rust-lang/crates.io-index)",
"hex 0.3.2 (registry+https://github.com/rust-lang/crates.io-index)", "hex 0.3.2 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4386,7 +4387,7 @@ dependencies = [ ...@@ -4386,7 +4387,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-network" name = "substrate-network"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)", "bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4427,7 +4428,7 @@ dependencies = [ ...@@ -4427,7 +4428,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-offchain" name = "substrate-offchain"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)", "bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)", "fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -4452,7 +4453,7 @@ dependencies = [ ...@@ -4452,7 +4453,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-offchain-primitives" name = "substrate-offchain-primitives"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [
"sr-primitives 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sr-primitives 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"substrate-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "substrate-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -4461,7 +4462,7 @@ dependencies = [ ...@@ -4461,7 +4462,7 @@ dependencies = [
[[package]] [[package]]
name = "substrate-panic-handler" name = "substrate-panic-handler"
version = "2.0.0" version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#46b63afe5f593f1035bcc0d84e4619826c12881a" source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#3ba0f2a2dbd37c31851a0ff1c1c0c47aa940de90"
dependencies = [ dependencies = [