Commit ef451369 authored by Gavin Wood's avatar Gavin Wood Committed by Bastian Köcher
Browse files

Bump to latest Substrate (#706)

* Updates, but won't build.

* Bump version.

* Fix

* Fix test
parent 5f5b8eac
Pipeline #72711 passed with stages
in 15 minutes and 44 seconds
......@@ -11,11 +11,11 @@ dependencies = [
[[package]]
name = "adder"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"dlmalloc 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.10",
"polkadot-parachain 0.7.11",
"sp-io 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
"tiny-keccak 1.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -25,14 +25,14 @@ dependencies = [
name = "adder-collator"
version = "0.1.0"
dependencies = [
"adder 0.7.10",
"adder 0.7.11",
"ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-collator 0.7.10",
"polkadot-parachain 0.7.10",
"polkadot-primitives 0.7.10",
"polkadot-collator 0.7.11",
"polkadot-parachain 0.7.11",
"polkadot-primitives 0.7.11",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1109,7 +1109,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "fork-tree"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
]
......@@ -1117,7 +1117,7 @@ dependencies = [
[[package]]
name = "frame-executive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1131,7 +1131,7 @@ dependencies = [
[[package]]
name = "frame-metadata"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1142,7 +1142,7 @@ dependencies = [
[[package]]
name = "frame-support"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"bitmask 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-metadata 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1166,7 +1166,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support-procedural-tools 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1177,7 +1177,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support-procedural-tools-derive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1189,7 +1189,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools-derive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
"quote 1.0.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1199,7 +1199,7 @@ dependencies = [
[[package]]
name = "frame-system"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"impl-trait-for-tuples 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1216,7 +1216,7 @@ dependencies = [
[[package]]
name = "frame-system-rpc-runtime-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1529,7 +1529,7 @@ dependencies = [
[[package]]
name = "grafana-data-source"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"async-std 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"chrono 0.4.9 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1582,7 +1582,7 @@ dependencies = [
[[package]]
name = "halt"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
]
......@@ -2905,7 +2905,7 @@ dependencies = [
[[package]]
name = "pallet-authority-discovery"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2923,7 +2923,7 @@ dependencies = [
[[package]]
name = "pallet-authorship"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2940,7 +2940,7 @@ dependencies = [
[[package]]
name = "pallet-babe"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2961,7 +2961,7 @@ dependencies = [
[[package]]
name = "pallet-balances"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2975,7 +2975,7 @@ dependencies = [
[[package]]
name = "pallet-collective"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2991,7 +2991,7 @@ dependencies = [
[[package]]
name = "pallet-democracy"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3006,7 +3006,7 @@ dependencies = [
[[package]]
name = "pallet-elections-phragmen"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3019,7 +3019,7 @@ dependencies = [
[[package]]
name = "pallet-finality-tracker"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3035,7 +3035,7 @@ dependencies = [
[[package]]
name = "pallet-grandpa"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3053,7 +3053,7 @@ dependencies = [
[[package]]
name = "pallet-identity"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"enumflags2 0.6.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3068,7 +3068,7 @@ dependencies = [
[[package]]
name = "pallet-im-online"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3087,7 +3087,7 @@ dependencies = [
[[package]]
name = "pallet-indices"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3104,7 +3104,7 @@ dependencies = [
[[package]]
name = "pallet-membership"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3118,7 +3118,7 @@ dependencies = [
[[package]]
name = "pallet-nicks"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3132,7 +3132,7 @@ dependencies = [
[[package]]
name = "pallet-offences"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3147,7 +3147,7 @@ dependencies = [
[[package]]
name = "pallet-randomness-collective-flip"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3160,7 +3160,7 @@ dependencies = [
[[package]]
name = "pallet-session"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3179,7 +3179,7 @@ dependencies = [
[[package]]
name = "pallet-staking"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3199,7 +3199,7 @@ dependencies = [
[[package]]
name = "pallet-staking-reward-curve"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3210,7 +3210,7 @@ dependencies = [
[[package]]
name = "pallet-timestamp"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3226,7 +3226,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3239,7 +3239,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"jsonrpc-core 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"jsonrpc-core-client 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3256,7 +3256,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc-runtime-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3269,7 +3269,7 @@ dependencies = [
[[package]]
name = "pallet-treasury"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3280,6 +3280,21 @@ dependencies = [
"sp-std 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
]
[[package]]
name = "pallet-utility"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-io 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-runtime 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-std 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
]
[[package]]
name = "parity-bytes"
version = "0.1.1"
......@@ -3565,18 +3580,18 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "polkadot"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.10",
"polkadot-service 0.7.10",
"polkadot-cli 0.7.11",
"polkadot-service 0.7.11",
"vergen 3.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "polkadot-availability-store"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3587,9 +3602,9 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-erasure-coding 0.7.10",
"polkadot-primitives 0.7.10",
"polkadot-runtime 0.7.10",
"polkadot-erasure-coding 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-runtime 0.7.11",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-keystore 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3604,7 +3619,7 @@ dependencies = [
[[package]]
name = "polkadot-cli"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"console_error_panic_hook 0.1.6 (registry+https://github.com/rust-lang/crates.io-index)",
"console_log 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3614,7 +3629,7 @@ dependencies = [
"kvdb-web 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
"libp2p 0.13.1 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-service 0.7.10",
"polkadot-service 0.7.11",
"rand 0.6.5 (registry+https://github.com/rust-lang/crates.io-index)",
"rand 0.7.2 (registry+https://github.com/rust-lang/crates.io-index)",
"sc-cli 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3628,17 +3643,17 @@ dependencies = [
[[package]]
name = "polkadot-collator"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-timer 1.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.10",
"polkadot-network 0.7.10",
"polkadot-primitives 0.7.10",
"polkadot-runtime 0.7.10",
"polkadot-service 0.7.10",
"polkadot-validation 0.7.10",
"polkadot-cli 0.7.11",
"polkadot-network 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-runtime 0.7.11",
"polkadot-service 0.7.11",
"polkadot-validation 0.7.11",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network 0.8.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3650,11 +3665,11 @@ dependencies = [
[[package]]
name = "polkadot-erasure-coding"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"derive_more 0.15.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.10",
"polkadot-primitives 0.7.11",
"reed-solomon-erasure 4.0.0 (git+https://github.com/paritytech/reed-solomon-erasure)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-trie 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3662,15 +3677,15 @@ dependencies = [
[[package]]
name = "polkadot-executor"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"polkadot-runtime 0.7.10",
"polkadot-runtime 0.7.11",
"sc-executor 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
]
[[package]]
name = "polkadot-network"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"arrayvec 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3678,10 +3693,10 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.10",
"polkadot-erasure-coding 0.7.10",
"polkadot-primitives 0.7.10",
"polkadot-validation 0.7.10",
"polkadot-availability-store 0.7.11",
"polkadot-erasure-coding 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-validation 0.7.11",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network 0.8.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network-gossip 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3694,11 +3709,11 @@ dependencies = [
[[package]]
name = "polkadot-parachain"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"adder 0.7.10",
"adder 0.7.11",
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
"halt 0.7.10",
"halt 0.7.11",
"lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3713,12 +3728,12 @@ dependencies = [
[[package]]
name = "polkadot-primitives"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.10",
"polkadot-parachain 0.7.11",
"pretty_assertions 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3733,12 +3748,12 @@ dependencies = [
[[package]]
name = "polkadot-rpc"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"jsonrpc-core 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-transaction-payment-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"polkadot-primitives 0.7.10",
"polkadot-runtime 0.7.10",
"polkadot-primitives 0.7.11",
"polkadot-runtime 0.7.11",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-runtime 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3748,7 +3763,7 @@ dependencies = [
[[package]]
name = "polkadot-runtime"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-executive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3781,9 +3796,10 @@ dependencies = [
"pallet-transaction-payment 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-transaction-payment-rpc-runtime-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-treasury 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-utility 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.10",
"polkadot-primitives 0.7.10",
"polkadot-parachain 0.7.11",
"polkadot-primitives 0.7.11",
"rustc-hex 2.0.1 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3813,7 +3829,7 @@ dependencies = [
[[package]]
name = "polkadot-service"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3824,13 +3840,13 @@ dependencies = [
"pallet-im-online 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-staking 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.10",
"polkadot-executor 0.7.10",
"polkadot-network 0.7.10",
"polkadot-primitives 0.7.10",
"polkadot-rpc 0.7.10",
"polkadot-runtime 0.7.10",
"polkadot-validation 0.7.10",
"polkadot-availability-store 0.7.11",
"polkadot-executor 0.7.11",
"polkadot-network 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-rpc 0.7.11",
"polkadot-runtime 0.7.11",
"polkadot-validation 0.7.11",
"sc-authority-discovery 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3858,16 +3874,16 @@ dependencies = [
[[package]]
name = "polkadot-statement-table"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.10",
"polkadot-primitives 0.7.11",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
]
[[package]]
name = "polkadot-validation"
version = "0.7.10"
version = "0.7.11"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3878,12 +3894,12 @@ dependencies = [
"pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.10",
"polkadot-erasure-coding 0.7.10",
"polkadot-parachain 0.7.10",
"polkadot-primitives 0.7.10",
"polkadot-runtime 0.7.10",
"polkadot-statement-table 0.7.10",
"polkadot-availability-store 0.7.11",
"polkadot-erasure-coding 0.7.11",
"polkadot-parachain 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-runtime 0.7.11",
"polkadot-statement-table 0.7.11",
"sc-block-builder 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-finality-grandpa 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4408,7 +4424,7 @@ dependencies = [
[[package]]
name = "sc-authority-discovery"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4432,7 +4448,7 @@ dependencies = [
[[package]]
name = "sc-block-builder"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4446,7 +4462,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"impl-trait-for-tuples 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"sc-chain-spec-derive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4461,7 +4477,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec-derive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4472,7 +4488,7 @@ dependencies = [
[[package]]
name = "sc-cli"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"ansi_term 0.12.1 (registry+https://github.com/rust-lang/crates.io-index)",
"app_dirs 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4507,7 +4523,7 @@ dependencies = [
[[package]]
name = "sc-client"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4540,7 +4556,7 @@ dependencies = [
[[package]]
name = "sc-client-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#ab217bf3513a8f6c287b33dedc5bce0bd9ec863b"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#e3962b6869640308016b1a8a50845a78bda391ce"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4571,7 +4587,7 @@ dependencies = [
[[package]]
name = "sc-client-db"