Unverified Commit e9866d55 authored by Andronik Ordian's avatar Andronik Ordian Committed by GitHub
Browse files

upgrade a few dependencies (companion for 7831) (#2205)

* upgrade a few dependencies

* "Update Substrate"

Co-authored-by: parity-processbot <>
parent 51d55338
Pipeline #119092 canceled with stages
in 9 seconds
This diff is collapsed.
...@@ -7,8 +7,8 @@ edition = "2018" ...@@ -7,8 +7,8 @@ edition = "2018"
[dependencies] [dependencies]
futures = "0.3.8" futures = "0.3.8"
futures-timer = "3.0.2" futures-timer = "3.0.2"
kvdb = "0.7.0" kvdb = "0.8.0"
kvdb-rocksdb = "0.9.1" kvdb-rocksdb = "0.10.0"
thiserror = "1.0.23" thiserror = "1.0.23"
tracing = "0.1.22" tracing = "0.1.22"
tracing-futures = "0.2.4" tracing-futures = "0.2.4"
...@@ -26,7 +26,7 @@ sc-service = { git = "https://github.com/paritytech/substrate", branch = "master ...@@ -26,7 +26,7 @@ sc-service = { git = "https://github.com/paritytech/substrate", branch = "master
log = "0.4.11" log = "0.4.11"
env_logger = "0.8.2" env_logger = "0.8.2"
assert_matches = "1.4.0" assert_matches = "1.4.0"
kvdb-memorydb = "0.7.0" kvdb-memorydb = "0.8.0"
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" } sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
polkadot-node-subsystem-util = { path = "../../subsystem-util" } polkadot-node-subsystem-util = { path = "../../subsystem-util" }
......
...@@ -10,7 +10,7 @@ futures01 = { package = "futures", version = "0.1.29" } ...@@ -10,7 +10,7 @@ futures01 = { package = "futures", version = "0.1.29" }
hex = "0.4.2" hex = "0.4.2"
tracing = "0.1.22" tracing = "0.1.22"
tracing-futures = "0.2.4" tracing-futures = "0.2.4"
rand = "0.7.3" rand = "0.8.1"
tempfile = "3.1.0" tempfile = "3.1.0"
# Polkadot dependencies # Polkadot dependencies
......
...@@ -23,7 +23,7 @@ serde = { version = "1.0.117", default-features = false, features = [ "derive" ] ...@@ -23,7 +23,7 @@ serde = { version = "1.0.117", default-features = false, features = [ "derive" ]
sp-externalities = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true } sp-externalities = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
sc-executor = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true } sc-executor = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
sp-io = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true } sp-io = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
parking_lot = { version = "0.11.0", optional = true } parking_lot = { version = "0.11.1", optional = true }
log = { version = "0.4.11", optional = true } log = { version = "0.4.11", optional = true }
futures = { version = "0.3.8", optional = true } futures = { version = "0.3.8", optional = true }
......
...@@ -39,8 +39,8 @@ xcm-executor = { package = "xcm-executor", path = "../../xcm/xcm-executor", defa ...@@ -39,8 +39,8 @@ xcm-executor = { package = "xcm-executor", path = "../../xcm/xcm-executor", defa
primitives = { package = "polkadot-primitives", path = "../../primitives", default-features = false } primitives = { package = "polkadot-primitives", path = "../../primitives", default-features = false }
libsecp256k1 = { version = "0.3.5", default-features = false, optional = true } libsecp256k1 = { version = "0.3.5", default-features = false, optional = true }
rand = { version = "0.7.3", default-features = false } rand = { version = "0.8.1", default-features = false }
rand_chacha = { version = "0.2.2", default-features = false } rand_chacha = { version = "0.3.0", default-features = false }
[dev-dependencies] [dev-dependencies]
futures = "0.3.8" futures = "0.3.8"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment