Unverified Commit d4f0a74b authored by Gavin Wood's avatar Gavin Wood Committed by GitHub
Browse files

Companion for #5412 (#942)

* Fixes for democracy using Scheduler

* Revert branch change
parent 5e0170c2
Pipeline #85855 canceled with stages
...@@ -12,7 +12,7 @@ dependencies = [ ...@@ -12,7 +12,7 @@ dependencies = [
[[package]] [[package]]
name = "adder" name = "adder"
version = "0.7.28" version = "0.7.29-pre1"
dependencies = [ dependencies = [
"dlmalloc", "dlmalloc",
"parity-scale-codec", "parity-scale-codec",
...@@ -127,9 +127,9 @@ dependencies = [ ...@@ -127,9 +127,9 @@ dependencies = [
[[package]] [[package]]
name = "anyhow" name = "anyhow"
version = "1.0.28" version = "1.0.27"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "d9a60d744a80c30fcb657dfe2c1b22bcb3e814c1a1e3674f32bf5820b570fbff" checksum = "013a6e0a2cbe3d20f9c60b65458f7a7f7a5e636c5d0f45a5a6aee5d4b1f01785"
[[package]] [[package]]
name = "app_dirs" name = "app_dirs"
...@@ -200,16 +200,15 @@ dependencies = [ ...@@ -200,16 +200,15 @@ dependencies = [
[[package]] [[package]]
name = "assert_cmd" name = "assert_cmd"
version = "0.12.2" version = "0.12.1"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "936fcf2c692b37c696cd0002c57752b2d9478402450c9ca4a463f6afae16d6f5" checksum = "35ad62275a8bda1c2c9a9303aea121eb04204272d3be0735d5dc1f49eb9ff9a9"
dependencies = [ dependencies = [
"doc-comment", "doc-comment",
"escargot", "escargot",
"predicates", "predicates",
"predicates-core", "predicates-core",
"predicates-tree", "predicates-tree",
"wait-timeout",
] ]
[[package]] [[package]]
...@@ -358,7 +357,7 @@ dependencies = [ ...@@ -358,7 +357,7 @@ dependencies = [
"lazycell", "lazycell",
"log 0.4.8", "log 0.4.8",
"peeking_take_while", "peeking_take_while",
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"regex", "regex",
"rustc-hash", "rustc-hash",
...@@ -581,9 +580,9 @@ dependencies = [ ...@@ -581,9 +580,9 @@ dependencies = [
[[package]] [[package]]
name = "clang-sys" name = "clang-sys"
version = "0.29.3" version = "0.29.2"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "fe6837df1d5cba2397b835c8530f51723267e16abbf83892e9e5af4f0e5dd10a" checksum = "f92986241798376849e1a007827041fed9bb36195822c2049d18e174420e0534"
dependencies = [ dependencies = [
"glob", "glob",
"libc", "libc",
...@@ -934,11 +933,11 @@ dependencies = [ ...@@ -934,11 +933,11 @@ dependencies = [
[[package]] [[package]]
name = "derive_more" name = "derive_more"
version = "0.99.5" version = "0.99.3"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e2323f3f47db9a0e77ce7a300605d8d2098597fc451ed1a97bb1f6411bb550a7" checksum = "a806e96c59a76a5ba6e18735b6cf833344671e61e7863f2edb5c518ea2cac95c"
dependencies = [ dependencies = [
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"syn 1.0.17", "syn 1.0.17",
] ]
...@@ -1047,7 +1046,7 @@ version = "0.6.2" ...@@ -1047,7 +1046,7 @@ version = "0.6.2"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "ecf634c5213044b8d54a46dd282cf5dd1f86bb5cb53e92c409cb4680a7fb9894" checksum = "ecf634c5213044b8d54a46dd282cf5dd1f86bb5cb53e92c409cb4680a7fb9894"
dependencies = [ dependencies = [
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"syn 1.0.17", "syn 1.0.17",
] ]
...@@ -1086,18 +1085,18 @@ checksum = "516aa8d7a71cb00a1c4146f0798549b93d083d4f189b3ced8f3de6b8f11ee6c4" ...@@ -1086,18 +1085,18 @@ checksum = "516aa8d7a71cb00a1c4146f0798549b93d083d4f189b3ced8f3de6b8f11ee6c4"
[[package]] [[package]]
name = "erased-serde" name = "erased-serde"
version = "0.3.11" version = "0.3.10"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "d88b6d1705e16a4d62e05ea61cc0496c2bd190f4fa8e5c1f11ce747be6bcf3d1" checksum = "cd7d80305c9bd8cd78e3c753eb9fb110f83621e5211f1a3afffcc812b104daf9"
dependencies = [ dependencies = [
"serde", "serde",
] ]
[[package]] [[package]]
name = "errno" name = "errno"
version = "0.2.5" version = "0.2.4"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "b480f641ccf0faf324e20c1d3e53d81b7484c698b42ea677f6907ae4db195371" checksum = "c2a071601ed01b988f896ab14b95e67335d1eeb50190932a1320f7fe3cadc84e"
dependencies = [ dependencies = [
"errno-dragonfly", "errno-dragonfly",
"libc", "libc",
...@@ -1194,7 +1193,7 @@ version = "0.1.7" ...@@ -1194,7 +1193,7 @@ version = "0.1.7"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "030a733c8287d6213886dd487564ff5c8f6aae10278b3588ed177f9d18f8d231" checksum = "030a733c8287d6213886dd487564ff5c8f6aae10278b3588ed177f9d18f8d231"
dependencies = [ dependencies = [
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"syn 1.0.17", "syn 1.0.17",
"synstructure", "synstructure",
...@@ -1285,7 +1284,7 @@ checksum = "2fad85553e09a6f881f739c29f0b00b0f01357c743266d478b68951ce23285f3" ...@@ -1285,7 +1284,7 @@ checksum = "2fad85553e09a6f881f739c29f0b00b0f01357c743266d478b68951ce23285f3"
[[package]] [[package]]
name = "fork-tree" name = "fork-tree"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
] ]
...@@ -1293,7 +1292,7 @@ dependencies = [ ...@@ -1293,7 +1292,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-benchmarking" name = "frame-benchmarking"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -1309,7 +1308,7 @@ dependencies = [ ...@@ -1309,7 +1308,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-benchmarking-cli" name = "frame-benchmarking-cli"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-benchmarking", "frame-benchmarking",
"parity-scale-codec", "parity-scale-codec",
...@@ -1328,7 +1327,7 @@ dependencies = [ ...@@ -1328,7 +1327,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-executive" name = "frame-executive"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -1341,7 +1340,7 @@ dependencies = [ ...@@ -1341,7 +1340,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-metadata" name = "frame-metadata"
version = "11.0.0-alpha.5" version = "11.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"serde", "serde",
...@@ -1352,7 +1351,7 @@ dependencies = [ ...@@ -1352,7 +1351,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-support" name = "frame-support"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"bitmask", "bitmask",
"frame-metadata", "frame-metadata",
...@@ -1376,10 +1375,10 @@ dependencies = [ ...@@ -1376,10 +1375,10 @@ dependencies = [
[[package]] [[package]]
name = "frame-support-procedural" name = "frame-support-procedural"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support-procedural-tools", "frame-support-procedural-tools",
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"syn 1.0.17", "syn 1.0.17",
] ]
...@@ -1387,11 +1386,11 @@ dependencies = [ ...@@ -1387,11 +1386,11 @@ dependencies = [
[[package]] [[package]]
name = "frame-support-procedural-tools" name = "frame-support-procedural-tools"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support-procedural-tools-derive", "frame-support-procedural-tools-derive",
"proc-macro-crate", "proc-macro-crate",
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"syn 1.0.17", "syn 1.0.17",
] ]
...@@ -1399,9 +1398,9 @@ dependencies = [ ...@@ -1399,9 +1398,9 @@ dependencies = [
[[package]] [[package]]
name = "frame-support-procedural-tools-derive" name = "frame-support-procedural-tools-derive"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"syn 1.0.17", "syn 1.0.17",
] ]
...@@ -1409,7 +1408,7 @@ dependencies = [ ...@@ -1409,7 +1408,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-system" name = "frame-system"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"impl-trait-for-tuples", "impl-trait-for-tuples",
...@@ -1425,7 +1424,7 @@ dependencies = [ ...@@ -1425,7 +1424,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-system-rpc-runtime-api" name = "frame-system-rpc-runtime-api"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"sp-api", "sp-api",
...@@ -1559,7 +1558,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index" ...@@ -1559,7 +1558,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "9a5081aa3de1f7542a794a397cde100ed903b0630152d0973479018fd85423a7" checksum = "9a5081aa3de1f7542a794a397cde100ed903b0630152d0973479018fd85423a7"
dependencies = [ dependencies = [
"proc-macro-hack", "proc-macro-hack",
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"syn 1.0.17", "syn 1.0.17",
] ]
...@@ -1751,9 +1750,9 @@ dependencies = [ ...@@ -1751,9 +1750,9 @@ dependencies = [
[[package]] [[package]]
name = "h2" name = "h2"
version = "0.2.4" version = "0.2.3"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "377038bf3c89d18d6ca1431e7a5027194fbd724ca10592b9487ede5e8e144f42" checksum = "7938e6aa2a31df4e21f224dc84704bd31c089a6d1355c535b03667371cccc843"
dependencies = [ dependencies = [
"bytes 0.5.4", "bytes 0.5.4",
"fnv", "fnv",
...@@ -1770,7 +1769,7 @@ dependencies = [ ...@@ -1770,7 +1769,7 @@ dependencies = [
[[package]] [[package]]
name = "halt" name = "halt"
version = "0.7.28" version = "0.7.29-pre1"
dependencies = [ dependencies = [
"substrate-wasm-builder-runner 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)", "substrate-wasm-builder-runner 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
] ]
...@@ -1811,9 +1810,9 @@ dependencies = [ ...@@ -1811,9 +1810,9 @@ dependencies = [
[[package]] [[package]]
name = "hermit-abi" name = "hermit-abi"
version = "0.1.10" version = "0.1.8"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "725cf19794cf90aa94e65050cb4191ff5d8fa87a498383774c47b332e3af952e" checksum = "1010591b26bbfe835e9faeabeb11866061cc7dcebffd56ad7d0942d0e61aefd8"
dependencies = [ dependencies = [
"libc", "libc",
] ]
...@@ -1963,7 +1962,7 @@ dependencies = [ ...@@ -1963,7 +1962,7 @@ dependencies = [
"futures-channel", "futures-channel",
"futures-core", "futures-core",
"futures-util", "futures-util",
"h2 0.2.4", "h2 0.2.3",
"http 0.2.1", "http 0.2.1",
"http-body 0.3.1", "http-body 0.3.1",
"httparse", "httparse",
...@@ -2059,7 +2058,7 @@ version = "0.1.3" ...@@ -2059,7 +2058,7 @@ version = "0.1.3"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "7ef5550a42e3740a0e71f909d4c861056a284060af885ae7aa6242820f920d9d" checksum = "7ef5550a42e3740a0e71f909d4c861056a284060af885ae7aa6242820f920d9d"
dependencies = [ dependencies = [
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"syn 1.0.17", "syn 1.0.17",
] ]
...@@ -2209,7 +2208,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index" ...@@ -2209,7 +2208,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "8609af8f63b626e8e211f52441fcdb6ec54f1a446606b10d5c89ae9bf8a20058" checksum = "8609af8f63b626e8e211f52441fcdb6ec54f1a446606b10d5c89ae9bf8a20058"
dependencies = [ dependencies = [
"proc-macro-crate", "proc-macro-crate",
"proc-macro2 1.0.10", "proc-macro2 1.0.9",
"quote 1.0.3", "quote 1.0.3",
"syn 1.0.17", "syn 1.0.17",
] ]
...@@ -2289,7 +2288,7 @@ dependencies = [ ...@@ -2289,7 +2288,7 @@ dependencies = [
[[package]] [[package]]
name = "kusama-runtime" name = "kusama-runtime"
version = "0.7.28" version = "0.7.29-pre1"
dependencies = [ dependencies = [
"bitvec", "bitvec",
"frame-benchmarking", "frame-benchmarking",
...@@ -2317,6 +2316,7 @@ dependencies = [ ...@@ -2317,6 +2316,7 @@ dependencies = [
"pallet-offences", "pallet-offences",
"pallet-randomness-collective-flip", "pallet-randomness-collective-flip",
"pallet-recovery", "pallet-recovery",
"pallet-scheduler",
"pallet-session", "pallet-session",
"pallet-society", "pallet-society",
"pallet-staking", "pallet-staking",
...@@ -3132,9 +3132,9 @@ checksum = "0debeb9fcf88823ea64d64e4a815ab1643f33127d995978e099942ce38f25238" ...@@ -3132,9 +3132,9 @@ checksum = "0debeb9fcf88823ea64d64e4a815ab1643f33127d995978e099942ce38f25238"
[[package]] [[package]]
name = "multimap" name = "multimap"
version = "0.8.1" version = "0.8.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "d8883adfde9756c1d30b0f519c9b8c502a94b41ac62f696453c37c7fc0a958ce" checksum = "a97fbd5d00e0e37bfb10f433af8f5aaf631e739368dc9fc28286ca81ca4948dc"
[[package]] [[package]]
name = "multistream-select" name = "multistream-select"
...@@ -3374,7 +3374,7 @@ dependencies = [ ...@@ -3374,7 +3374,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-authority-discovery" name = "pallet-authority-discovery"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3392,7 +3392,7 @@ dependencies = [ ...@@ -3392,7 +3392,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-authorship" name = "pallet-authorship"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3409,7 +3409,7 @@ dependencies = [ ...@@ -3409,7 +3409,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-babe" name = "pallet-babe"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3430,7 +3430,7 @@ dependencies = [ ...@@ -3430,7 +3430,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-balances" name = "pallet-balances"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-benchmarking", "frame-benchmarking",
"frame-support", "frame-support",
...@@ -3445,7 +3445,7 @@ dependencies = [ ...@@ -3445,7 +3445,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-collective" name = "pallet-collective"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3460,7 +3460,7 @@ dependencies = [ ...@@ -3460,7 +3460,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-democracy" name = "pallet-democracy"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-benchmarking", "frame-benchmarking",
"frame-support", "frame-support",
...@@ -3475,7 +3475,7 @@ dependencies = [ ...@@ -3475,7 +3475,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-elections-phragmen" name = "pallet-elections-phragmen"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3489,7 +3489,7 @@ dependencies = [ ...@@ -3489,7 +3489,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-finality-tracker" name = "pallet-finality-tracker"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3505,7 +3505,7 @@ dependencies = [ ...@@ -3505,7 +3505,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-grandpa" name = "pallet-grandpa"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3523,7 +3523,7 @@ dependencies = [ ...@@ -3523,7 +3523,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-identity" name = "pallet-identity"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"enumflags2", "enumflags2",
"frame-benchmarking", "frame-benchmarking",
...@@ -3539,7 +3539,7 @@ dependencies = [ ...@@ -3539,7 +3539,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-im-online" name = "pallet-im-online"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3558,7 +3558,7 @@ dependencies = [ ...@@ -3558,7 +3558,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-indices" name = "pallet-indices"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3574,7 +3574,7 @@ dependencies = [ ...@@ -3574,7 +3574,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-membership" name = "pallet-membership"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3588,7 +3588,7 @@ dependencies = [ ...@@ -3588,7 +3588,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-nicks" name = "pallet-nicks"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3602,7 +3602,7 @@ dependencies = [ ...@@ -3602,7 +3602,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-offences" name = "pallet-offences"
version = "2.0.0-alpha.5" version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#d477017fb655f71de6c952b7eb085866bd8f6f7f" source = "git+https://github.com/paritytech/substrate#2449d21ca2998325b95671236dd9911c3534718d"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -3617,7 +3617,7 @@ dependencies = [ ...@@ -3617,7 +3617,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-randomness-collective-flip" nam