Commit d18b07d4 authored by Cecile Tonglet's avatar Cecile Tonglet
Browse files

Merge commit e9866d55 (no conflict)

parents 7ab456b1 e9866d55
Pipeline #119106 failed with stages
in 6 minutes and 14 seconds
......@@ -244,19 +244,16 @@ publish-docker:
( echo "no docker credentials provided"; exit 1 )
- cd ./artifacts
- buildah bud
--squash
--format=docker
--build-arg VCS_REF="${CI_COMMIT_SHA}"
--build-arg BUILD_DATE="$(date -u '+%Y-%m-%dT%H:%M:%SZ')"
--tag "$IMAGE_NAME:$VERSION"
--tag "$IMAGE_NAME:$EXTRATAG" .
--format=docker
--build-arg VCS_REF="${CI_COMMIT_SHA}"
--build-arg BUILD_DATE="$(date -u '+%Y-%m-%dT%H:%M:%SZ')"
--tag "$IMAGE_NAME:$VERSION"
--tag "$IMAGE_NAME:$EXTRATAG" .
- echo "$Docker_Hub_Pass_Parity" |
buildah login --username "$Docker_Hub_User_Parity" --password-stdin docker.io
- buildah info
- buildah push
--format=v2s2
"$IMAGE_NAME:$VERSION"
"$IMAGE_NAME:$EXTRATAG"
- buildah push --format=v2s2 "$IMAGE_NAME:$VERSION"
- buildah push --format=v2s2 "$IMAGE_NAME:$EXTRATAG"
after_script:
- buildah logout "$IMAGE_NAME"
# only VERSION information is needed for the deployment
......
This diff is collapsed.
......@@ -7,8 +7,8 @@ edition = "2018"
[dependencies]
futures = "0.3.8"
futures-timer = "3.0.2"
kvdb = "0.7.0"
kvdb-rocksdb = "0.9.1"
kvdb = "0.8.0"
kvdb-rocksdb = "0.10.0"
thiserror = "1.0.23"
tracing = "0.1.22"
tracing-futures = "0.2.4"
......@@ -26,7 +26,7 @@ sc-service = { git = "https://github.com/paritytech/substrate", branch = "master
log = "0.4.11"
env_logger = "0.8.2"
assert_matches = "1.4.0"
kvdb-memorydb = "0.7.0"
kvdb-memorydb = "0.8.0"
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
polkadot-node-subsystem-util = { path = "../../subsystem-util" }
......
......@@ -10,7 +10,7 @@ futures01 = { package = "futures", version = "0.1.29" }
hex = "0.4.2"
tracing = "0.1.22"
tracing-futures = "0.2.4"
rand = "0.7.3"
rand = "0.8.1"
tempfile = "3.1.0"
# Polkadot dependencies
......
......@@ -23,7 +23,7 @@ serde = { version = "1.0.117", default-features = false, features = [ "derive" ]
sp-externalities = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
sc-executor = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
sp-io = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
parking_lot = { version = "0.11.0", optional = true }
parking_lot = { version = "0.11.1", optional = true }
log = { version = "0.4.11", optional = true }
futures = { version = "0.3.8", optional = true }
......
......@@ -14,7 +14,7 @@ sp-keystore = { git = "https://github.com/paritytech/substrate", branch = "maste
sp-api = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-version = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-std = { package = "sp-std", git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-io = { git = "https://github.com/paritytech/substrate", default-features = false, branch = "master" }
sp-io = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-staking = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-arithmetic = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-authority-discovery = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
......
......@@ -39,8 +39,8 @@ xcm-executor = { package = "xcm-executor", path = "../../xcm/xcm-executor", defa
primitives = { package = "polkadot-primitives", path = "../../primitives", default-features = false }
libsecp256k1 = { version = "0.3.5", default-features = false, optional = true }
rand = { version = "0.7.3", default-features = false }
rand_chacha = { version = "0.2.2", default-features = false }
rand = { version = "0.8.1", default-features = false }
rand_chacha = { version = "0.3.0", default-features = false }
[dev-dependencies]
futures = "0.3.8"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment