Unverified Commit bea3def2 authored by dependabot[bot]'s avatar dependabot[bot] Committed by GitHub
Browse files

Bump structopt from 0.3.23 to 0.3.25 (#4098)

Bumps [structopt](https://github.com/TeXitoi/structopt) from 0.3.23 to 0.3.25.
- [Release notes](https://github.com/TeXitoi/structopt/releases)
- [Changelog](https://github.com/TeXitoi/structopt/blob/master/CHANGELOG.md)
- [Commits](https://github.com/TeXitoi/structopt/compare/v0.3.23...v0.3.25

)

---
updated-dependencies:
- dependency-name: structopt
  dependency-type: direct:production
  update-type: version-update:semver-patch
...

Signed-off-by: default avatardependabot[bot] <support@github.com>

Co-authored-by: default avatardependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
parent b72dd980
Pipeline #162859 passed with stages
in 42 minutes and 35 seconds
...@@ -10168,9 +10168,9 @@ checksum = "8ea5119cdb4c55b55d432abb513a0429384878c15dde60cc77b1c99de1a95a6a" ...@@ -10168,9 +10168,9 @@ checksum = "8ea5119cdb4c55b55d432abb513a0429384878c15dde60cc77b1c99de1a95a6a"
[[package]] [[package]]
name = "structopt" name = "structopt"
version = "0.3.23" version = "0.3.25"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "bf9d950ef167e25e0bdb073cf1d68e9ad2795ac826f2f3f59647817cf23c0bfa" checksum = "40b9788f4202aa75c240ecc9c15c65185e6a39ccdeb0fd5d008b98825464c87c"
dependencies = [ dependencies = [
"clap", "clap",
"lazy_static", "lazy_static",
...@@ -10179,9 +10179,9 @@ dependencies = [ ...@@ -10179,9 +10179,9 @@ dependencies = [
[[package]] [[package]]
name = "structopt-derive" name = "structopt-derive"
version = "0.4.16" version = "0.4.18"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "134d838a2c9943ac3125cf6df165eda53493451b719f3255b2a26b85f772d0ba" checksum = "dcb5ae327f9cc13b68763b5749770cb9e048a99bd9dfdfa58d0cf05d5f64afe0"
dependencies = [ dependencies = [
"heck", "heck",
"proc-macro-error 1.0.4", "proc-macro-error 1.0.4",
......
...@@ -16,7 +16,7 @@ crate-type = ["cdylib", "rlib"] ...@@ -16,7 +16,7 @@ crate-type = ["cdylib", "rlib"]
[dependencies] [dependencies]
log = "0.4.13" log = "0.4.13"
thiserror = "1.0.30" thiserror = "1.0.30"
structopt = { version = "0.3.23", optional = true } structopt = { version = "0.3.25", optional = true }
futures = "0.3.17" futures = "0.3.17"
service = { package = "polkadot-service", path = "../node/service", default-features = false, optional = true } service = { package = "polkadot-service", path = "../node/service", default-features = false, optional = true }
......
...@@ -25,7 +25,7 @@ polkadot-node-core-pvf = { path = "../core/pvf" } ...@@ -25,7 +25,7 @@ polkadot-node-core-pvf = { path = "../core/pvf" }
parity-util-mem = { version = "0.10.0", default-features = false, features = ["jemalloc-global"] } parity-util-mem = { version = "0.10.0", default-features = false, features = ["jemalloc-global"] }
color-eyre = { version = "0.5.11", default-features = false } color-eyre = { version = "0.5.11", default-features = false }
assert_matches = "1.5" assert_matches = "1.5"
structopt = "0.3.23" structopt = "0.3.25"
async-trait = "0.1.51" async-trait = "0.1.51"
[dev-dependencies] [dev-dependencies]
......
...@@ -33,7 +33,7 @@ polkadot-runtime = { path = "../../../../runtime/polkadot" } ...@@ -33,7 +33,7 @@ polkadot-runtime = { path = "../../../../runtime/polkadot" }
polkadot-runtime-common = { path = "../../../../runtime/common" } polkadot-runtime-common = { path = "../../../../runtime/common" }
codec = { package = "parity-scale-codec", version = "2.0.0" } codec = { package = "parity-scale-codec", version = "2.0.0" }
structopt = "0.3.23" structopt = "0.3.25"
[dev-dependencies] [dev-dependencies]
log = "0.4.14" log = "0.4.14"
...@@ -18,7 +18,7 @@ parity-scale-codec = { version = "2.3.1", default-features = false, features = [ ...@@ -18,7 +18,7 @@ parity-scale-codec = { version = "2.3.1", default-features = false, features = [
futures = "0.3.17" futures = "0.3.17"
futures-timer = "3.0.2" futures-timer = "3.0.2"
log = "0.4.13" log = "0.4.13"
structopt = "0.3.23" structopt = "0.3.25"
test-parachain-adder = { path = ".." } test-parachain-adder = { path = ".." }
polkadot-primitives = { path = "../../../../primitives" } polkadot-primitives = { path = "../../../../primitives" }
......
...@@ -21,4 +21,4 @@ frame-support = { git = "https://github.com/paritytech/substrate", branch = "mas ...@@ -21,4 +21,4 @@ frame-support = { git = "https://github.com/paritytech/substrate", branch = "mas
remote-externalities = { git = "https://github.com/paritytech/substrate", branch = "master" } remote-externalities = { git = "https://github.com/paritytech/substrate", branch = "master" }
tokio = { version = "1", features = ["macros"] } tokio = { version = "1", features = ["macros"] }
log = { version = "0.4.14" } log = { version = "0.4.14" }
structopt = {version = "0.3.23" } structopt = {version = "0.3.25" }
...@@ -9,7 +9,7 @@ codec = { package = "parity-scale-codec", version = "2.0.0" } ...@@ -9,7 +9,7 @@ codec = { package = "parity-scale-codec", version = "2.0.0" }
tokio = { version = "1.12", features = ["macros"] } tokio = { version = "1.12", features = ["macros"] }
log = "0.4.11" log = "0.4.11"
env_logger = "0.9.0" env_logger = "0.9.0"
structopt = "0.3.23" structopt = "0.3.25"
jsonrpsee-ws-client = { version = "0.3.1", default-features = false, features = ["tokio1"] } jsonrpsee-ws-client = { version = "0.3.1", default-features = false, features = ["tokio1"] }
serde_json = "1.0" serde_json = "1.0"
serde = "1.0.130" serde = "1.0.130"
......
...@@ -7,7 +7,7 @@ edition = "2018" ...@@ -7,7 +7,7 @@ edition = "2018"
[dependencies] [dependencies]
generate-bags = { git = "https://github.com/paritytech/substrate", branch = "master" } generate-bags = { git = "https://github.com/paritytech/substrate", branch = "master" }
sp-io = { git = "https://github.com/paritytech/substrate", branch = "master" } sp-io = { git = "https://github.com/paritytech/substrate", branch = "master" }
structopt = "0.3.21" structopt = "0.3.25"
westend-runtime = { path = "../../runtime/westend" } westend-runtime = { path = "../../runtime/westend" }
kusama-runtime = { path = "../../runtime/kusama" } kusama-runtime = { path = "../../runtime/kusama" }
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment