Unverified Commit bc19d952 authored by Gavin Wood's avatar Gavin Wood Committed by GitHub
Browse files

Bump version (#729)

parent 255697f2
Pipeline #73568 passed with stages
in 27 minutes and 44 seconds
......@@ -11,11 +11,11 @@ dependencies = [
[[package]]
name = "adder"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"dlmalloc 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.11",
"polkadot-parachain 0.7.12",
"sp-io 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
"tiny-keccak 1.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -25,14 +25,14 @@ dependencies = [
name = "adder-collator"
version = "0.1.0"
dependencies = [
"adder 0.7.11",
"adder 0.7.12",
"ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-collator 0.7.11",
"polkadot-parachain 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-collator 0.7.12",
"polkadot-parachain 0.7.12",
"polkadot-primitives 0.7.12",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1582,7 +1582,7 @@ dependencies = [
[[package]]
name = "halt"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
]
......@@ -2031,7 +2031,7 @@ dependencies = [
[[package]]
name = "kusama-runtime"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-executive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2066,9 +2066,9 @@ dependencies = [
"pallet-treasury 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-utility 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-runtime-common 0.7.11",
"polkadot-parachain 0.7.12",
"polkadot-primitives 0.7.12",
"polkadot-runtime-common 0.7.12",
"rustc-hex 2.0.1 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3666,18 +3666,18 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "polkadot"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.11",
"polkadot-service 0.7.11",
"polkadot-cli 0.7.12",
"polkadot-service 0.7.12",
"vergen 3.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "polkadot-availability-store"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3688,8 +3688,8 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-erasure-coding 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-erasure-coding 0.7.12",
"polkadot-primitives 0.7.12",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-keystore 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3704,7 +3704,7 @@ dependencies = [
[[package]]
name = "polkadot-cli"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"console_error_panic_hook 0.1.6 (registry+https://github.com/rust-lang/crates.io-index)",
"console_log 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3714,7 +3714,7 @@ dependencies = [
"kvdb-web 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
"libp2p 0.13.2 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-service 0.7.11",
"polkadot-service 0.7.12",
"rand 0.6.5 (registry+https://github.com/rust-lang/crates.io-index)",
"rand 0.7.2 (registry+https://github.com/rust-lang/crates.io-index)",
"sc-cli 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3728,16 +3728,16 @@ dependencies = [
[[package]]
name = "polkadot-collator"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-timer 1.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.11",
"polkadot-network 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-service 0.7.11",
"polkadot-validation 0.7.11",
"polkadot-cli 0.7.12",
"polkadot-network 0.7.12",
"polkadot-primitives 0.7.12",
"polkadot-service 0.7.12",
"polkadot-validation 0.7.12",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network 0.8.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3750,11 +3750,11 @@ dependencies = [
[[package]]
name = "polkadot-erasure-coding"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"derive_more 0.15.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.11",
"polkadot-primitives 0.7.12",
"reed-solomon-erasure 4.0.0 (git+https://github.com/paritytech/reed-solomon-erasure)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-trie 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3762,7 +3762,7 @@ dependencies = [
[[package]]
name = "polkadot-network"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"arrayvec 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3770,10 +3770,10 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.11",
"polkadot-erasure-coding 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-validation 0.7.11",
"polkadot-availability-store 0.7.12",
"polkadot-erasure-coding 0.7.12",
"polkadot-primitives 0.7.12",
"polkadot-validation 0.7.12",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network 0.8.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network-gossip 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3786,11 +3786,11 @@ dependencies = [
[[package]]
name = "polkadot-parachain"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"adder 0.7.11",
"adder 0.7.12",
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
"halt 0.7.11",
"halt 0.7.12",
"lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3805,12 +3805,12 @@ dependencies = [
[[package]]
name = "polkadot-primitives"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.11",
"polkadot-parachain 0.7.12",
"pretty_assertions 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3826,12 +3826,12 @@ dependencies = [
[[package]]
name = "polkadot-rpc"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"jsonrpc-core 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-transaction-payment-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.11",
"polkadot-primitives 0.7.12",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-runtime 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3841,7 +3841,7 @@ dependencies = [
[[package]]
name = "polkadot-runtime"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-executive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3875,9 +3875,9 @@ dependencies = [
"pallet-transaction-payment-rpc-runtime-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-treasury 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-runtime-common 0.7.11",
"polkadot-parachain 0.7.12",
"polkadot-primitives 0.7.12",
"polkadot-runtime-common 0.7.12",
"rustc-hex 2.0.1 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3905,7 +3905,7 @@ dependencies = [
[[package]]
name = "polkadot-runtime-common"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3923,8 +3923,8 @@ dependencies = [
"pallet-timestamp 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-treasury 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-parachain 0.7.12",
"polkadot-primitives 0.7.12",
"rustc-hex 2.0.1 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
"serde_derive 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3944,13 +3944,13 @@ dependencies = [
[[package]]
name = "polkadot-service"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"frame-system-rpc-runtime-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"hex-literal 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
"kusama-runtime 0.7.11",
"kusama-runtime 0.7.12",
"lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3959,12 +3959,12 @@ dependencies = [
"pallet-transaction-payment-rpc-runtime-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.11",
"polkadot-network 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-rpc 0.7.11",
"polkadot-runtime 0.7.11",
"polkadot-validation 0.7.11",
"polkadot-availability-store 0.7.12",
"polkadot-network 0.7.12",
"polkadot-primitives 0.7.12",
"polkadot-rpc 0.7.12",
"polkadot-runtime 0.7.12",
"polkadot-validation 0.7.12",
"sc-authority-discovery 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-chain-spec 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3998,16 +3998,16 @@ dependencies = [
[[package]]
name = "polkadot-statement-table"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.11",
"polkadot-primitives 0.7.12",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
]
[[package]]
name = "polkadot-validation"
version = "0.7.11"
version = "0.7.12"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4018,11 +4018,11 @@ dependencies = [
"pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.11",
"polkadot-erasure-coding 0.7.11",
"polkadot-parachain 0.7.11",
"polkadot-primitives 0.7.11",
"polkadot-statement-table 0.7.11",
"polkadot-availability-store 0.7.12",
"polkadot-erasure-coding 0.7.12",
"polkadot-parachain 0.7.12",
"polkadot-primitives 0.7.12",
"polkadot-statement-table 0.7.12",
"sc-block-builder 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-finality-grandpa 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -5046,8 +5046,6 @@ dependencies = [
]
[[package]]
name = "sc-peerset"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#2223fed56a3729ea1ff7e9d6cf6189ecceaf581c"
......
......@@ -4,7 +4,7 @@ path = "src/main.rs"
[package]
name = "polkadot"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
build = "build.rs"
edition = "2018"
......
[package]
name = "polkadot-availability-store"
description = "Persistent database for parachain data"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-cli"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Polkadot node implementation in Rust."
edition = "2018"
......
[package]
name = "polkadot-collator"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Collator node implementation"
edition = "2018"
......
[package]
name = "polkadot-erasure-coding"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-network"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Polkadot-specific networking protocol"
edition = "2018"
......
[package]
name = "polkadot-parachain"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Types and utilities for creating and working with parachains"
edition = "2018"
......
[package]
name = "polkadot-primitives"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-rpc"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-runtime-common"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "kusama-runtime"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
build = "build.rs"
......
[package]
name = "polkadot-runtime"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
build = "build.rs"
......
[package]
name = "polkadot-service"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-statement-table"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "adder"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Test parachain which adds to a number as its state transition"
edition = "2018"
......
[package]
name = "halt"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Test parachain which executes forever"
edition = "2018"
......
[package]
name = "polkadot-validation"
version = "0.7.11"
version = "0.7.12"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment