Unverified Commit b7d102b7 authored by Hernando Castano's avatar Hernando Castano
Browse files

Add bridge chain primitives to workspace

parent 1667e02e
Pipeline #135395 canceled with stages
in 5 minutes and 2 seconds
...@@ -678,21 +678,33 @@ dependencies = [ ...@@ -678,21 +678,33 @@ dependencies = [
] ]
[[package]] [[package]]
name = "bp-kusama" name = "bp-header-chain"
version = "0.1.0" version = "0.1.0"
dependencies = [ dependencies = [
"bp-message-lane", "bp-test-utils",
"bp-runtime", "finality-grandpa",
"frame-support", "frame-support",
"frame-system", "parity-scale-codec",
"sp-api", "serde",
"sp-core", "sp-core",
"sp-finality-grandpa",
"sp-runtime", "sp-runtime",
"sp-std", "sp-std",
] ]
[[package]] [[package]]
name = "bp-message-lane" name = "bp-kusama"
version = "0.1.0"
dependencies = [
"bp-messages",
"bp-polkadot-core",
"bp-runtime",
"sp-api",
"sp-std",
]
[[package]]
name = "bp-messages"
version = "0.1.0" version = "0.1.0"
dependencies = [ dependencies = [
"bp-runtime", "bp-runtime",
...@@ -706,14 +718,43 @@ dependencies = [ ...@@ -706,14 +718,43 @@ dependencies = [
name = "bp-polkadot" name = "bp-polkadot"
version = "0.1.0" version = "0.1.0"
dependencies = [ dependencies = [
"bp-message-lane", "bp-messages",
"bp-polkadot-core",
"bp-runtime",
"sp-api",
"sp-std",
]
[[package]]
name = "bp-polkadot-core"
version = "0.1.0"
dependencies = [
"bp-messages",
"bp-runtime", "bp-runtime",
"frame-support", "frame-support",
"frame-system", "frame-system",
"hex",
"parity-scale-codec",
"sp-api", "sp-api",
"sp-core", "sp-core",
"sp-runtime", "sp-runtime",
"sp-std", "sp-std",
"sp-version",
]
[[package]]
name = "bp-rococo"
version = "0.1.0"
dependencies = [
"bp-header-chain",
"bp-messages",
"bp-polkadot-core",
"bp-runtime",
"parity-scale-codec",
"sp-api",
"sp-runtime",
"sp-std",
"sp-version",
] ]
[[package]] [[package]]
...@@ -721,12 +762,44 @@ name = "bp-runtime" ...@@ -721,12 +762,44 @@ name = "bp-runtime"
version = "0.1.0" version = "0.1.0"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"hash-db",
"num-traits", "num-traits",
"parity-scale-codec", "parity-scale-codec",
"sp-core", "sp-core",
"sp-io", "sp-io",
"sp-runtime", "sp-runtime",
"sp-state-machine",
"sp-std",
"sp-trie",
]
[[package]]
name = "bp-test-utils"
version = "0.1.0"
dependencies = [
"bp-header-chain",
"ed25519-dalek",
"finality-grandpa",
"parity-scale-codec",
"sp-application-crypto",
"sp-finality-grandpa",
"sp-runtime",
"sp-std",
]
[[package]]
name = "bp-westend"
version = "0.1.0"
dependencies = [
"bp-header-chain",
"bp-messages",
"bp-polkadot-core",
"bp-runtime",
"parity-scale-codec",
"sp-api",
"sp-runtime",
"sp-std", "sp-std",
"sp-version",
] ]
[[package]] [[package]]
......
...@@ -26,8 +26,10 @@ tempfile = "3.2.0" ...@@ -26,8 +26,10 @@ tempfile = "3.2.0"
[workspace] [workspace]
members = [ members = [
"bridges/primitives/kusama", "bridges/primitives/chain-kusama",
"bridges/primitives/polkadot", "bridges/primitives/chain-polkadot",
"bridges/primitives/chain-rococo",
"bridges/primitives/chain-westend",
"bridges/primitives/runtime", "bridges/primitives/runtime",
"cli", "cli",
"core-primitives", "core-primitives",
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment