Unverified Commit b3a27322 authored by asynchronous rob's avatar asynchronous rob Committed by GitHub
Browse files

more tracing for av-store (#2604)



* more tracing for av-store

* Update node/core/av-store/src/lib.rs

Co-authored-by: default avatarBastian Köcher <bkchr@users.noreply.github.com>

* Update node/core/av-store/src/lib.rs

Co-authored-by: default avatarBastian Köcher <bkchr@users.noreply.github.com>

* Update node/core/av-store/src/lib.rs

Co-authored-by: default avatarBastian Köcher <bkchr@users.noreply.github.com>

* Update tracing everywhere

* Fix build

* More fixes

* Push cargo.lock

* Update

Co-authored-by: default avatarBastian Köcher <bkchr@users.noreply.github.com>
Co-authored-by: default avatarBastian Köcher <info@kchr.de>
parent c8649e59
Pipeline #127881 passed with stages
in 34 minutes and 12 seconds
This diff is collapsed.
......@@ -25,7 +25,6 @@ service = { package = "polkadot-service", path = "../node/service", default-feat
polkadot-parachain = { path = "../parachain", optional = true }
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
tracing-futures = "0.2.4"
frame-benchmarking-cli = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
try-runtime-cli = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
sc-cli = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
......
......@@ -6,8 +6,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
polkadot-erasure-coding = { path = "../../erasure-coding" }
polkadot-node-primitives = { path = "../primitives" }
polkadot-node-subsystem = { path = "../subsystem" }
......
......@@ -8,8 +8,7 @@ edition = "2018"
futures = "0.3.8"
futures-timer = "3.0.2"
parity-scale-codec = { version = "2.0.0", default-features = false, features = ["bit-vec", "derive"] }
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
bitvec = { version = "0.20.1", default-features = false, features = ["alloc"] }
merlin = "2.0"
schnorrkel = "0.9.1"
......
......@@ -10,8 +10,7 @@ futures-timer = "3.0.2"
kvdb = "0.9.0"
kvdb-rocksdb = "0.11.0"
thiserror = "1.0.23"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
bitvec = "0.20.1"
parity-scale-codec = { version = "2.0.0", features = ["derive"] }
......
......@@ -679,6 +679,12 @@ fn note_block_backed(
) -> Result<(), Error> {
let candidate_hash = candidate.hash();
tracing::trace!(
target: LOG_TARGET,
?candidate_hash,
"Candidate backed",
);
if load_meta(db, &candidate_hash)?.is_none() {
let meta = CandidateMeta {
state: State::Unavailable(now.into()),
......@@ -717,6 +723,12 @@ fn note_block_included(
Some(mut meta) => {
let be_block = (BEBlockNumber(block.0), block.1);
tracing::trace!(
target: LOG_TARGET,
?candidate_hash,
"Candidate included",
);
meta.state = match meta.state {
State::Unavailable(at) => {
let at_d: Duration = at.into();
......@@ -1045,6 +1057,13 @@ fn store_chunk(
None => return Ok(false), // out of bounds.
}
tracing::debug!(
target: LOG_TARGET,
?candidate_hash,
chunk_index = %chunk.index.0,
"Stored chunk index for candidate.",
);
db.write(tx)?;
Ok(true)
}
......
......@@ -14,8 +14,7 @@ polkadot-node-subsystem-util = { path = "../../subsystem-util" }
erasure-coding = { package = "polkadot-erasure-coding", path = "../../../erasure-coding" }
statement-table = { package = "polkadot-statement-table", path = "../../../statement-table" }
bitvec = { version = "0.20.1", default-features = false, features = ["alloc"] }
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
thiserror = "1.0.23"
[dev-dependencies]
......
......@@ -6,8 +6,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
polkadot-primitives = { path = "../../../primitives" }
polkadot-node-subsystem = { path = "../../subsystem" }
polkadot-node-subsystem-util = { path = "../../subsystem-util" }
......
......@@ -6,8 +6,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
thiserror = "1.0.23"
sp-keystore = { git = "https://github.com/paritytech/substrate", branch = "master" }
......
......@@ -6,8 +6,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
sp-core = { package = "sp-core", git = "https://github.com/paritytech/substrate", branch = "master" }
parity-scale-codec = { version = "2.0.0", default-features = false, features = ["bit-vec", "derive"] }
......
......@@ -6,8 +6,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
sp-blockchain = { git = "https://github.com/paritytech/substrate", branch = "master" }
polkadot-primitives = { path = "../../../primitives" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
......
......@@ -7,7 +7,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
futures-timer = "3.0.2"
tracing = "0.1.22"
tracing = "0.1.25"
polkadot-node-subsystem = { path = "../../subsystem" }
polkadot-overseer = { path = "../../overseer" }
polkadot-primitives = { path = "../../../primitives" }
......
......@@ -7,8 +7,7 @@ edition = "2018"
[dependencies]
bitvec = { version = "0.20.1", default-features = false, features = ["alloc"] }
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
thiserror = "1.0.23"
polkadot-primitives = { path = "../../../primitives" }
polkadot-node-subsystem = { path = "../../subsystem" }
......
......@@ -6,8 +6,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
memory-lru = "0.1.0"
parity-util-mem = { version = "0.9.0", default-features = false }
......
......@@ -12,8 +12,7 @@ polkadot-node-subsystem-util = { path = "../../subsystem-util" }
polkadot-primitives = { path = "../../../primitives" }
futures = "0.3.8"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
[dev-dependencies]
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master", features = ["std"] }
......
......@@ -6,8 +6,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
parity-scale-codec = { version = "2.0.0", features = ["std"] }
polkadot-primitives = { path = "../../../primitives" }
polkadot-erasure-coding = { path = "../../../erasure-coding" }
......
......@@ -9,8 +9,7 @@ futures = "0.3.12"
lru = "0.6.1"
rand = "0.8.3"
thiserror = "1.0.21"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
polkadot-erasure-coding = { path = "../../../erasure-coding" }
polkadot-primitives = { path = "../../../primitives" }
......
......@@ -6,8 +6,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
parity-scale-codec = { version = "2.0.0", default-features = false, features = ["derive"] }
polkadot-primitives = { path = "../../../primitives" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
......
......@@ -7,8 +7,7 @@ edition = "2018"
[dependencies]
async-trait = "0.1.42"
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
polkadot-primitives = { path = "../../../primitives" }
parity-scale-codec = { version = "2.0.0", default-features = false, features = ["derive"] }
sc-authority-discovery = { git = "https://github.com/paritytech/substrate", branch = "master" }
......
......@@ -6,8 +6,7 @@ edition = "2018"
[dependencies]
futures = "0.3.12"
tracing = "0.1.22"
tracing-futures = "0.2.4"
tracing = "0.1.25"
thiserror = "1.0.23"
polkadot-primitives = { path = "../../../primitives" }
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment