Unverified Commit a2869fa9 authored by dependabot[bot]'s avatar dependabot[bot] Committed by GitHub
Browse files

Bump parity-scale-codec from 2.3.0 to 2.3.1 (#3959)

Bumps [parity-scale-codec](https://github.com/paritytech/parity-scale-codec) from 2.3.0 to 2.3.1.
- [Release notes](https://github.com/paritytech/parity-scale-codec/releases)
- [Changelog](https://github.com/paritytech/parity-scale-codec/blob/master/CHANGELOG.md)
- [Commits](https://github.com/paritytech/parity-scale-codec/compare/parity-scale-codec-v2.3.0...parity-scale-codec-v2.3.1

)

---
updated-dependencies:
- dependency-name: parity-scale-codec
  dependency-type: direct:production
  update-type: version-update:semver-patch
...
Signed-off-by: default avatardependabot[bot] <support@github.com>
Co-authored-by: default avatardependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
parent ad40ebbe
Pipeline #159763 passed with stages
in 48 minutes and 13 seconds
......@@ -5489,9 +5489,9 @@ dependencies = [
[[package]]
name = "parity-scale-codec"
version = "2.3.0"
version = "2.3.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e11263a97373b43da4b426edbb52ef99a7b51e2d9752ef56a7f8b356f48495a5"
checksum = "373b1a4c1338d9cd3d1fa53b3a11bdab5ab6bd80a20f7f7becd76953ae2be909"
dependencies = [
"arrayvec 0.7.0",
"bitvec 0.20.1",
......@@ -5503,9 +5503,9 @@ dependencies = [
[[package]]
name = "parity-scale-codec-derive"
version = "2.2.0"
version = "2.3.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "40dbbfef7f0a1143c5b06e0d76a6278e25dac0bc1af4be51a0fbb73f07e7ad09"
checksum = "1557010476e0595c9b568d16dcfb81b93cdeb157612726f5170d31aa707bed27"
dependencies = [
"proc-macro-crate 1.1.0",
"proc-macro2",
......
......@@ -9,7 +9,7 @@ sp-core = { git = "https://github.com/paritytech/substrate", branch = "master",
sp-std = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-runtime = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
scale-info = { version = "1.0", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "2.3.0", default-features = false, features = [ "derive" ] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = [ "derive" ] }
parity-util-mem = { version = "0.10.0", default-features = false, optional = true }
[features]
......
......@@ -8,7 +8,7 @@ edition = "2018"
polkadot-primitives = { path = "../primitives" }
polkadot-node-primitives = { package = "polkadot-node-primitives", path = "../node/primitives" }
novelpoly = { package = "reed-solomon-novelpoly", version = "1.0.0" }
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["std", "derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["std", "derive"] }
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
trie = { package = "sp-trie", git = "https://github.com/paritytech/substrate", branch = "master" }
thiserror = "1.0.26"
......@@ -15,7 +15,7 @@ polkadot-primitives = { path = "../../primitives" }
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
sp-maybe-compressed-blob = { git = "https://github.com/paritytech/substrate", branch = "master" }
thiserror = "1.0.26"
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["bit-vec", "derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["bit-vec", "derive"] }
[dev-dependencies]
polkadot-node-subsystem-test-helpers = { path = "../subsystem-test-helpers" }
......@@ -7,7 +7,7 @@ edition = "2018"
[dependencies]
futures = "0.3.17"
futures-timer = "3.0.2"
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["bit-vec", "derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["bit-vec", "derive"] }
tracing = "0.1.28"
bitvec = { version = "0.20.1", default-features = false, features = ["alloc"] }
lru = "0.6"
......
......@@ -12,7 +12,7 @@ thiserror = "1.0.26"
tracing = "0.1.28"
bitvec = "0.20.1"
parity-scale-codec = { version = "2.3.0", features = ["derive"] }
parity-scale-codec = { version = "2.3.1", features = ["derive"] }
erasure = { package = "polkadot-erasure-coding", path = "../../../erasure-coding" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
polkadot-node-subsystem-util = { path = "../../subsystem-util" }
......
......@@ -10,7 +10,7 @@ futures = "0.3.17"
tracing = "0.1.28"
sp-maybe-compressed-blob = { package = "sp-maybe-compressed-blob", git = "https://github.com/paritytech/substrate", branch = "master" }
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["bit-vec", "derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["bit-vec", "derive"] }
polkadot-primitives = { path = "../../../primitives" }
polkadot-parachain = { path = "../../../parachain" }
......
......@@ -17,7 +17,7 @@ sc-consensus-babe = { git = "https://github.com/paritytech/substrate", branch =
[dev-dependencies]
futures = { version = "0.3.17", features = ["thread-pool"] }
maplit = "1.0.2"
parity-scale-codec = "2.3.0"
parity-scale-codec = "2.3.1"
polkadot-node-primitives = { path = "../../primitives" }
polkadot-node-subsystem-test-helpers = { path = "../../subsystem-test-helpers" }
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
......@@ -15,6 +15,6 @@ polkadot-primitives = { path = "../../../primitives" }
[dev-dependencies]
assert_matches = "1.5.0"
parity-scale-codec = "2.3.0"
parity-scale-codec = "2.3.1"
polkadot-node-subsystem-test-helpers = { path = "../../subsystem-test-helpers"}
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
......@@ -20,7 +20,7 @@ slotmap = "1.0"
tracing = "0.1.28"
pin-project = "1.0.8"
rand = "0.8.3"
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["derive"] }
polkadot-parachain = { path = "../../../parachain" }
polkadot-core-primitives = { path = "../../../core-primitives" }
polkadot-node-subsystem-util = { path = "../../subsystem-util"}
......
......@@ -16,4 +16,4 @@ sc-network = { git = "https://github.com/paritytech/substrate", branch = "master
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
thiserror = "1.0.26"
log = "0.4.13"
parity-scale-codec = { version = "2.3.0", default-features = false }
parity-scale-codec = { version = "2.3.1", default-features = false }
......@@ -7,7 +7,7 @@ edition = "2018"
[dependencies]
futures = "0.3.17"
tracing = "0.1.28"
parity-scale-codec = { version = "2.3.0", features = ["std"] }
parity-scale-codec = { version = "2.3.1", features = ["std"] }
polkadot-primitives = { path = "../../../primitives" }
polkadot-erasure-coding = { path = "../../../erasure-coding" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
......
......@@ -17,7 +17,7 @@ polkadot-node-primitives = { path = "../../primitives" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
polkadot-node-subsystem-util = { path = "../../subsystem-util" }
polkadot-node-network-protocol = { path = "../../network/protocol" }
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["derive"] }
sc-network = { git = "https://github.com/paritytech/substrate", branch = "master" }
[dev-dependencies]
......
......@@ -9,7 +9,7 @@ async-trait = "0.1.51"
futures = "0.3.17"
tracing = "0.1.28"
polkadot-primitives = { path = "../../../primitives" }
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["derive"] }
sc-network = { git = "https://github.com/paritytech/substrate", branch = "master" }
sp-consensus = { git = "https://github.com/paritytech/substrate", branch = "master" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
......
......@@ -30,6 +30,6 @@ assert_matches = "1.4.0"
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master", features = ["std"] }
sp-keyring = { git = "https://github.com/paritytech/substrate", branch = "master" }
sc-network = { git = "https://github.com/paritytech/substrate", branch = "master" }
parity-scale-codec = { version = "2.3.0", features = ["std"] }
parity-scale-codec = { version = "2.3.1", features = ["std"] }
polkadot-subsystem-testhelpers = { package = "polkadot-node-subsystem-test-helpers", path = "../../subsystem-test-helpers" }
......@@ -8,7 +8,7 @@ edition = "2018"
futures = "0.3.17"
tracing = "0.1.28"
derive_more = "0.99.14"
parity-scale-codec = { version = "2.3.0", features = ["std"] }
parity-scale-codec = { version = "2.3.1", features = ["std"] }
polkadot-primitives = { path = "../../../primitives" }
polkadot-erasure-coding = { path = "../../../erasure-coding" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
......
......@@ -10,7 +10,7 @@ async-trait = "0.1.51"
polkadot-primitives = { path = "../../../primitives" }
polkadot-node-primitives = { path = "../../primitives" }
polkadot-node-jaeger = { path = "../../jaeger" }
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["derive"] }
sc-network = { git = "https://github.com/paritytech/substrate", branch = "master" }
sc-authority-discovery = { git = "https://github.com/paritytech/substrate", branch = "master" }
strum = { version = "0.21", features = ["derive"] }
......
......@@ -17,7 +17,7 @@ polkadot-node-subsystem-util = { path = "../../subsystem-util" }
polkadot-node-network-protocol = { path = "../../network/protocol" }
arrayvec = "0.5.2"
indexmap = "1.7.0"
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["derive"] }
derive_more = "0.99.11"
thiserror = "1.0.26"
......
......@@ -9,7 +9,7 @@ description = "Primitives types for the Node-side"
bounded-vec = "0.4"
futures = "0.3.17"
polkadot-primitives = { path = "../../primitives" }
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["derive"] }
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
sp-application-crypto = { git = "https://github.com/paritytech/substrate", branch = "master" }
sp-consensus-vrf = { git = "https://github.com/paritytech/substrate", branch = "master" }
......
......@@ -9,7 +9,7 @@ description = "Subsystem traits and message definitions"
async-trait = "0.1.51"
futures = "0.3.17"
itertools = "0.10"
parity-scale-codec = { version = "2.3.0", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "2.3.1", default-features = false, features = ["derive"] }
pin-project = "1.0.8"
rand = "0.8.3"
thiserror = "1.0.26"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment