Unverified Commit a06b9def authored by Gavin Wood's avatar Gavin Wood Committed by GitHub
Browse files

Update Substrate (#661)

* Make compat with exit-future updates

* Update exit-future entirely

* Tidy

* Bump Substrate
parent 84ece424
Pipeline #71032 passed with stages
in 26 minutes and 59 seconds
......@@ -27,7 +27,7 @@ version = "0.1.0"
dependencies = [
"adder 0.7.8",
"ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-collator 0.7.8",
......@@ -427,6 +427,11 @@ dependencies = [
"iovec 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "bytes"
version = "0.5.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "c2-chacha"
version = "0.2.3"
......@@ -954,6 +959,14 @@ dependencies = [
"parking_lot 0.7.1 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "exit-future"
version = "0.2.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
dependencies = [
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "faerie"
version = "0.13.0"
......@@ -1067,7 +1080,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "fork-tree"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
]
......@@ -1075,7 +1088,7 @@ dependencies = [
[[package]]
name = "frame-executive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1089,7 +1102,7 @@ dependencies = [
[[package]]
name = "frame-metadata"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1100,7 +1113,7 @@ dependencies = [
[[package]]
name = "frame-support"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"bitmask 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-metadata 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1124,7 +1137,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support-procedural-tools 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1135,7 +1148,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support-procedural-tools-derive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1147,7 +1160,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools-derive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
"quote 1.0.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1157,7 +1170,7 @@ dependencies = [
[[package]]
name = "frame-system"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"impl-trait-for-tuples 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1174,7 +1187,7 @@ dependencies = [
[[package]]
name = "frame-system-rpc-runtime-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1464,7 +1477,7 @@ dependencies = [
[[package]]
name = "grafana-data-source"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"async-std 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"chrono 0.4.9 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -2810,7 +2823,7 @@ dependencies = [
[[package]]
name = "pallet-authority-discovery"
version = "0.1.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2828,7 +2841,7 @@ dependencies = [
[[package]]
name = "pallet-authorship"
version = "0.1.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2845,7 +2858,7 @@ dependencies = [
[[package]]
name = "pallet-babe"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2866,7 +2879,7 @@ dependencies = [
[[package]]
name = "pallet-balances"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2880,7 +2893,7 @@ dependencies = [
[[package]]
name = "pallet-collective"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2896,7 +2909,7 @@ dependencies = [
[[package]]
name = "pallet-democracy"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2911,7 +2924,7 @@ dependencies = [
[[package]]
name = "pallet-elections-phragmen"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2924,7 +2937,7 @@ dependencies = [
[[package]]
name = "pallet-finality-tracker"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2940,7 +2953,7 @@ dependencies = [
[[package]]
name = "pallet-grandpa"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2949,7 +2962,7 @@ dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-finality-granpda 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-finality-grandpa 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-runtime 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-staking 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-std 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2958,7 +2971,7 @@ dependencies = [
[[package]]
name = "pallet-im-online"
version = "0.1.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2977,7 +2990,7 @@ dependencies = [
[[package]]
name = "pallet-indices"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2994,7 +3007,7 @@ dependencies = [
[[package]]
name = "pallet-membership"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3008,7 +3021,7 @@ dependencies = [
[[package]]
name = "pallet-nicks"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3022,7 +3035,7 @@ dependencies = [
[[package]]
name = "pallet-offences"
version = "1.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3037,7 +3050,7 @@ dependencies = [
[[package]]
name = "pallet-randomness-collective-flip"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3050,7 +3063,7 @@ dependencies = [
[[package]]
name = "pallet-session"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3069,7 +3082,7 @@ dependencies = [
[[package]]
name = "pallet-staking"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3089,7 +3102,7 @@ dependencies = [
[[package]]
name = "pallet-staking-reward-curve"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3100,7 +3113,7 @@ dependencies = [
[[package]]
name = "pallet-timestamp"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3116,7 +3129,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3129,7 +3142,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"jsonrpc-core 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"jsonrpc-core-client 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3146,7 +3159,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc-runtime-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3159,7 +3172,7 @@ dependencies = [
[[package]]
name = "pallet-treasury"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3469,7 +3482,7 @@ name = "polkadot-availability-store"
version = "0.7.8"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures01 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"kvdb 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3554,7 +3567,7 @@ name = "polkadot-network"
version = "0.7.8"
dependencies = [
"arrayvec 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3730,7 +3743,7 @@ dependencies = [
"sp-consensus 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-consensus-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-finality-granpda 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-finality-grandpa 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-inherents 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-io 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-runtime 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3753,7 +3766,7 @@ dependencies = [
"async-std 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-timer 2.0.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4290,7 +4303,7 @@ dependencies = [
[[package]]
name = "sc-application-crypto"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4302,7 +4315,7 @@ dependencies = [
[[package]]
name = "sc-authority-discovery"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4326,7 +4339,7 @@ dependencies = [
[[package]]
name = "sc-block-builder"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4340,7 +4353,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"impl-trait-for-tuples 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"sc-chain-spec-derive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4355,7 +4368,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec-derive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4366,7 +4379,7 @@ dependencies = [
[[package]]
name = "sc-cli"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"ansi_term 0.12.1 (registry+https://github.com/rust-lang/crates.io-index)",
"app_dirs 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4376,7 +4389,6 @@ dependencies = [
"env_logger 0.7.1 (registry+https://github.com/rust-lang/crates.io-index)",
"fdlimit 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures01 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"names 0.11.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4396,13 +4408,13 @@ dependencies = [
"sp-state-machine 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"structopt 0.3.5 (registry+https://github.com/rust-lang/crates.io-index)",
"time 0.1.42 (registry+https://github.com/rust-lang/crates.io-index)",
"tokio 0.1.22 (registry+https://github.com/rust-lang/crates.io-index)",
"tokio 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "sc-client"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4435,7 +4447,7 @@ dependencies = [
[[package]]
name = "sc-client-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4467,7 +4479,7 @@ dependencies = [
[[package]]
name = "sc-client-db"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"hash-db 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"kvdb 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4492,7 +4504,7 @@ dependencies = [
[[package]]
name = "sc-consensus-babe"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"fork-tree 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4532,7 +4544,7 @@ dependencies = [
[[package]]
name = "sc-consensus-slots"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-timer 2.0.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4551,7 +4563,7 @@ dependencies = [
[[package]]
name = "sc-consensus-uncles"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4565,7 +4577,7 @@ dependencies = [
[[package]]
name = "sc-executor"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"cranelift-codegen 0.50.0 (registry+https://github.com/rust-lang/crates.io-index)",
"cranelift-entity 0.50.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4597,7 +4609,7 @@ dependencies = [
[[package]]
name = "sc-finality-grandpa"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"finality-grandpa 0.10.1 (registry+https://github.com/rust-lang/crates.io-index)",
"fork-tree 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4616,7 +4628,7 @@ dependencies = [
"sp-blockchain 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-consensus 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-finality-granpda 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-finality-grandpa 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-finality-tracker 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-inherents 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-runtime 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4627,7 +4639,7 @@ dependencies = [
[[package]]
name = "sc-keystore"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"hex 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4642,7 +4654,7 @@ dependencies = [
[[package]]
name = "sc-network"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"bitflags 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
"bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4687,7 +4699,7 @@ dependencies = [
[[package]]
name = "sc-offchain"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4714,7 +4726,7 @@ dependencies = [
[[package]]
name = "sc-peerset"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"libp2p 0.13.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4725,7 +4737,7 @@ dependencies = [
[[package]]
name = "sc-rpc"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"hash-db 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4754,7 +4766,7 @@ dependencies = [
[[package]]
name = "sc-rpc-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4776,7 +4788,7 @@ dependencies = [
[[package]]
name = "sc-rpc-server"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"jsonrpc-core 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"jsonrpc-http-server 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4791,10 +4803,10 @@ dependencies = [
[[package]]
name = "sc-service"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"grafana-data-source 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4839,7 +4851,7 @@ dependencies = [
[[package]]
name = "sc-state-db"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4850,7 +4862,7 @@ dependencies = [
[[package]]
name = "sc-telemetry"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4872,7 +4884,7 @@ dependencies = [
[[package]]
name = "sc-tracing"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"erased-serde 0.3.9 (registry+https://github.com/rust-lang/crates.io-index)",
"grafana-data-source 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4888,7 +4900,7 @@ dependencies = [
[[package]]
name = "sc-transaction-graph"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4903,7 +4915,7 @@ dependencies = [
[[package]]
name = "sc-transaction-pool"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -5195,7 +5207,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "sp-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api-proc-macro 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -5209,7 +5221,7 @@ dependencies = [
[[package]]
name = "sp-api-proc-macro"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"blake2-rfc 0.2.18 (registry+https://github.com/rust-lang/crates.io-index)",
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -5221,7 +5233,7 @@ dependencies = [
[[package]]
name = "sp-arithmetic"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"integer-sqrt 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)",
"num-traits 0.2.10 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -5234,7 +5246,7 @@ dependencies = [
[[package]]
name = "sp-authority-discovery"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sc-application-crypto 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -5246,7 +5258,7 @@ dependencies = [
[[package]]
name = "sp-authorship"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-inherents 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -5256,7 +5268,7 @@ dependencies = [
[[package]]
name = "sp-block-builder"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -5268,7 +5280,7 @@ dependencies = [
[[package]]
name = "sp-blockchain"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#333f3a7d00771d15102bd40f5aade9e58b1b095f"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",