Unverified Commit 7ac03537 authored by dependabot[bot]'s avatar dependabot[bot] Committed by GitHub
Browse files

Bump async-trait from 0.1.41 to 0.1.42 (#1996)

Bumps [async-trait](https://github.com/dtolnay/async-trait) from 0.1.41 to 0.1.42.
- [Release notes](https://github.com/dtolnay/async-trait/releases)
- [Commits](https://github.com/dtolnay/async-trait/compare/0.1.41...0.1.42

)

Signed-off-by: default avatardependabot[bot] <support@github.com>

Co-authored-by: default avatardependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
parent ba74791b
Pipeline #114733 passed with stages
in 28 minutes and 11 seconds
...@@ -333,9 +333,9 @@ dependencies = [ ...@@ -333,9 +333,9 @@ dependencies = [
[[package]] [[package]]
name = "async-trait" name = "async-trait"
version = "0.1.41" version = "0.1.42"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "b246867b8b3b6ae56035f1eb1ed557c1d8eae97f0d53696138a50fa0e3a3b8c0" checksum = "8d3a45e77e34375a7923b1e8febb049bb011f064714a8e17a1a616fef01da13d"
dependencies = [ dependencies = [
"proc-macro2 1.0.24", "proc-macro2 1.0.24",
"quote 1.0.7", "quote 1.0.7",
......
...@@ -5,7 +5,7 @@ authors = ["Parity Technologies <admin@parity.io>"] ...@@ -5,7 +5,7 @@ authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
[dependencies] [dependencies]
async-trait = "0.1.41" async-trait = "0.1.42"
futures = "0.3.8" futures = "0.3.8"
tracing = "0.1.21" tracing = "0.1.21"
tracing-futures = "0.2.4" tracing-futures = "0.2.4"
......
...@@ -15,7 +15,7 @@ client = { package = "sc-client-api", git = "https://github.com/paritytech/subst ...@@ -15,7 +15,7 @@ client = { package = "sc-client-api", git = "https://github.com/paritytech/subst
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../subsystem" } polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../subsystem" }
polkadot-node-subsystem-util = { path = "../subsystem-util" } polkadot-node-subsystem-util = { path = "../subsystem-util" }
polkadot-node-primitives = { package = "polkadot-node-primitives", path = "../primitives" } polkadot-node-primitives = { package = "polkadot-node-primitives", path = "../primitives" }
async-trait = "0.1.41" async-trait = "0.1.42"
[dev-dependencies] [dev-dependencies]
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" } sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
......
...@@ -6,7 +6,7 @@ edition = "2018" ...@@ -6,7 +6,7 @@ edition = "2018"
description = "Subsystem traits and message definitions" description = "Subsystem traits and message definitions"
[dependencies] [dependencies]
async-trait = "0.1.41" async-trait = "0.1.42"
futures = "0.3.8" futures = "0.3.8"
futures-timer = "3.0.2" futures-timer = "3.0.2"
tracing = "0.1.21" tracing = "0.1.21"
......
...@@ -6,7 +6,7 @@ edition = "2018" ...@@ -6,7 +6,7 @@ edition = "2018"
description = "Subsystem traits and message definitions" description = "Subsystem traits and message definitions"
[dependencies] [dependencies]
async-trait = "0.1.41" async-trait = "0.1.42"
futures = "0.3.8" futures = "0.3.8"
futures-timer = "3.0.2" futures-timer = "3.0.2"
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] } parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
...@@ -29,7 +29,7 @@ substrate-prometheus-endpoint = { git = "https://github.com/paritytech/substrate ...@@ -29,7 +29,7 @@ substrate-prometheus-endpoint = { git = "https://github.com/paritytech/substrate
[dev-dependencies] [dev-dependencies]
assert_matches = "1.4.0" assert_matches = "1.4.0"
async-trait = "0.1.41" async-trait = "0.1.42"
env_logger = "0.8.2" env_logger = "0.8.2"
futures = { version = "0.3.8", features = ["thread-pool"] } futures = { version = "0.3.8", features = ["thread-pool"] }
log = "0.4.11" log = "0.4.11"
......
...@@ -6,7 +6,7 @@ edition = "2018" ...@@ -6,7 +6,7 @@ edition = "2018"
description = "Subsystem traits and message definitions" description = "Subsystem traits and message definitions"
[dependencies] [dependencies]
async-trait = "0.1.41" async-trait = "0.1.42"
derive_more = "0.99.11" derive_more = "0.99.11"
futures = "0.3.8" futures = "0.3.8"
futures-timer = "3.0.2" futures-timer = "3.0.2"
...@@ -27,7 +27,7 @@ thiserror = "1.0.22" ...@@ -27,7 +27,7 @@ thiserror = "1.0.22"
[dev-dependencies] [dev-dependencies]
assert_matches = "1.4.0" assert_matches = "1.4.0"
async-trait = "0.1.41" async-trait = "0.1.42"
futures = { version = "0.3.8", features = ["thread-pool"] } futures = { version = "0.3.8", features = ["thread-pool"] }
parking_lot = "0.11.1" parking_lot = "0.11.1"
polkadot-node-subsystem-test-helpers = { path = "../subsystem-test-helpers" } polkadot-node-subsystem-test-helpers = { path = "../subsystem-test-helpers" }
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment