Unverified Commit 79cfa68c authored by Squirrel's avatar Squirrel Committed by GitHub
Browse files

Removed unneeded deps (#3658)



* Removed unneeded deps (except under bridge)
Co-authored-by: Andronik Ordian's avatarAndronik Ordian <write@reusable.software>
parent 56a8ebb5
Pipeline #154779 passed with stages
in 39 minutes and 32 seconds
...@@ -1500,12 +1500,6 @@ dependencies = [ ...@@ -1500,12 +1500,6 @@ dependencies = [
"syn", "syn",
] ]
[[package]]
name = "diff"
version = "0.1.12"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "0e25ea47919b1560c4e3b7fe0aaab9becf5b84a10325ddf7db0f0ba5e1026499"
[[package]] [[package]]
name = "difference" name = "difference"
version = "2.0.0" version = "2.0.0"
...@@ -2095,7 +2089,7 @@ dependencies = [ ...@@ -2095,7 +2089,7 @@ dependencies = [
"frame-support-test-pallet", "frame-support-test-pallet",
"frame-system", "frame-system",
"parity-scale-codec", "parity-scale-codec",
"pretty_assertions 0.6.1", "pretty_assertions",
"rustversion", "rustversion",
"serde", "serde",
"sp-core", "sp-core",
...@@ -4080,7 +4074,6 @@ dependencies = [ ...@@ -4080,7 +4074,6 @@ dependencies = [
name = "metered-channel" name = "metered-channel"
version = "0.9.9" version = "0.9.9"
dependencies = [ dependencies = [
"assert_matches",
"derive_more", "derive_more",
"futures 0.3.16", "futures 0.3.16",
"futures-timer 3.0.2", "futures-timer 3.0.2",
...@@ -5734,10 +5727,8 @@ dependencies = [ ...@@ -5734,10 +5727,8 @@ dependencies = [
"futures 0.3.16", "futures 0.3.16",
"futures-timer 3.0.2", "futures-timer 3.0.2",
"lru", "lru",
"maplit",
"parity-scale-codec", "parity-scale-codec",
"polkadot-erasure-coding", "polkadot-erasure-coding",
"polkadot-node-core-runtime-api",
"polkadot-node-network-protocol", "polkadot-node-network-protocol",
"polkadot-node-primitives", "polkadot-node-primitives",
"polkadot-node-subsystem", "polkadot-node-subsystem",
...@@ -5746,7 +5737,6 @@ dependencies = [ ...@@ -5746,7 +5737,6 @@ dependencies = [
"polkadot-primitives", "polkadot-primitives",
"rand 0.8.4", "rand 0.8.4",
"sc-network", "sc-network",
"sp-application-crypto",
"sp-core", "sp-core",
"sp-keyring", "sp-keyring",
"sp-keystore", "sp-keystore",
...@@ -5882,22 +5872,17 @@ dependencies = [ ...@@ -5882,22 +5872,17 @@ dependencies = [
"futures-timer 3.0.2", "futures-timer 3.0.2",
"lazy_static", "lazy_static",
"lru", "lru",
"maplit",
"parity-scale-codec", "parity-scale-codec",
"polkadot-erasure-coding", "polkadot-erasure-coding",
"polkadot-node-core-runtime-api",
"polkadot-node-network-protocol", "polkadot-node-network-protocol",
"polkadot-node-primitives", "polkadot-node-primitives",
"polkadot-node-subsystem", "polkadot-node-subsystem",
"polkadot-node-subsystem-test-helpers", "polkadot-node-subsystem-test-helpers",
"polkadot-node-subsystem-util", "polkadot-node-subsystem-util",
"polkadot-primitives", "polkadot-primitives",
"rand 0.8.4",
"sc-keystore", "sc-keystore",
"sc-network", "sc-network",
"smallvec",
"sp-application-crypto", "sp-application-crypto",
"sp-core",
"sp-keyring", "sp-keyring",
"sp-keystore", "sp-keystore",
"sp-tracing", "sp-tracing",
...@@ -5992,7 +5977,6 @@ dependencies = [ ...@@ -5992,7 +5977,6 @@ dependencies = [
"kvdb", "kvdb",
"kvdb-memorydb", "kvdb-memorydb",
"lru", "lru",
"maplit",
"merlin", "merlin",
"parity-scale-codec", "parity-scale-codec",
"parking_lot 0.11.1", "parking_lot 0.11.1",
...@@ -6003,13 +5987,10 @@ dependencies = [ ...@@ -6003,13 +5987,10 @@ dependencies = [
"polkadot-node-subsystem-util", "polkadot-node-subsystem-util",
"polkadot-overseer", "polkadot-overseer",
"polkadot-primitives", "polkadot-primitives",
"rand 0.8.4",
"rand_core 0.5.1", "rand_core 0.5.1",
"sc-client-api",
"sc-keystore", "sc-keystore",
"schnorrkel", "schnorrkel",
"sp-application-crypto", "sp-application-crypto",
"sp-blockchain",
"sp-consensus", "sp-consensus",
"sp-consensus-babe", "sp-consensus-babe",
"sp-consensus-slots", "sp-consensus-slots",
...@@ -6162,7 +6143,6 @@ dependencies = [ ...@@ -6162,7 +6143,6 @@ dependencies = [
"polkadot-node-subsystem", "polkadot-node-subsystem",
"polkadot-node-subsystem-test-helpers", "polkadot-node-subsystem-test-helpers",
"polkadot-node-subsystem-util", "polkadot-node-subsystem-util",
"polkadot-overseer",
"polkadot-primitives", "polkadot-primitives",
"sc-keystore", "sc-keystore",
"sp-core", "sp-core",
...@@ -6295,15 +6275,10 @@ dependencies = [ ...@@ -6295,15 +6275,10 @@ dependencies = [
name = "polkadot-node-metrics" name = "polkadot-node-metrics"
version = "0.9.9" version = "0.9.9"
dependencies = [ dependencies = [
"async-trait",
"futures 0.3.16", "futures 0.3.16",
"futures-timer 3.0.2", "futures-timer 3.0.2",
"jemalloc-ctl", "jemalloc-ctl",
"metered-channel", "metered-channel",
"sc-network",
"sp-application-crypto",
"sp-core",
"sp-keystore",
"substrate-prometheus-endpoint", "substrate-prometheus-endpoint",
] ]
...@@ -6333,7 +6308,6 @@ dependencies = [ ...@@ -6333,7 +6308,6 @@ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"polkadot-parachain", "polkadot-parachain",
"polkadot-primitives", "polkadot-primitives",
"polkadot-statement-table",
"schnorrkel", "schnorrkel",
"serde", "serde",
"sp-application-crypto", "sp-application-crypto",
...@@ -6342,9 +6316,7 @@ dependencies = [ ...@@ -6342,9 +6316,7 @@ dependencies = [
"sp-core", "sp-core",
"sp-keystore", "sp-keystore",
"sp-maybe-compressed-blob", "sp-maybe-compressed-blob",
"sp-runtime",
"thiserror", "thiserror",
"tracing",
"zstd", "zstd",
] ]
...@@ -6363,55 +6335,34 @@ version = "0.9.9" ...@@ -6363,55 +6335,34 @@ version = "0.9.9"
dependencies = [ dependencies = [
"async-trait", "async-trait",
"futures 0.3.16", "futures 0.3.16",
"futures-timer 3.0.2",
"parity-scale-codec",
"parking_lot 0.11.1", "parking_lot 0.11.1",
"pin-project 1.0.8",
"polkadot-node-primitives",
"polkadot-node-subsystem", "polkadot-node-subsystem",
"polkadot-node-subsystem-util", "polkadot-node-subsystem-util",
"polkadot-overseer", "polkadot-overseer",
"polkadot-primitives", "polkadot-primitives",
"polkadot-statement-table",
"sc-keystore", "sc-keystore",
"sc-network",
"smallvec",
"sp-application-crypto", "sp-application-crypto",
"sp-core", "sp-core",
"sp-keyring", "sp-keyring",
"sp-keystore", "sp-keystore",
"tracing",
] ]
[[package]] [[package]]
name = "polkadot-node-subsystem-types" name = "polkadot-node-subsystem-types"
version = "0.9.9" version = "0.9.9"
dependencies = [ dependencies = [
"assert_matches",
"async-std",
"async-trait",
"derive_more", "derive_more",
"futures 0.3.16", "futures 0.3.16",
"futures-timer 3.0.2",
"lazy_static",
"log",
"mick-jaeger",
"parity-scale-codec",
"parking_lot 0.11.1",
"pin-project 1.0.8",
"polkadot-node-jaeger", "polkadot-node-jaeger",
"polkadot-node-network-protocol", "polkadot-node-network-protocol",
"polkadot-node-primitives", "polkadot-node-primitives",
"polkadot-node-subsystem-test-helpers",
"polkadot-overseer-gen", "polkadot-overseer-gen",
"polkadot-primitives", "polkadot-primitives",
"polkadot-statement-table", "polkadot-statement-table",
"sc-network", "sc-network",
"smallvec", "smallvec",
"sp-core",
"substrate-prometheus-endpoint", "substrate-prometheus-endpoint",
"thiserror", "thiserror",
"tracing",
] ]
[[package]] [[package]]
...@@ -6423,28 +6374,23 @@ dependencies = [ ...@@ -6423,28 +6374,23 @@ dependencies = [
"derive_more", "derive_more",
"env_logger 0.9.0", "env_logger 0.9.0",
"futures 0.3.16", "futures 0.3.16",
"futures-timer 3.0.2",
"itertools 0.10.1", "itertools 0.10.1",
"log", "log",
"lru", "lru",
"metered-channel", "metered-channel",
"parity-scale-codec", "parity-scale-codec",
"parking_lot 0.11.1",
"pin-project 1.0.8", "pin-project 1.0.8",
"polkadot-node-jaeger", "polkadot-node-jaeger",
"polkadot-node-metrics", "polkadot-node-metrics",
"polkadot-node-network-protocol", "polkadot-node-network-protocol",
"polkadot-node-primitives",
"polkadot-node-subsystem", "polkadot-node-subsystem",
"polkadot-node-subsystem-test-helpers", "polkadot-node-subsystem-test-helpers",
"polkadot-overseer", "polkadot-overseer",
"polkadot-primitives", "polkadot-primitives",
"rand 0.8.4", "rand 0.8.4",
"sc-network",
"sp-application-crypto", "sp-application-crypto",
"sp-core", "sp-core",
"sp-keystore", "sp-keystore",
"substrate-prometheus-endpoint",
"thiserror", "thiserror",
"tracing", "tracing",
] ]
...@@ -6454,11 +6400,9 @@ name = "polkadot-overseer" ...@@ -6454,11 +6400,9 @@ name = "polkadot-overseer"
version = "0.9.9" version = "0.9.9"
dependencies = [ dependencies = [
"assert_matches", "assert_matches",
"async-trait",
"femme", "femme",
"futures 0.3.16", "futures 0.3.16",
"futures-timer 3.0.2", "futures-timer 3.0.2",
"kv-log-macro",
"lru", "lru",
"metered-channel", "metered-channel",
"parking_lot 0.11.1", "parking_lot 0.11.1",
...@@ -6479,7 +6423,6 @@ dependencies = [ ...@@ -6479,7 +6423,6 @@ dependencies = [
name = "polkadot-overseer-all-subsystems-gen" name = "polkadot-overseer-all-subsystems-gen"
version = "0.9.9" version = "0.9.9"
dependencies = [ dependencies = [
"assert_matches",
"proc-macro2", "proc-macro2",
"quote", "quote",
"syn", "syn",
...@@ -6540,7 +6483,6 @@ dependencies = [ ...@@ -6540,7 +6483,6 @@ dependencies = [
"parity-util-mem", "parity-util-mem",
"polkadot-core-primitives", "polkadot-core-primitives",
"polkadot-parachain", "polkadot-parachain",
"pretty_assertions 0.7.2",
"serde", "serde",
"sp-api", "sp-api",
"sp-application-crypto", "sp-application-crypto",
...@@ -6552,12 +6494,10 @@ dependencies = [ ...@@ -6552,12 +6494,10 @@ dependencies = [
"sp-io", "sp-io",
"sp-keystore", "sp-keystore",
"sp-runtime", "sp-runtime",
"sp-serializer",
"sp-staking", "sp-staking",
"sp-std", "sp-std",
"sp-trie", "sp-trie",
"sp-version", "sp-version",
"thiserror",
] ]
[[package]] [[package]]
...@@ -6569,7 +6509,6 @@ dependencies = [ ...@@ -6569,7 +6509,6 @@ dependencies = [
"jsonrpc-core", "jsonrpc-core",
"pallet-mmr-rpc", "pallet-mmr-rpc",
"pallet-transaction-payment-rpc", "pallet-transaction-payment-rpc",
"parity-scale-codec",
"polkadot-primitives", "polkadot-primitives",
"sc-chain-spec", "sc-chain-spec",
"sc-client-api", "sc-client-api",
...@@ -6578,7 +6517,6 @@ dependencies = [ ...@@ -6578,7 +6517,6 @@ dependencies = [
"sc-consensus-epochs", "sc-consensus-epochs",
"sc-finality-grandpa", "sc-finality-grandpa",
"sc-finality-grandpa-rpc", "sc-finality-grandpa-rpc",
"sc-keystore",
"sc-rpc", "sc-rpc",
"sc-sync-state-rpc", "sc-sync-state-rpc",
"sc-transaction-pool-api", "sc-transaction-pool-api",
...@@ -6690,10 +6628,8 @@ dependencies = [ ...@@ -6690,10 +6628,8 @@ dependencies = [
"pallet-balances", "pallet-balances",
"pallet-beefy-mmr", "pallet-beefy-mmr",
"pallet-election-provider-multi-phase", "pallet-election-provider-multi-phase",
"pallet-offences",
"pallet-session", "pallet-session",
"pallet-staking", "pallet-staking",
"pallet-staking-reward-curve",
"pallet-timestamp", "pallet-timestamp",
"pallet-transaction-payment", "pallet-transaction-payment",
"pallet-treasury", "pallet-treasury",
...@@ -6707,19 +6643,15 @@ dependencies = [ ...@@ -6707,19 +6643,15 @@ dependencies = [
"serde_json", "serde_json",
"slot-range-helper", "slot-range-helper",
"sp-api", "sp-api",
"sp-application-crypto",
"sp-core", "sp-core",
"sp-inherents", "sp-inherents",
"sp-io", "sp-io",
"sp-keyring",
"sp-keystore", "sp-keystore",
"sp-runtime", "sp-runtime",
"sp-session", "sp-session",
"sp-staking", "sp-staking",
"sp-std", "sp-std",
"sp-trie",
"static_assertions", "static_assertions",
"trie-db",
"xcm", "xcm",
] ]
...@@ -6739,14 +6671,10 @@ dependencies = [ ...@@ -6739,14 +6671,10 @@ dependencies = [
"log", "log",
"pallet-authority-discovery", "pallet-authority-discovery",
"pallet-authorship", "pallet-authorship",
"pallet-babe",
"pallet-balances", "pallet-balances",
"pallet-offences",
"pallet-session", "pallet-session",
"pallet-staking", "pallet-staking",
"pallet-staking-reward-curve",
"pallet-timestamp", "pallet-timestamp",
"pallet-treasury",
"pallet-vesting", "pallet-vesting",
"parity-scale-codec", "parity-scale-codec",
"polkadot-primitives", "polkadot-primitives",
...@@ -6755,9 +6683,7 @@ dependencies = [ ...@@ -6755,9 +6683,7 @@ dependencies = [
"rustc-hex", "rustc-hex",
"sc-keystore", "sc-keystore",
"serde", "serde",
"serde_json",
"sp-api", "sp-api",
"sp-application-crypto",
"sp-core", "sp-core",
"sp-inherents", "sp-inherents",
"sp-io", "sp-io",
...@@ -6767,8 +6693,6 @@ dependencies = [ ...@@ -6767,8 +6693,6 @@ dependencies = [
"sp-session", "sp-session",
"sp-staking", "sp-staking",
"sp-std", "sp-std",
"sp-trie",
"sp-version",
"xcm", "xcm",
"xcm-executor", "xcm-executor",
] ]
...@@ -6899,13 +6823,8 @@ dependencies = [ ...@@ -6899,13 +6823,8 @@ dependencies = [
"sc-finality-grandpa", "sc-finality-grandpa",
"sc-service", "sc-service",
"sc-tracing", "sc-tracing",
"sc-transaction-pool",
"sp-api",
"sp-consensus",
"sp-consensus-babe", "sp-consensus-babe",
"sp-inherents",
"sp-keyring", "sp-keyring",
"sp-keystore",
"sp-runtime", "sp-runtime",
"structopt", "structopt",
"test-runner", "test-runner",
...@@ -7210,18 +7129,6 @@ dependencies = [ ...@@ -7210,18 +7129,6 @@ dependencies = [
"output_vt100", "output_vt100",
] ]
[[package]]
name = "pretty_assertions"
version = "0.7.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "1cab0e7c02cf376875e9335e0ba1da535775beb5450d21e1dffca068818ed98b"
dependencies = [
"ansi_term 0.12.1",
"ctor",
"diff",
"output_vt100",
]
[[package]] [[package]]
name = "primitive-types" name = "primitive-types"
version = "0.10.1" version = "0.10.1"
...@@ -7886,7 +7793,6 @@ dependencies = [ ...@@ -7886,7 +7793,6 @@ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
"frame-system-rpc-runtime-api", "frame-system-rpc-runtime-api",
"hex-literal",
"log", "log",
"pallet-authority-discovery", "pallet-authority-discovery",
"pallet-authorship", "pallet-authorship",
...@@ -7908,7 +7814,6 @@ dependencies = [ ...@@ -7908,7 +7814,6 @@ dependencies = [
"pallet-proxy", "pallet-proxy",
"pallet-session", "pallet-session",
"pallet-staking", "pallet-staking",
"pallet-staking-reward-curve",
"pallet-sudo", "pallet-sudo",
"pallet-timestamp", "pallet-timestamp",
"pallet-transaction-payment", "pallet-transaction-payment",
...@@ -10097,13 +10002,10 @@ name = "staking-miner" ...@@ -10097,13 +10002,10 @@ name = "staking-miner"
version = "0.9.9" version = "0.9.9"
dependencies = [ dependencies = [
"env_logger 0.9.0", "env_logger 0.9.0",
"frame-election-provider-support",
"frame-support", "frame-support",
"frame-system", "frame-system",
"hex",
"jsonrpsee-ws-client", "jsonrpsee-ws-client",
"kusama-runtime", "kusama-runtime",
"lazy_static",
"log", "log",
"pallet-balances", "pallet-balances",
"pallet-election-provider-multi-phase", "pallet-election-provider-multi-phase",
...@@ -10120,7 +10022,6 @@ dependencies = [ ...@@ -10120,7 +10022,6 @@ dependencies = [
"serde_json", "serde_json",
"sp-core", "sp-core",
"sp-io", "sp-io",
"sp-npos-elections",
"sp-runtime", "sp-runtime",
"sp-version", "sp-version",
"structopt", "structopt",
...@@ -10484,7 +10385,6 @@ dependencies = [ ...@@ -10484,7 +10385,6 @@ dependencies = [
"polkadot-primitives", "polkadot-primitives",
"polkadot-service", "polkadot-service",
"polkadot-test-service", "polkadot-test-service",
"sc-authority-discovery",
"sc-cli", "sc-cli",
"sc-service", "sc-service",
"sp-core", "sp-core",
...@@ -10507,7 +10407,6 @@ name = "test-parachains" ...@@ -10507,7 +10407,6 @@ name = "test-parachains"
version = "0.9.9" version = "0.9.9"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"polkadot-parachain",
"sp-core", "sp-core",
"test-parachain-adder", "test-parachain-adder",
"test-parachain-halt", "test-parachain-halt",
...@@ -11619,7 +11518,6 @@ dependencies = [ ...@@ -11619,7 +11518,6 @@ dependencies = [
"sp-transaction-pool", "sp-transaction-pool",
"sp-trie", "sp-trie",
"sp-version", "sp-version",
"static_assertions",
"substrate-wasm-builder", "substrate-wasm-builder",
"tiny-keccak", "tiny-keccak",
"xcm", "xcm",
...@@ -11739,7 +11637,6 @@ version = "0.9.9" ...@@ -11739,7 +11637,6 @@ version = "0.9.9"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
"impl-trait-for-tuples",
"pallet-balances", "pallet-balances",
"pallet-transaction-payment", "pallet-transaction-payment",
"pallet-xcm", "pallet-xcm",
...@@ -11825,7 +11722,6 @@ dependencies = [ ...@@ -11825,7 +11722,6 @@ dependencies = [
"