Unverified Commit 7754bea9 authored by Gavin Wood's avatar Gavin Wood Committed by GitHub
Browse files

Update Substrate (#649)

* Bump Substrate

* Bump version

* Reinstate wasmtime

* Fix warning.
parent e5138efc
Pipeline #70905 passed with stages
in 33 minutes and 49 seconds
......@@ -11,11 +11,11 @@ dependencies = [
[[package]]
name = "adder"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"dlmalloc 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.5",
"polkadot-parachain 0.7.6",
"sp-io 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
"tiny-keccak 1.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -25,14 +25,14 @@ dependencies = [
name = "adder-collator"
version = "0.1.0"
dependencies = [
"adder 0.7.5",
"adder 0.7.6",
"ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-collator 0.7.5",
"polkadot-parachain 0.7.5",
"polkadot-primitives 0.7.5",
"polkadot-collator 0.7.6",
"polkadot-parachain 0.7.6",
"polkadot-primitives 0.7.6",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1067,7 +1067,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "fork-tree"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
]
......@@ -1075,7 +1075,7 @@ dependencies = [
[[package]]
name = "frame-executive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1089,7 +1089,7 @@ dependencies = [
[[package]]
name = "frame-metadata"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1100,7 +1100,7 @@ dependencies = [
[[package]]
name = "frame-support"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"bitmask 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-metadata 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1124,7 +1124,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support-procedural-tools 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1135,7 +1135,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support-procedural-tools-derive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1147,7 +1147,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools-derive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
"quote 1.0.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1157,7 +1157,7 @@ dependencies = [
[[package]]
name = "frame-system"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"impl-trait-for-tuples 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1174,7 +1174,7 @@ dependencies = [
[[package]]
name = "frame-system-rpc-runtime-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -1464,7 +1464,7 @@ dependencies = [
[[package]]
name = "grafana-data-source"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"async-std 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"chrono 0.4.9 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -1521,7 +1521,7 @@ dependencies = [
[[package]]
name = "halt"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
]
......@@ -2810,7 +2810,7 @@ dependencies = [
[[package]]
name = "pallet-authority-discovery"
version = "0.1.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2828,7 +2828,7 @@ dependencies = [
[[package]]
name = "pallet-authorship"
version = "0.1.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2845,7 +2845,7 @@ dependencies = [
[[package]]
name = "pallet-babe"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2866,7 +2866,7 @@ dependencies = [
[[package]]
name = "pallet-balances"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2880,7 +2880,7 @@ dependencies = [
[[package]]
name = "pallet-collective"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2896,7 +2896,7 @@ dependencies = [
[[package]]
name = "pallet-democracy"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2911,7 +2911,7 @@ dependencies = [
[[package]]
name = "pallet-elections-phragmen"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2924,7 +2924,7 @@ dependencies = [
[[package]]
name = "pallet-finality-tracker"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2940,7 +2940,7 @@ dependencies = [
[[package]]
name = "pallet-grandpa"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2958,7 +2958,7 @@ dependencies = [
[[package]]
name = "pallet-im-online"
version = "0.1.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2977,7 +2977,7 @@ dependencies = [
[[package]]
name = "pallet-indices"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -2994,7 +2994,7 @@ dependencies = [
[[package]]
name = "pallet-membership"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3008,7 +3008,7 @@ dependencies = [
[[package]]
name = "pallet-nicks"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3022,7 +3022,7 @@ dependencies = [
[[package]]
name = "pallet-offences"
version = "1.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3037,7 +3037,7 @@ dependencies = [
[[package]]
name = "pallet-randomness-collective-flip"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3050,7 +3050,7 @@ dependencies = [
[[package]]
name = "pallet-session"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3069,7 +3069,7 @@ dependencies = [
[[package]]
name = "pallet-staking"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3089,7 +3089,7 @@ dependencies = [
[[package]]
name = "pallet-staking-reward-curve"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3100,7 +3100,7 @@ dependencies = [
[[package]]
name = "pallet-timestamp"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3116,7 +3116,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3129,7 +3129,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"jsonrpc-core 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"jsonrpc-core-client 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3146,7 +3146,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc-runtime-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3159,7 +3159,7 @@ dependencies = [
[[package]]
name = "pallet-treasury"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"frame-support 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"frame-system 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3455,18 +3455,18 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "polkadot"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.5",
"polkadot-service 0.7.5",
"polkadot-cli 0.7.6",
"polkadot-service 0.7.6",
"vergen 3.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "polkadot-availability-store"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3478,9 +3478,9 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-erasure-coding 0.7.5",
"polkadot-primitives 0.7.5",
"polkadot-runtime 0.7.5",
"polkadot-erasure-coding 0.7.6",
"polkadot-primitives 0.7.6",
"polkadot-runtime 0.7.6",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-keystore 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3495,12 +3495,12 @@ dependencies = [
[[package]]
name = "polkadot-cli"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-service 0.7.5",
"polkadot-service 0.7.6",
"sc-cli 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"structopt 0.3.5 (registry+https://github.com/rust-lang/crates.io-index)",
"tokio 0.1.22 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3508,18 +3508,18 @@ dependencies = [
[[package]]
name = "polkadot-collator"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-timer 1.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.5",
"polkadot-network 0.7.5",
"polkadot-primitives 0.7.5",
"polkadot-runtime 0.7.5",
"polkadot-service 0.7.5",
"polkadot-validation 0.7.5",
"polkadot-cli 0.7.6",
"polkadot-network 0.7.6",
"polkadot-primitives 0.7.6",
"polkadot-runtime 0.7.6",
"polkadot-service 0.7.6",
"polkadot-validation 0.7.6",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3531,11 +3531,11 @@ dependencies = [
[[package]]
name = "polkadot-erasure-coding"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"derive_more 0.15.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.5",
"polkadot-primitives 0.7.6",
"reed-solomon-erasure 4.0.0 (git+https://github.com/paritytech/reed-solomon-erasure)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-trie 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3543,15 +3543,15 @@ dependencies = [
[[package]]
name = "polkadot-executor"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"polkadot-runtime 0.7.5",
"polkadot-runtime 0.7.6",
"sc-executor 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
]
[[package]]
name = "polkadot-network"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"arrayvec 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3560,10 +3560,10 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.5",
"polkadot-erasure-coding 0.7.5",
"polkadot-primitives 0.7.5",
"polkadot-validation 0.7.5",
"polkadot-availability-store 0.7.6",
"polkadot-erasure-coding 0.7.6",
"polkadot-primitives 0.7.6",
"polkadot-validation 0.7.6",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3575,11 +3575,11 @@ dependencies = [
[[package]]
name = "polkadot-parachain"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"adder 0.7.5",
"adder 0.7.6",
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
"halt 0.7.5",
"halt 0.7.6",
"lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3594,12 +3594,12 @@ dependencies = [
[[package]]
name = "polkadot-primitives"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.5",
"polkadot-parachain 0.7.6",
"pretty_assertions 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
"sc-application-crypto 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3614,12 +3614,12 @@ dependencies = [
[[package]]
name = "polkadot-rpc"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"jsonrpc-core 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-transaction-payment-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"polkadot-primitives 0.7.5",
"polkadot-runtime 0.7.5",
"polkadot-primitives 0.7.6",
"polkadot-runtime 0.7.6",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-runtime 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3629,7 +3629,7 @@ dependencies = [
[[package]]
name = "polkadot-runtime"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-executive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3662,8 +3662,8 @@ dependencies = [
"pallet-transaction-payment-rpc-runtime-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-treasury 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.5",
"polkadot-primitives 0.7.5",
"polkadot-parachain 0.7.6",
"polkadot-primitives 0.7.6",
"rustc-hex 2.0.1 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3693,7 +3693,7 @@ dependencies = [
[[package]]
name = "polkadot-service"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3705,13 +3705,13 @@ dependencies = [
"pallet-im-online 0.1.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-staking 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.5",
"polkadot-executor 0.7.5",
"polkadot-network 0.7.5",
"polkadot-primitives 0.7.5",
"polkadot-rpc 0.7.5",
"polkadot-runtime 0.7.5",
"polkadot-validation 0.7.5",
"polkadot-availability-store 0.7.6",
"polkadot-executor 0.7.6",
"polkadot-network 0.7.6",
"polkadot-primitives 0.7.6",
"polkadot-rpc 0.7.6",
"polkadot-runtime 0.7.6",
"polkadot-validation 0.7.6",
"sc-authority-discovery 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -3739,16 +3739,16 @@ dependencies = [
[[package]]
name = "polkadot-statement-table"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.5",
"polkadot-primitives 0.7.6",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
]
[[package]]
name = "polkadot-validation"
version = "0.7.5"
version = "0.7.6"
dependencies = [
"async-std 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3761,12 +3761,12 @@ dependencies = [
"pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.5",
"polkadot-erasure-coding 0.7.5",
"polkadot-parachain 0.7.5",
"polkadot-primitives 0.7.5",
"polkadot-runtime 0.7.5",
"polkadot-statement-table 0.7.5",
"polkadot-availability-store 0.7.6",
"polkadot-erasure-coding 0.7.6",
"polkadot-parachain 0.7.6",
"polkadot-primitives 0.7.6",
"polkadot-runtime 0.7.6",
"polkadot-statement-table 0.7.6",
"sc-block-builder 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-finality-grandpa 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4290,7 +4290,7 @@ dependencies = [
[[package]]
name = "sc-application-crypto"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4302,7 +4302,7 @@ dependencies = [
[[package]]
name = "sc-authority-discovery"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"bytes 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4326,7 +4326,7 @@ dependencies = [
[[package]]
name = "sc-block-builder"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4340,7 +4340,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"impl-trait-for-tuples 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"sc-chain-spec-derive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4355,7 +4355,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec-derive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"proc-macro-crate 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"proc-macro2 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4366,7 +4366,7 @@ dependencies = [
[[package]]
name = "sc-cli"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"ansi_term 0.12.1 (registry+https://github.com/rust-lang/crates.io-index)",
"app_dirs 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4402,7 +4402,7 @@ dependencies = [
[[package]]
name = "sc-client"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4435,7 +4435,7 @@ dependencies = [
[[package]]
name = "sc-client-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4467,7 +4467,7 @@ dependencies = [
[[package]]
name = "sc-client-db"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"hash-db 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"kvdb 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4492,7 +4492,7 @@ dependencies = [
[[package]]
name = "sc-consensus-babe"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"fork-tree 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......@@ -4532,7 +4532,7 @@ dependencies = [
[[package]]
name = "sc-consensus-slots"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#042dc459f3875d65bec412068ba1939172c5e8c2"
source = "git+https://github.com/paritytech/substrate?branch=polkadot-master#6e242a5a9fcc5d5ea34386864ec064a01677efff"
dependencies = [
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-timer 2.0.2 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4551,7 +4551,7 @@ dependencies = [
[[package]]