Unverified Commit 702fc938 authored by André Silva's avatar André Silva Committed by GitHub
Browse files

runtime: remove finality-tracker (#1762)

* runtime: remove finality-tracker

* runtime: bump spec_version

* update substrate
parent 5dd3bd8f
Pipeline #110738 passed with stages
in 21 minutes and 51 seconds
......@@ -1429,7 +1429,7 @@ checksum = "3f9eec918d3f24069decb9af1554cad7c880e2da24a9afd88aca000531ab82c1"
[[package]]
name = "fork-tree"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"parity-scale-codec",
]
......@@ -1437,7 +1437,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -1455,7 +1455,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking-cli"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"chrono",
"frame-benchmarking",
......@@ -1475,7 +1475,7 @@ dependencies = [
[[package]]
name = "frame-executive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -1491,7 +1491,7 @@ dependencies = [
[[package]]
name = "frame-metadata"
version = "12.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"parity-scale-codec",
"serde",
......@@ -1502,7 +1502,7 @@ dependencies = [
[[package]]
name = "frame-support"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"bitmask",
"frame-metadata",
......@@ -1527,7 +1527,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support-procedural-tools",
"proc-macro2 1.0.18",
......@@ -1538,7 +1538,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support-procedural-tools-derive",
"proc-macro-crate",
......@@ -1550,7 +1550,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools-derive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"proc-macro2 1.0.18",
"quote 1.0.7",
......@@ -1560,7 +1560,7 @@ dependencies = [
[[package]]
name = "frame-system"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"impl-trait-for-tuples",
......@@ -1576,7 +1576,7 @@ dependencies = [
[[package]]
name = "frame-system-benchmarking"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -1590,7 +1590,7 @@ dependencies = [
[[package]]
name = "frame-system-rpc-runtime-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"parity-scale-codec",
"sp-api",
......@@ -2567,7 +2567,6 @@ dependencies = [
"pallet-collective",
"pallet-democracy",
"pallet-elections-phragmen",
"pallet-finality-tracker",
"pallet-grandpa",
"pallet-identity",
"pallet-im-online",
......@@ -3758,7 +3757,7 @@ dependencies = [
[[package]]
name = "pallet-authority-discovery"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -3774,7 +3773,7 @@ dependencies = [
[[package]]
name = "pallet-authorship"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -3789,7 +3788,7 @@ dependencies = [
[[package]]
name = "pallet-babe"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3814,7 +3813,7 @@ dependencies = [
[[package]]
name = "pallet-balances"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3828,7 +3827,7 @@ dependencies = [
[[package]]
name = "pallet-collective"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3844,7 +3843,7 @@ dependencies = [
[[package]]
name = "pallet-democracy"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3859,7 +3858,7 @@ dependencies = [
[[package]]
name = "pallet-elections-phragmen"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3871,32 +3870,15 @@ dependencies = [
"sp-std",
]
[[package]]
name = "pallet-finality-tracker"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
dependencies = [
"frame-support",
"frame-system",
"impl-trait-for-tuples",
"parity-scale-codec",
"serde",
"sp-finality-tracker",
"sp-inherents",
"sp-runtime",
"sp-std",
]
[[package]]
name = "pallet-grandpa"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"pallet-authorship",
"pallet-finality-tracker",
"pallet-session",
"parity-scale-codec",
"serde",
......@@ -3912,7 +3894,7 @@ dependencies = [
[[package]]
name = "pallet-identity"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"enumflags2",
"frame-benchmarking",
......@@ -3928,7 +3910,7 @@ dependencies = [
[[package]]
name = "pallet-im-online"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3948,7 +3930,7 @@ dependencies = [
[[package]]
name = "pallet-indices"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3965,7 +3947,7 @@ dependencies = [
[[package]]
name = "pallet-membership"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -3979,7 +3961,7 @@ dependencies = [
[[package]]
name = "pallet-multisig"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3995,7 +3977,7 @@ dependencies = [
[[package]]
name = "pallet-nicks"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -4009,7 +3991,7 @@ dependencies = [
[[package]]
name = "pallet-offences"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -4024,7 +4006,7 @@ dependencies = [
[[package]]
name = "pallet-offences-benchmarking"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4045,7 +4027,7 @@ dependencies = [
[[package]]
name = "pallet-proxy"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4061,7 +4043,7 @@ dependencies = [
[[package]]
name = "pallet-randomness-collective-flip"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -4074,7 +4056,7 @@ dependencies = [
[[package]]
name = "pallet-recovery"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"enumflags2",
"frame-support",
......@@ -4089,7 +4071,7 @@ dependencies = [
[[package]]
name = "pallet-scheduler"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4104,7 +4086,7 @@ dependencies = [
[[package]]
name = "pallet-session"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -4124,7 +4106,7 @@ dependencies = [
[[package]]
name = "pallet-session-benchmarking"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4140,7 +4122,7 @@ dependencies = [
[[package]]
name = "pallet-society"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -4154,7 +4136,7 @@ dependencies = [
[[package]]
name = "pallet-staking"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4176,7 +4158,7 @@ dependencies = [
[[package]]
name = "pallet-staking-reward-curve"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"proc-macro-crate",
"proc-macro2 1.0.18",
......@@ -4187,7 +4169,7 @@ dependencies = [
[[package]]
name = "pallet-sudo"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -4201,7 +4183,7 @@ dependencies = [
[[package]]
name = "pallet-timestamp"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4219,7 +4201,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"frame-system",
......@@ -4236,7 +4218,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"jsonrpc-core",
"jsonrpc-core-client",
......@@ -4254,7 +4236,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc-runtime-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-support",
"parity-scale-codec",
......@@ -4267,7 +4249,7 @@ dependencies = [
[[package]]
name = "pallet-treasury"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4282,7 +4264,7 @@ dependencies = [
[[package]]
name = "pallet-utility"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4298,7 +4280,7 @@ dependencies = [
[[package]]
name = "pallet-vesting"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"enumflags2",
"frame-benchmarking",
......@@ -5246,7 +5228,6 @@ dependencies = [
"pallet-collective",
"pallet-democracy",
"pallet-elections-phragmen",
"pallet-finality-tracker",
"pallet-grandpa",
"pallet-identity",
"pallet-im-online",
......@@ -5508,7 +5489,6 @@ dependencies = [
"pallet-authorship",
"pallet-babe",
"pallet-balances",
"pallet-finality-tracker",
"pallet-grandpa",
"pallet-indices",
"pallet-nicks",
......@@ -6464,7 +6444,7 @@ dependencies = [
[[package]]
name = "sc-authority-discovery"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"bytes 0.5.6",
"derive_more 0.99.11",
......@@ -6493,7 +6473,7 @@ dependencies = [
[[package]]
name = "sc-basic-authorship"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"futures 0.3.5",
"futures-timer 3.0.2",
......@@ -6517,7 +6497,7 @@ dependencies = [
[[package]]
name = "sc-block-builder"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"parity-scale-codec",
"sc-client-api",
......@@ -6534,7 +6514,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"impl-trait-for-tuples",
"parity-scale-codec",
......@@ -6555,7 +6535,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec-derive"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"proc-macro-crate",
"proc-macro2 1.0.18",
......@@ -6566,7 +6546,7 @@ dependencies = [
[[package]]
name = "sc-cli"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"ansi_term 0.12.1",
"atty",
......@@ -6619,7 +6599,7 @@ dependencies = [
[[package]]
name = "sc-client-api"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"derive_more 0.99.11",
"fnv",
......@@ -6656,7 +6636,7 @@ dependencies = [
[[package]]
name = "sc-client-db"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"blake2-rfc",
"hash-db",
......@@ -6686,7 +6666,7 @@ dependencies = [
[[package]]
name = "sc-consensus"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"sc-client-api",
"sp-blockchain",
......@@ -6697,7 +6677,7 @@ dependencies = [
[[package]]
name = "sc-consensus-babe"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"derive_more 0.99.11",
"fork-tree",
......@@ -6742,7 +6722,7 @@ dependencies = [
[[package]]
name = "sc-consensus-babe-rpc"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"derive_more 0.99.11",
"futures 0.3.5",
......@@ -6766,7 +6746,7 @@ dependencies = [
[[package]]
name = "sc-consensus-epochs"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"fork-tree",
"parity-scale-codec",
......@@ -6779,7 +6759,7 @@ dependencies = [
[[package]]
name = "sc-consensus-slots"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"futures 0.3.5",
"futures-timer 3.0.2",
......@@ -6802,7 +6782,7 @@ dependencies = [
[[package]]
name = "sc-consensus-uncles"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"log 0.4.11",
"sc-client-api",
......@@ -6816,7 +6796,7 @@ dependencies = [
[[package]]
name = "sc-executor"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"derive_more 0.99.11",
"lazy_static",
......@@ -6844,7 +6824,7 @@ dependencies = [
[[package]]
name = "sc-executor-common"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"derive_more 0.99.11",
"log 0.4.11",
......@@ -6861,7 +6841,7 @@ dependencies = [
[[package]]
name = "sc-executor-wasmi"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"log 0.4.11",
"parity-scale-codec",
......@@ -6876,7 +6856,7 @@ dependencies = [
[[package]]
name = "sc-executor-wasmtime"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"log 0.4.11",
"parity-scale-codec",
......@@ -6894,7 +6874,7 @@ dependencies = [
[[package]]
name = "sc-finality-grandpa"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"derive_more 0.99.11",
"finality-grandpa",
......@@ -6921,7 +6901,6 @@ dependencies = [
"sp-consensus",
"sp-core",
"sp-finality-grandpa",
"sp-finality-tracker",
"sp-inherents",
"sp-keystore",
"sp-runtime",
......@@ -6932,7 +6911,7 @@ dependencies = [
[[package]]
name = "sc-finality-grandpa-rpc"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"derive_more 0.99.11",
"finality-grandpa",
......@@ -6956,7 +6935,7 @@ dependencies = [
[[package]]
name = "sc-informant"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"ansi_term 0.12.1",
"futures 0.3.5",
......@@ -6974,7 +6953,7 @@ dependencies = [
[[package]]
name = "sc-keystore"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"async-trait",
"derive_more 0.99.11",
......@@ -6994,7 +6973,7 @@ dependencies = [
[[package]]
name = "sc-light"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"hash-db",
"lazy_static",
......@@ -7013,7 +6992,7 @@ dependencies = [
[[package]]
name = "sc-network"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"async-std",
"async-trait",
......@@ -7067,7 +7046,7 @@ dependencies = [
[[package]]
name = "sc-network-gossip"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"futures 0.3.5",
"futures-timer 3.0.2",
......@@ -7082,7 +7061,7 @@ dependencies = [
[[package]]
name = "sc-offchain"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"bytes 0.5.6",
"fnv",
......@@ -7109,7 +7088,7 @@ dependencies = [
[[package]]
name = "sc-peerset"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"futures 0.3.5",
"libp2p",
......@@ -7122,7 +7101,7 @@ dependencies = [
[[package]]
name = "sc-proposer-metrics"
version = "0.8.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"log 0.4.11",
"substrate-prometheus-endpoint",
......@@ -7131,7 +7110,7 @@ dependencies = [
[[package]]
name = "sc-rpc"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#65cc9af9b8df8d36928f6144ee7474cefbd70454"
source = "git+https://github.com/paritytech/substrate#cefcd99d5156bfe3476124f356cd54083a43a49d"
dependencies = [
"futures 0.3.5",
"hash-db",
......@@ -7164,7 +7143,7 @@ dependencies = [