Unverified Commit 685dc4e2 authored by Martin Pugh's avatar Martin Pugh Committed by GitHub
Browse files

Bump version, spec_version & substrate in prep for release v0.9.5 (#3238)

* bump spec_version and version

* bump substrate

* remove migrations

* Revert "remove migrations"

This reverts commit ceeab924.

* remove stale migration for kusama + westend
parent f91c8ee4
Pipeline #142309 passed with stages
in 36 minutes and 7 seconds
# This file is automatically @generated by Cargo. # This file is automatically @generated by Cargo.
# It is not intended for manual editing. # It is not intended for manual editing.
version = 3
[[package]] [[package]]
name = "Inflector" name = "Inflector"
version = "0.11.4" version = "0.11.4"
...@@ -479,7 +481,7 @@ dependencies = [ ...@@ -479,7 +481,7 @@ dependencies = [
[[package]] [[package]]
name = "beefy-gadget" name = "beefy-gadget"
version = "0.1.0" version = "0.1.0"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget#a58179d4f59f4c31c7a09d5b0ce14df8450743a3" source = "git+https://github.com/paritytech/grandpa-bridge-gadget?branch=master#a58179d4f59f4c31c7a09d5b0ce14df8450743a3"
dependencies = [ dependencies = [
"beefy-primitives", "beefy-primitives",
"futures 0.3.15", "futures 0.3.15",
...@@ -507,7 +509,7 @@ dependencies = [ ...@@ -507,7 +509,7 @@ dependencies = [
[[package]] [[package]]
name = "beefy-gadget-rpc" name = "beefy-gadget-rpc"
version = "0.1.0" version = "0.1.0"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget#a58179d4f59f4c31c7a09d5b0ce14df8450743a3" source = "git+https://github.com/paritytech/grandpa-bridge-gadget?branch=master#a58179d4f59f4c31c7a09d5b0ce14df8450743a3"
dependencies = [ dependencies = [
"beefy-gadget", "beefy-gadget",
"beefy-primitives", "beefy-primitives",
...@@ -528,7 +530,7 @@ dependencies = [ ...@@ -528,7 +530,7 @@ dependencies = [
[[package]] [[package]]
name = "beefy-primitives" name = "beefy-primitives"
version = "0.1.0" version = "0.1.0"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget#a58179d4f59f4c31c7a09d5b0ce14df8450743a3" source = "git+https://github.com/paritytech/grandpa-bridge-gadget?branch=master#a58179d4f59f4c31c7a09d5b0ce14df8450743a3"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"sp-api", "sp-api",
...@@ -3231,7 +3233,7 @@ dependencies = [ ...@@ -3231,7 +3233,7 @@ dependencies = [
[[package]] [[package]]
name = "kusama-runtime" name = "kusama-runtime"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"beefy-primitives", "beefy-primitives",
"bitvec", "bitvec",
...@@ -4623,7 +4625,7 @@ dependencies = [ ...@@ -4623,7 +4625,7 @@ dependencies = [
[[package]] [[package]]
name = "pallet-beefy" name = "pallet-beefy"
version = "0.1.0" version = "0.1.0"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget#a58179d4f59f4c31c7a09d5b0ce14df8450743a3" source = "git+https://github.com/paritytech/grandpa-bridge-gadget?branch=master#a58179d4f59f4c31c7a09d5b0ce14df8450743a3"
dependencies = [ dependencies = [
"beefy-primitives", "beefy-primitives",
"frame-support", "frame-support",
...@@ -5681,7 +5683,7 @@ checksum = "989d43012e2ca1c4a02507c67282691a0a3207f9dc67cec596b43fe925b3d325" ...@@ -5681,7 +5683,7 @@ checksum = "989d43012e2ca1c4a02507c67282691a0a3207f9dc67cec596b43fe925b3d325"
[[package]] [[package]]
name = "polkadot" name = "polkadot"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"assert_cmd", "assert_cmd",
"color-eyre", "color-eyre",
...@@ -5793,7 +5795,7 @@ dependencies = [ ...@@ -5793,7 +5795,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-cli" name = "polkadot-cli"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"frame-benchmarking-cli", "frame-benchmarking-cli",
"futures 0.3.15", "futures 0.3.15",
...@@ -5870,7 +5872,7 @@ dependencies = [ ...@@ -5870,7 +5872,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-core-primitives" name = "polkadot-core-primitives"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"parity-util-mem", "parity-util-mem",
...@@ -5881,7 +5883,7 @@ dependencies = [ ...@@ -5881,7 +5883,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-erasure-coding" name = "polkadot-erasure-coding"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"polkadot-node-primitives", "polkadot-node-primitives",
...@@ -6380,7 +6382,7 @@ dependencies = [ ...@@ -6380,7 +6382,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-parachain" name = "polkadot-parachain"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"derive_more", "derive_more",
"parity-scale-codec", "parity-scale-codec",
...@@ -6394,7 +6396,7 @@ dependencies = [ ...@@ -6394,7 +6396,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-primitives" name = "polkadot-primitives"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"bitvec", "bitvec",
"frame-system", "frame-system",
...@@ -6447,7 +6449,7 @@ dependencies = [ ...@@ -6447,7 +6449,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-rpc" name = "polkadot-rpc"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"beefy-gadget", "beefy-gadget",
"beefy-gadget-rpc", "beefy-gadget-rpc",
...@@ -6479,7 +6481,7 @@ dependencies = [ ...@@ -6479,7 +6481,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-runtime" name = "polkadot-runtime"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"beefy-primitives", "beefy-primitives",
"bitvec", "bitvec",
...@@ -6562,7 +6564,7 @@ dependencies = [ ...@@ -6562,7 +6564,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-runtime-common" name = "polkadot-runtime-common"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"beefy-primitives", "beefy-primitives",
"bitvec", "bitvec",
...@@ -6615,7 +6617,7 @@ dependencies = [ ...@@ -6615,7 +6617,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-runtime-parachains" name = "polkadot-runtime-parachains"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"bitvec", "bitvec",
"derive_more", "derive_more",
...@@ -6666,7 +6668,7 @@ dependencies = [ ...@@ -6666,7 +6668,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-service" name = "polkadot-service"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"beefy-gadget", "beefy-gadget",
"beefy-primitives", "beefy-primitives",
...@@ -6786,7 +6788,7 @@ dependencies = [ ...@@ -6786,7 +6788,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-statement-table" name = "polkadot-statement-table"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"polkadot-primitives", "polkadot-primitives",
...@@ -6795,7 +6797,7 @@ dependencies = [ ...@@ -6795,7 +6797,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-test-client" name = "polkadot-test-client"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"futures 0.3.15", "futures 0.3.15",
"parity-scale-codec", "parity-scale-codec",
...@@ -6821,7 +6823,7 @@ dependencies = [ ...@@ -6821,7 +6823,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-test-runtime" name = "polkadot-test-runtime"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"beefy-primitives", "beefy-primitives",
"bitvec", "bitvec",
...@@ -6883,7 +6885,7 @@ dependencies = [ ...@@ -6883,7 +6885,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-test-service" name = "polkadot-test-service"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"frame-benchmarking", "frame-benchmarking",
"frame-system", "frame-system",
...@@ -7602,7 +7604,7 @@ dependencies = [ ...@@ -7602,7 +7604,7 @@ dependencies = [
[[package]] [[package]]
name = "rococo-runtime" name = "rococo-runtime"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"beefy-primitives", "beefy-primitives",
"bp-rococo", "bp-rococo",
...@@ -9145,7 +9147,7 @@ dependencies = [ ...@@ -9145,7 +9147,7 @@ dependencies = [
[[package]] [[package]]
name = "slot-range-helper" name = "slot-range-helper"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"enumn", "enumn",
"parity-scale-codec", "parity-scale-codec",
...@@ -10297,7 +10299,7 @@ dependencies = [ ...@@ -10297,7 +10299,7 @@ dependencies = [
[[package]] [[package]]
name = "test-parachain-adder" name = "test-parachain-adder"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"dlmalloc", "dlmalloc",
"parity-scale-codec", "parity-scale-codec",
...@@ -10310,7 +10312,7 @@ dependencies = [ ...@@ -10310,7 +10312,7 @@ dependencies = [
[[package]] [[package]]
name = "test-parachain-adder-collator" name = "test-parachain-adder-collator"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"futures 0.3.15", "futures 0.3.15",
"futures-timer 3.0.2", "futures-timer 3.0.2",
...@@ -10337,14 +10339,14 @@ dependencies = [ ...@@ -10337,14 +10339,14 @@ dependencies = [
[[package]] [[package]]
name = "test-parachain-halt" name = "test-parachain-halt"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"substrate-wasm-builder", "substrate-wasm-builder",
] ]
[[package]] [[package]]
name = "test-parachains" name = "test-parachains"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"polkadot-parachain", "polkadot-parachain",
...@@ -11622,7 +11624,7 @@ dependencies = [ ...@@ -11622,7 +11624,7 @@ dependencies = [
[[package]] [[package]]
name = "westend-runtime" name = "westend-runtime"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"beefy-primitives", "beefy-primitives",
"bitvec", "bitvec",
...@@ -11816,7 +11818,7 @@ dependencies = [ ...@@ -11816,7 +11818,7 @@ dependencies = [
[[package]] [[package]]
name = "xcm" name = "xcm"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"derivative", "derivative",
"impl-trait-for-tuples", "impl-trait-for-tuples",
...@@ -11825,7 +11827,7 @@ dependencies = [ ...@@ -11825,7 +11827,7 @@ dependencies = [
[[package]] [[package]]
name = "xcm-builder" name = "xcm-builder"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -11843,7 +11845,7 @@ dependencies = [ ...@@ -11843,7 +11845,7 @@ dependencies = [
[[package]] [[package]]
name = "xcm-executor" name = "xcm-executor"
version = "0.9.4" version = "0.9.5"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"impl-trait-for-tuples", "impl-trait-for-tuples",
......
...@@ -6,7 +6,7 @@ path = "src/main.rs" ...@@ -6,7 +6,7 @@ path = "src/main.rs"
name = "polkadot" name = "polkadot"
description = "Implementation of a https://polkadot.network node in Rust based on the Substrate framework." description = "Implementation of a https://polkadot.network node in Rust based on the Substrate framework."
license = "GPL-3.0-only" license = "GPL-3.0-only"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
readme = "README.md" readme = "README.md"
......
[package] [package]
name = "polkadot-cli" name = "polkadot-cli"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Polkadot Relay-chain Client Node" description = "Polkadot Relay-chain Client Node"
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-core-primitives" name = "polkadot-core-primitives"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-erasure-coding" name = "polkadot-erasure-coding"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-service" name = "polkadot-service"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-test-client" name = "polkadot-test-client"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-test-service" name = "polkadot-test-service"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-parachain" name = "polkadot-parachain"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Types and utilities for creating and working with parachains" description = "Types and utilities for creating and working with parachains"
edition = "2018" edition = "2018"
......
[package] [package]
name = "test-parachains" name = "test-parachains"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Integration tests using the test-parachains" description = "Integration tests using the test-parachains"
edition = "2018" edition = "2018"
......
[package] [package]
name = "test-parachain-adder" name = "test-parachain-adder"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Test parachain which adds to a number as its state transition" description = "Test parachain which adds to a number as its state transition"
edition = "2018" edition = "2018"
......
[package] [package]
name = "test-parachain-adder-collator" name = "test-parachain-adder-collator"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Collator for the adder test parachain" description = "Collator for the adder test parachain"
edition = "2018" edition = "2018"
......
[package] [package]
name = "test-parachain-halt" name = "test-parachain-halt"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Test parachain which executes forever" description = "Test parachain which executes forever"
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-primitives" name = "polkadot-primitives"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-rpc" name = "polkadot-rpc"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-runtime-common" name = "polkadot-runtime-common"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "slot-range-helper" name = "slot-range-helper"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "kusama-runtime" name = "kusama-runtime"
version = "0.9.4" version = "0.9.5"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
build = "build.rs" build = "build.rs"
......
...@@ -120,7 +120,7 @@ pub const VERSION: RuntimeVersion = RuntimeVersion { ...@@ -120,7 +120,7 @@ pub const VERSION: RuntimeVersion = RuntimeVersion {
spec_name: create_runtime_str!("kusama"), spec_name: create_runtime_str!("kusama"),
impl_name: create_runtime_str!("parity-kusama"), impl_name: create_runtime_str!("parity-kusama"),
authoring_version: 2, authoring_version: 2,
spec_version: 9041, spec_version: 9050,
impl_version: 0, impl_version: 0,
#[cfg(not(feature = "disable-runtime-api"))] #[cfg(not(feature = "disable-runtime-api"))]
apis: RUNTIME_API_VERSIONS, apis: RUNTIME_API_VERSIONS,
...@@ -1480,31 +1480,6 @@ construct_runtime! { ...@@ -1480,31 +1480,6 @@ construct_runtime! {
} }
} }
pub struct GrandpaStoragePrefixMigration;
impl frame_support::traits::OnRuntimeUpgrade for GrandpaStoragePrefixMigration {
fn on_runtime_upgrade() -> frame_support::weights::Weight {
use frame_support::traits::PalletInfo;
let name = <Runtime as frame_system::Config>::PalletInfo::name::<Grandpa>()
.expect("grandpa is part of pallets in construct_runtime, so it has a name; qed");
pallet_grandpa::migrations::v3_1::migrate::<Runtime, Grandpa, _>(name)