Unverified Commit 664c6eca authored by Qinxuan Chen's avatar Qinxuan Chen Committed by GitHub
Browse files

Companion for substrate#9197 (#3359)



* Companion for substrate#9197

Signed-off-by: default avatarkoushiro <koushiro.cqx@gmail.com>

* update Substrate

Co-authored-by: Shawn Tabrizi's avatarShawn Tabrizi <shawntabrizi@gmail.com>
Co-authored-by: parity-processbot <>
parent a08a663e
Pipeline #147081 passed with stages
in 40 minutes and 1 second
......@@ -1970,7 +1970,7 @@ checksum = "3f9eec918d3f24069decb9af1554cad7c880e2da24a9afd88aca000531ab82c1"
[[package]]
name = "fork-tree"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"parity-scale-codec",
]
......@@ -1988,7 +1988,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -2007,7 +2007,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking-cli"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"Inflector",
"chrono",
......@@ -2031,7 +2031,7 @@ dependencies = [
[[package]]
name = "frame-election-provider-support"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -2044,7 +2044,7 @@ dependencies = [
[[package]]
name = "frame-executive"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -2059,7 +2059,7 @@ dependencies = [
[[package]]
name = "frame-metadata"
version = "14.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"parity-scale-codec",
"serde",
......@@ -2070,7 +2070,7 @@ dependencies = [
[[package]]
name = "frame-support"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"bitflags",
"frame-metadata",
......@@ -2096,7 +2096,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"Inflector",
"frame-support-procedural-tools",
......@@ -2108,7 +2108,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support-procedural-tools-derive",
"proc-macro-crate 1.0.0",
......@@ -2120,7 +2120,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools-derive"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"proc-macro2",
"quote",
......@@ -2130,7 +2130,7 @@ dependencies = [
[[package]]
name = "frame-support-test"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-metadata",
"frame-support",
......@@ -2150,7 +2150,7 @@ dependencies = [
[[package]]
name = "frame-system"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"impl-trait-for-tuples",
......@@ -2167,7 +2167,7 @@ dependencies = [
[[package]]
name = "frame-system-benchmarking"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -2181,7 +2181,7 @@ dependencies = [
[[package]]
name = "frame-system-rpc-runtime-api"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"parity-scale-codec",
"sp-api",
......@@ -2190,7 +2190,7 @@ dependencies = [
[[package]]
name = "frame-try-runtime"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"parity-scale-codec",
......@@ -4611,7 +4611,7 @@ checksum = "13370dae44474229701bb69b90b4f4dca6404cb0357a2d50d635f1171dc3aa7b"
[[package]]
name = "pallet-authority-discovery"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -4626,7 +4626,7 @@ dependencies = [
[[package]]
name = "pallet-authorship"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -4640,7 +4640,7 @@ dependencies = [
[[package]]
name = "pallet-babe"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4663,7 +4663,7 @@ dependencies = [
[[package]]
name = "pallet-balances"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4692,7 +4692,7 @@ dependencies = [
[[package]]
name = "pallet-bounties"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4770,7 +4770,7 @@ dependencies = [
[[package]]
name = "pallet-collective"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4786,7 +4786,7 @@ dependencies = [
[[package]]
name = "pallet-democracy"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4801,7 +4801,7 @@ dependencies = [
[[package]]
name = "pallet-election-provider-multi-phase"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-election-provider-support",
......@@ -4822,7 +4822,7 @@ dependencies = [
[[package]]
name = "pallet-elections-phragmen"
version = "5.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4839,7 +4839,7 @@ dependencies = [
[[package]]
name = "pallet-gilt"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4853,7 +4853,7 @@ dependencies = [
[[package]]
name = "pallet-grandpa"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4875,7 +4875,7 @@ dependencies = [
[[package]]
name = "pallet-identity"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"enumflags2",
"frame-benchmarking",
......@@ -4890,7 +4890,7 @@ dependencies = [
[[package]]
name = "pallet-im-online"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4909,7 +4909,7 @@ dependencies = [
[[package]]
name = "pallet-indices"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4925,7 +4925,7 @@ dependencies = [
[[package]]
name = "pallet-membership"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4940,7 +4940,7 @@ dependencies = [
[[package]]
name = "pallet-mmr"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"ckb-merkle-mountain-range",
"frame-benchmarking",
......@@ -4957,7 +4957,7 @@ dependencies = [
[[package]]
name = "pallet-mmr-primitives"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -4973,7 +4973,7 @@ dependencies = [
[[package]]
name = "pallet-mmr-rpc"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"jsonrpc-core",
"jsonrpc-core-client",
......@@ -4991,7 +4991,7 @@ dependencies = [
[[package]]
name = "pallet-multisig"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5006,7 +5006,7 @@ dependencies = [
[[package]]
name = "pallet-nicks"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -5019,7 +5019,7 @@ dependencies = [
[[package]]
name = "pallet-offences"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -5035,7 +5035,7 @@ dependencies = [
[[package]]
name = "pallet-offences-benchmarking"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-election-provider-support",
......@@ -5057,7 +5057,7 @@ dependencies = [
[[package]]
name = "pallet-proxy"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5072,7 +5072,7 @@ dependencies = [
[[package]]
name = "pallet-recovery"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"enumflags2",
"frame-support",
......@@ -5086,7 +5086,7 @@ dependencies = [
[[package]]
name = "pallet-scheduler"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5101,7 +5101,7 @@ dependencies = [
[[package]]
name = "pallet-session"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -5121,7 +5121,7 @@ dependencies = [
[[package]]
name = "pallet-session-benchmarking"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5137,7 +5137,7 @@ dependencies = [
[[package]]
name = "pallet-society"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -5150,7 +5150,7 @@ dependencies = [
[[package]]
name = "pallet-staking"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-election-provider-support",
......@@ -5174,7 +5174,7 @@ dependencies = [
[[package]]
name = "pallet-staking-reward-curve"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"proc-macro-crate 1.0.0",
"proc-macro2",
......@@ -5185,7 +5185,7 @@ dependencies = [
[[package]]
name = "pallet-staking-reward-fn"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"log",
"sp-arithmetic",
......@@ -5194,7 +5194,7 @@ dependencies = [
[[package]]
name = "pallet-sudo"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -5207,7 +5207,7 @@ dependencies = [
[[package]]
name = "pallet-timestamp"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5225,7 +5225,7 @@ dependencies = [
[[package]]
name = "pallet-tips"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5240,7 +5240,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-support",
"frame-system",
......@@ -5256,7 +5256,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"jsonrpc-core",
"jsonrpc-core-client",
......@@ -5273,7 +5273,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc-runtime-api"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"pallet-transaction-payment",
"parity-scale-codec",
......@@ -5284,7 +5284,7 @@ dependencies = [
[[package]]
name = "pallet-treasury"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5300,7 +5300,7 @@ dependencies = [
[[package]]
name = "pallet-utility"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5315,7 +5315,7 @@ dependencies = [
[[package]]
name = "pallet-vesting"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"enumflags2",
"frame-benchmarking",
......@@ -7719,7 +7719,7 @@ dependencies = [
[[package]]
name = "remote-externalities"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"env_logger 0.8.4",
"hex",
......@@ -8017,7 +8017,7 @@ dependencies = [
[[package]]
name = "sc-allocator"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"log",
"sp-core",
......@@ -8028,7 +8028,7 @@ dependencies = [
[[package]]
name = "sc-authority-discovery"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"async-trait",
"derive_more",
......@@ -8057,7 +8057,7 @@ dependencies = [
[[package]]
name = "sc-basic-authorship"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"futures 0.3.15",
"futures-timer 3.0.2",
......@@ -8080,7 +8080,7 @@ dependencies = [
[[package]]
name = "sc-block-builder"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"parity-scale-codec",
"sc-client-api",
......@@ -8096,7 +8096,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"impl-trait-for-tuples",
"parity-scale-codec",
......@@ -8116,7 +8116,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec-derive"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"proc-macro-crate 1.0.0",
"proc-macro2",
......@@ -8127,7 +8127,7 @@ dependencies = [
[[package]]
name = "sc-cli"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"chrono",
"fdlimit",
......@@ -8165,7 +8165,7 @@ dependencies = [
[[package]]
name = "sc-client-api"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"derive_more",
"fnv",
......@@ -8199,7 +8199,7 @@ dependencies = [
[[package]]
name = "sc-client-db"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"blake2-rfc",
"hash-db",
......@@ -8229,7 +8229,7 @@ dependencies = [
[[package]]
name = "sc-consensus"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"async-trait",
"parking_lot 0.11.1",
......@@ -8242,7 +8242,7 @@ dependencies = [
[[package]]
name = "sc-consensus-babe"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"async-trait",
"derive_more",
......@@ -8288,7 +8288,7 @@ dependencies = [
[[package]]
name = "sc-consensus-babe-rpc"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"derive_more",
"futures 0.3.15",
......@@ -8312,7 +8312,7 @@ dependencies = [
[[package]]
name = "sc-consensus-epochs"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"fork-tree",
"parity-scale-codec",
......@@ -8325,7 +8325,7 @@ dependencies = [
[[package]]
name = "sc-consensus-slots"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"async-trait",
"futures 0.3.15",
......@@ -8353,7 +8353,7 @@ dependencies = [
[[package]]
name = "sc-consensus-uncles"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"sc-client-api",
"sp-authorship",
......@@ -8364,7 +8364,7 @@ dependencies = [
[[package]]
name = "sc-executor"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"derive_more",
"lazy_static",
......@@ -8393,7 +8393,7 @@ dependencies = [
[[package]]
name = "sc-executor-common"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"derive_more",
"parity-scale-codec",
......@@ -8410,7 +8410,7 @@ dependencies = [
[[package]]
name = "sc-executor-wasmi"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"log",
"parity-scale-codec",
......@@ -8425,7 +8425,7 @@ dependencies = [
[[package]]
name = "sc-executor-wasmtime"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"cfg-if 1.0.0",
"libc",
......@@ -8445,7 +8445,7 @@ dependencies = [
[[package]]
name = "sc-finality-grandpa"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"async-trait",
"derive_more",
......@@ -8486,7 +8486,7 @@ dependencies = [
[[package]]
name = "sc-finality-grandpa-rpc"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"derive_more",
"finality-grandpa",
......@@ -8510,7 +8510,7 @@ dependencies = [
[[package]]
name = "sc-finality-grandpa-warp-sync"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"derive_more",
"futures 0.3.15",
......@@ -8531,7 +8531,7 @@ dependencies = [
[[package]]
name = "sc-informant"
version = "0.10.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"ansi_term 0.12.1",
"futures 0.3.15",
......@@ -8549,7 +8549,7 @@ dependencies = [
[[package]]
name = "sc-keystore"
version = "4.0.0-dev"
source = "git+https://github.com/paritytech/substrate?branch=master#2543f6f6d80b374da8a2986a258987f20c0c28c6"
source = "git+https://github.com/paritytech/substrate?branch=master#e0638a1a518fe3f93269f1db4360ae9b4cc698e3"
dependencies = [
"async-trait",
"derive_more",
......@@ -8569,7 +8569,7 @@ dependencies = [
[[package]]
name = "sc-light"
version = "4.0.0-dev"