Unverified Commit 4758b9f6 authored by Martin Pugh's avatar Martin Pugh Committed by GitHub
Browse files

v0.9.0 prep (#2959)

* bump version and unify spec version

* bump substrate

* spec_version to 900
parent 9d73c530
Pipeline #136439 passed with stages
in 37 minutes and 4 seconds
......@@ -458,7 +458,7 @@ checksum = "6736e2428df2ca2848d846c43e88745121a6654696e349ce0054a420815a7409"
[[package]]
name = "beefy-gadget"
version = "0.1.0"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget#ad64f84dc7e2929eee0b821dc41d9a1ef93ab10b"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget?branch=master#5726a43094cad395d6e253bbc8b93ff7e54f2453"
dependencies = [
"beefy-primitives",
"futures 0.3.14",
......@@ -486,7 +486,7 @@ dependencies = [
[[package]]
name = "beefy-gadget-rpc"
version = "0.1.0"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget#ad64f84dc7e2929eee0b821dc41d9a1ef93ab10b"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget?branch=master#5726a43094cad395d6e253bbc8b93ff7e54f2453"
dependencies = [
"beefy-gadget",
"beefy-primitives",
......@@ -507,7 +507,7 @@ dependencies = [
[[package]]
name = "beefy-primitives"
version = "0.1.0"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget#ad64f84dc7e2929eee0b821dc41d9a1ef93ab10b"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget?branch=master#5726a43094cad395d6e253bbc8b93ff7e54f2453"
dependencies = [
"parity-scale-codec",
"sp-api",
......@@ -1864,7 +1864,7 @@ checksum = "3f9eec918d3f24069decb9af1554cad7c880e2da24a9afd88aca000531ab82c1"
[[package]]
name = "fork-tree"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"parity-scale-codec",
]
......@@ -1882,7 +1882,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking"
version = "3.1.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -1901,7 +1901,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking-cli"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"Inflector",
"chrono",
......@@ -1924,7 +1924,7 @@ dependencies = [
[[package]]
name = "frame-election-provider-support"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -1937,7 +1937,7 @@ dependencies = [
[[package]]
name = "frame-executive"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -1952,7 +1952,7 @@ dependencies = [
[[package]]
name = "frame-metadata"
version = "13.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"parity-scale-codec",
"serde",
......@@ -1963,7 +1963,7 @@ dependencies = [
[[package]]
name = "frame-support"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"bitflags",
"frame-metadata",
......@@ -1989,7 +1989,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"Inflector",
"frame-support-procedural-tools",
......@@ -2001,7 +2001,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support-procedural-tools-derive",
"proc-macro-crate 1.0.0",
......@@ -2013,7 +2013,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools-derive"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"proc-macro2",
"quote",
......@@ -2023,7 +2023,7 @@ dependencies = [
[[package]]
name = "frame-support-test"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-metadata",
"frame-support",
......@@ -2044,7 +2044,7 @@ dependencies = [
[[package]]
name = "frame-system"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"impl-trait-for-tuples",
......@@ -2061,7 +2061,7 @@ dependencies = [
[[package]]
name = "frame-system-benchmarking"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -2075,7 +2075,7 @@ dependencies = [
[[package]]
name = "frame-system-rpc-runtime-api"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"parity-scale-codec",
"sp-api",
......@@ -2084,7 +2084,7 @@ dependencies = [
[[package]]
name = "frame-try-runtime"
version = "0.9.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"parity-scale-codec",
......@@ -3110,9 +3110,9 @@ dependencies = [
[[package]]
name = "jsonrpsee-http-client"
version = "0.2.0-alpha.5"
version = "0.2.0-alpha.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "7e3a49473ea266be8e9f23e20a7bfa4349109b42319d72cc0b8a101e18fa6466"
checksum = "2737440f37efa10e5ef7beeec43d059d29dc92640978be21fcdcef481a2edb0d"
dependencies = [
"async-trait",
"fnv",
......@@ -3129,9 +3129,9 @@ dependencies = [
[[package]]
name = "jsonrpsee-proc-macros"
version = "0.2.0-alpha.5"
version = "0.2.0-alpha.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "b0cbaee9ca6440e191545a68c7bf28db0ff918359a904e37a6e7cf7edd132f5a"
checksum = "5784ee8bb31988fa2c7a755fe31b0e21aa51894a67e5c99b6d4470f0253bf31a"
dependencies = [
"Inflector",
"proc-macro-crate 1.0.0",
......@@ -3142,9 +3142,9 @@ dependencies = [
[[package]]
name = "jsonrpsee-types"
version = "0.2.0-alpha.5"
version = "0.2.0-alpha.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e4ce2de6884fb4abee16eca02329a1eec1eb8df8aed751a8e929083820c78ce7"
checksum = "bab3dabceeeeb865897661d532d47202eaae71cd2c606f53cb69f1fbc0555a51"
dependencies = [
"async-trait",
"beef",
......@@ -3158,9 +3158,9 @@ dependencies = [
[[package]]
name = "jsonrpsee-utils"
version = "0.2.0-alpha.5"
version = "0.2.0-alpha.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "3b22199cccd81d9ef601be86bedc5bef67aeacbbfddace031d4931c60fca96e9"
checksum = "d63cf4d423614e71fd144a8691208539d2b23d8373e069e2fbe023c5eba5e922"
dependencies = [
"futures-util",
"hyper 0.13.9",
......@@ -3185,7 +3185,7 @@ dependencies = [
[[package]]
name = "kusama-runtime"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"beefy-primitives",
"bitvec",
......@@ -4463,7 +4463,7 @@ checksum = "13370dae44474229701bb69b90b4f4dca6404cb0357a2d50d635f1171dc3aa7b"
[[package]]
name = "pallet-authority-discovery"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -4478,7 +4478,7 @@ dependencies = [
[[package]]
name = "pallet-authorship"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -4493,7 +4493,7 @@ dependencies = [
[[package]]
name = "pallet-babe"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4516,7 +4516,7 @@ dependencies = [
[[package]]
name = "pallet-balances"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4530,7 +4530,7 @@ dependencies = [
[[package]]
name = "pallet-beefy"
version = "0.1.0"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget#ad64f84dc7e2929eee0b821dc41d9a1ef93ab10b"
source = "git+https://github.com/paritytech/grandpa-bridge-gadget?branch=master#5726a43094cad395d6e253bbc8b93ff7e54f2453"
dependencies = [
"beefy-primitives",
"frame-support",
......@@ -4545,7 +4545,7 @@ dependencies = [
[[package]]
name = "pallet-bounties"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4559,7 +4559,7 @@ dependencies = [
[[package]]
name = "pallet-collective"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4575,7 +4575,7 @@ dependencies = [
[[package]]
name = "pallet-democracy"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4590,7 +4590,7 @@ dependencies = [
[[package]]
name = "pallet-election-provider-multi-phase"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-election-provider-support",
......@@ -4610,7 +4610,7 @@ dependencies = [
[[package]]
name = "pallet-elections-phragmen"
version = "4.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4627,7 +4627,7 @@ dependencies = [
[[package]]
name = "pallet-grandpa"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4648,7 +4648,7 @@ dependencies = [
[[package]]
name = "pallet-identity"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"enumflags2",
"frame-benchmarking",
......@@ -4663,7 +4663,7 @@ dependencies = [
[[package]]
name = "pallet-im-online"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4682,7 +4682,7 @@ dependencies = [
[[package]]
name = "pallet-indices"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4698,7 +4698,7 @@ dependencies = [
[[package]]
name = "pallet-membership"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4713,7 +4713,7 @@ dependencies = [
[[package]]
name = "pallet-mmr"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"ckb-merkle-mountain-range",
"frame-benchmarking",
......@@ -4730,7 +4730,7 @@ dependencies = [
[[package]]
name = "pallet-mmr-primitives"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -4746,7 +4746,7 @@ dependencies = [
[[package]]
name = "pallet-mmr-rpc"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"jsonrpc-core",
"jsonrpc-core-client",
......@@ -4764,7 +4764,7 @@ dependencies = [
[[package]]
name = "pallet-multisig"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4779,7 +4779,7 @@ dependencies = [
[[package]]
name = "pallet-nicks"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -4792,7 +4792,7 @@ dependencies = [
[[package]]
name = "pallet-offences"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -4808,7 +4808,7 @@ dependencies = [
[[package]]
name = "pallet-offences-benchmarking"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-election-provider-support",
......@@ -4830,7 +4830,7 @@ dependencies = [
[[package]]
name = "pallet-proxy"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4845,7 +4845,7 @@ dependencies = [
[[package]]
name = "pallet-randomness-collective-flip"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -4858,7 +4858,7 @@ dependencies = [
[[package]]
name = "pallet-recovery"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"enumflags2",
"frame-support",
......@@ -4872,7 +4872,7 @@ dependencies = [
[[package]]
name = "pallet-scheduler"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4887,7 +4887,7 @@ dependencies = [
[[package]]
name = "pallet-session"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -4906,7 +4906,7 @@ dependencies = [
[[package]]
name = "pallet-session-benchmarking"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4922,7 +4922,7 @@ dependencies = [
[[package]]
name = "pallet-society"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -4935,7 +4935,7 @@ dependencies = [
[[package]]
name = "pallet-staking"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-election-provider-support",
......@@ -4959,7 +4959,7 @@ dependencies = [
[[package]]
name = "pallet-staking-reward-curve"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"proc-macro-crate 1.0.0",
"proc-macro2",
......@@ -4970,7 +4970,7 @@ dependencies = [
[[package]]
name = "pallet-sudo"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -4983,7 +4983,7 @@ dependencies = [
[[package]]
name = "pallet-timestamp"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5001,7 +5001,7 @@ dependencies = [
[[package]]
name = "pallet-tips"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5016,7 +5016,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-support",
"frame-system",
......@@ -5032,7 +5032,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"jsonrpc-core",
"jsonrpc-core-client",
......@@ -5049,7 +5049,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc-runtime-api"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"pallet-transaction-payment",
"parity-scale-codec",
......@@ -5060,7 +5060,7 @@ dependencies = [
[[package]]
name = "pallet-treasury"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5076,7 +5076,7 @@ dependencies = [
[[package]]
name = "pallet-utility"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -5091,7 +5091,7 @@ dependencies = [
[[package]]
name = "pallet-vesting"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [
"enumflags2",
"frame-benchmarking",
......@@ -5539,7 +5539,7 @@ checksum = "989d43012e2ca1c4a02507c67282691a0a3207f9dc67cec596b43fe925b3d325"
[[package]]
name = "polkadot"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"assert_cmd",
"color-eyre",
......@@ -5655,7 +5655,7 @@ dependencies = [
[[package]]
name = "polkadot-cli"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"frame-benchmarking-cli",
"futures 0.3.14",
......@@ -5701,7 +5701,7 @@ dependencies = [
[[package]]
name = "polkadot-core-primitives"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"parity-scale-codec",
"parity-util-mem",
......@@ -5712,7 +5712,7 @@ dependencies = [
[[package]]
name = "polkadot-erasure-coding"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"parity-scale-codec",
"polkadot-node-primitives",
......@@ -6188,7 +6188,7 @@ dependencies = [
[[package]]
name = "polkadot-parachain"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"derive_more",
"parity-scale-codec",
......@@ -6202,7 +6202,7 @@ dependencies = [
[[package]]
name = "polkadot-primitives"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"bitvec",
"frame-system",
......@@ -6254,7 +6254,7 @@ dependencies = [
[[package]]
name = "polkadot-rpc"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"beefy-gadget",
"beefy-gadget-rpc",
......@@ -6286,7 +6286,7 @@ dependencies = [
[[package]]
name = "polkadot-runtime"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"beefy-primitives",
"bitvec",
......@@ -6367,7 +6367,7 @@ dependencies = [
[[package]]
name = "polkadot-runtime-common"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"beefy-primitives",
"bitvec",
......@@ -6420,7 +6420,7 @@ dependencies = [
[[package]]
name = "polkadot-runtime-parachains"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"bitvec",
"derive_more",
......@@ -6471,7 +6471,7 @@ dependencies = [
[[package]]
name = "polkadot-service"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"beefy-gadget",
"beefy-primitives",
......@@ -6589,7 +6589,7 @@ dependencies = [
[[package]]
name = "polkadot-statement-table"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"parity-scale-codec",
"polkadot-primitives",
......@@ -6598,7 +6598,7 @@ dependencies = [
[[package]]
name = "polkadot-test-client"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"futures 0.3.14",
"parity-scale-codec",
......@@ -6624,7 +6624,7 @@ dependencies = [
[[package]]
name = "polkadot-test-runtime"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"beefy-primitives",
"bitvec",
......@@ -6686,7 +6686,7 @@ dependencies = [
[[package]]
name = "polkadot-test-service"
version = "0.8.31"
version = "0.9.0"
dependencies = [
"frame-benchmarking",
"frame-system",
......@@ -7316,7 +7316,7 @@ dependencies = [
[[package]]
name = "remote-externalities"
version = "0.9.0"
source = "git+https://github.com/paritytech/substrate?branch=master#febdc30aca650c36080c513ef16cf66853a95481"
source = "git+https://github.com/paritytech/substrate?branch=master#dc9acd2d74a5451a63e34060a4c7869021780b3e"
dependencies = [