Unverified Commit 400ecc58 authored by Gavin Wood's avatar Gavin Wood Committed by GitHub
Browse files

Companion for #7363 (Account-providers ref-counting) (#2152)



* Fix

* Fix

* Bump Substrate
Co-authored-by: Shawn Tabrizi's avatarShawn Tabrizi <shawntabrizi@gmail.com>
parent 5649a8a1
Pipeline #120544 passed with stages
in 30 minutes and 46 seconds
...@@ -310,19 +310,6 @@ version = "4.0.3" ...@@ -310,19 +310,6 @@ version = "4.0.3"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e91831deabf0d6d7ec49552e489aed63b7456a7a3c46cff62adad428110b0af0" checksum = "e91831deabf0d6d7ec49552e489aed63b7456a7a3c46cff62adad428110b0af0"
[[package]]
name = "async-tls"
version = "0.11.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "2f23d769dbf1838d5df5156e7b1ad404f4c463d1ac2c6aeb6cd943630f8a8400"
dependencies = [
"futures-core",
"futures-io",
"rustls 0.19.0",
"webpki",
"webpki-roots",
]
[[package]] [[package]]
name = "async-trait" name = "async-trait"
version = "0.1.42" version = "0.1.42"
...@@ -334,6 +321,19 @@ dependencies = [ ...@@ -334,6 +321,19 @@ dependencies = [
"syn 1.0.58", "syn 1.0.58",
] ]
[[package]]
name = "asynchronous-codec"
version = "0.5.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "fb4401f0a3622dad2e0763fa79e0eb328bc70fb7dccfdd645341f00d671247d6"
dependencies = [
"bytes 1.0.1",
"futures-sink",
"futures-util",
"memchr",
"pin-project-lite 0.2.4",
]
[[package]] [[package]]
name = "atomic" name = "atomic"
version = "0.5.0" version = "0.5.0"
...@@ -435,7 +435,7 @@ dependencies = [ ...@@ -435,7 +435,7 @@ dependencies = [
"regex", "regex",
"rustc-hash", "rustc-hash",
"shlex", "shlex",
"which", "which 3.1.1",
] ]
[[package]] [[package]]
...@@ -613,6 +613,12 @@ version = "0.5.6" ...@@ -613,6 +613,12 @@ version = "0.5.6"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "0e4cec68f03f32e44924783795810fa50a7035d8c8ebe78580ad7e6c703fba38" checksum = "0e4cec68f03f32e44924783795810fa50a7035d8c8ebe78580ad7e6c703fba38"
[[package]]
name = "bytes"
version = "1.0.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "b700ce4376041dcd0a327fd0097c41095743c4c8af8887265942faf1100bd040"
[[package]] [[package]]
name = "cache-padded" name = "cache-padded"
version = "1.1.1" version = "1.1.1"
...@@ -1477,7 +1483,7 @@ checksum = "3f9eec918d3f24069decb9af1554cad7c880e2da24a9afd88aca000531ab82c1" ...@@ -1477,7 +1483,7 @@ checksum = "3f9eec918d3f24069decb9af1554cad7c880e2da24a9afd88aca000531ab82c1"
[[package]] [[package]]
name = "fork-tree" name = "fork-tree"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
] ]
...@@ -1495,7 +1501,7 @@ dependencies = [ ...@@ -1495,7 +1501,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-benchmarking" name = "frame-benchmarking"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -1513,7 +1519,7 @@ dependencies = [ ...@@ -1513,7 +1519,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-benchmarking-cli" name = "frame-benchmarking-cli"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"Inflector", "Inflector",
"chrono", "chrono",
...@@ -1536,7 +1542,7 @@ dependencies = [ ...@@ -1536,7 +1542,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-executive" name = "frame-executive"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"frame-system", "frame-system",
...@@ -1552,7 +1558,7 @@ dependencies = [ ...@@ -1552,7 +1558,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-metadata" name = "frame-metadata"
version = "12.0.1" version = "12.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"serde", "serde",
...@@ -1563,7 +1569,7 @@ dependencies = [ ...@@ -1563,7 +1569,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-support" name = "frame-support"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"bitflags", "bitflags",
"frame-metadata", "frame-metadata",
...@@ -1588,7 +1594,7 @@ dependencies = [ ...@@ -1588,7 +1594,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-support-procedural" name = "frame-support-procedural"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"Inflector", "Inflector",
"frame-support-procedural-tools", "frame-support-procedural-tools",
...@@ -1600,7 +1606,7 @@ dependencies = [ ...@@ -1600,7 +1606,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-support-procedural-tools" name = "frame-support-procedural-tools"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"frame-support-procedural-tools-derive", "frame-support-procedural-tools-derive",
"proc-macro-crate", "proc-macro-crate",
...@@ -1612,7 +1618,7 @@ dependencies = [ ...@@ -1612,7 +1618,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-support-procedural-tools-derive" name = "frame-support-procedural-tools-derive"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"proc-macro2 1.0.24", "proc-macro2 1.0.24",
"quote 1.0.7", "quote 1.0.7",
...@@ -1622,7 +1628,7 @@ dependencies = [ ...@@ -1622,7 +1628,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-system" name = "frame-system"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"frame-support", "frame-support",
"impl-trait-for-tuples 0.2.0", "impl-trait-for-tuples 0.2.0",
...@@ -1638,7 +1644,7 @@ dependencies = [ ...@@ -1638,7 +1644,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-system-benchmarking" name = "frame-system-benchmarking"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"frame-benchmarking", "frame-benchmarking",
"frame-support", "frame-support",
...@@ -1652,7 +1658,7 @@ dependencies = [ ...@@ -1652,7 +1658,7 @@ dependencies = [
[[package]] [[package]]
name = "frame-system-rpc-runtime-api" name = "frame-system-rpc-runtime-api"
version = "2.0.1" version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d" source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [ dependencies = [
"parity-scale-codec", "parity-scale-codec",
"sp-api", "sp-api",
...@@ -1806,6 +1812,17 @@ dependencies = [ ...@@ -1806,6 +1812,17 @@ dependencies = [
"syn 1.0.58", "syn 1.0.58",
] ]
[[package]]
name = "futures-rustls"
version = "0.21.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "3a1387e07917c711fb4ee4f48ea0adb04a3c9739e53ef85bf43ae1edc2937a8b"
dependencies = [
"futures-io",
"rustls 0.19.0",
"webpki",
]
[[package]] [[package]]
name = "futures-sink" name = "futures-sink"
version = "0.3.11" version = "0.3.11"
...@@ -1858,18 +1875,6 @@ dependencies = [ ...@@ -1858,18 +1875,6 @@ dependencies = [
"slab", "slab",
] ]
[[package]]
name = "futures_codec"
version = "0.4.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "ce54d63f8b0c75023ed920d46fd71d0cbbb830b0ee012726b5b4f506fb6dea5b"
dependencies = [
"bytes 0.5.6",
"futures 0.3.11",
"memchr",
"pin-project 0.4.23",
]
[[package]] [[package]]
name = "gcc" name = "gcc"
version = "0.3.55" version = "0.3.55"
...@@ -2455,15 +2460,6 @@ version = "2.3.0" ...@@ -2455,15 +2460,6 @@ version = "2.3.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "47be2f14c678be2fdcab04ab1171db51b2762ce6f0a8ee87c8dd4a04ed216135" checksum = "47be2f14c678be2fdcab04ab1171db51b2762ce6f0a8ee87c8dd4a04ed216135"
[[package]]
name = "itertools"
version = "0.8.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "f56a2d0bc861f9165be4eb3442afd3c236d8a98afd426f65d92324ae1091a484"
dependencies = [
"either",
]
[[package]] [[package]]
name = "itertools" name = "itertools"
version = "0.9.0" version = "0.9.0"
...@@ -2841,12 +2837,12 @@ checksum = "c7d73b3f436185384286bd8098d17ec07c9a7d2388a6599f824d8502b529702a" ...@@ -2841,12 +2837,12 @@ checksum = "c7d73b3f436185384286bd8098d17ec07c9a7d2388a6599f824d8502b529702a"
[[package]] [[package]]
name = "libp2p" name = "libp2p"
version = "0.33.0" version = "0.34.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "2e17c636b5fe5ff900ccc2840b643074bfac321551d821243a781d0d46f06588" checksum = "d5133112ce42be9482f6a87be92a605dd6bbc9e93c297aee77d172ff06908f3a"
dependencies = [ dependencies = [
"atomic", "atomic",
"bytes 0.5.6", "bytes 1.0.1",
"futures 0.3.11", "futures 0.3.11",
"lazy_static", "lazy_static",
"libp2p-core", "libp2p-core",
...@@ -2879,9 +2875,9 @@ dependencies = [ ...@@ -2879,9 +2875,9 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-core" name = "libp2p-core"
version = "0.26.0" version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e1cb706da14c064dce54d8864ade6836b3486b51689300da74eeb7053aa4551e" checksum = "dad04d3cef6c1df366a6ab58c9cf8b06497699e335d83ac2174783946ff847d6"
dependencies = [ dependencies = [
"asn1_der", "asn1_der",
"bs58", "bs58",
...@@ -2906,7 +2902,7 @@ dependencies = [ ...@@ -2906,7 +2902,7 @@ dependencies = [
"sha2 0.9.2", "sha2 0.9.2",
"smallvec 1.6.1", "smallvec 1.6.1",
"thiserror", "thiserror",
"unsigned-varint", "unsigned-varint 0.6.0",
"void", "void",
"zeroize", "zeroize",
] ]
...@@ -2923,9 +2919,9 @@ dependencies = [ ...@@ -2923,9 +2919,9 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-deflate" name = "libp2p-deflate"
version = "0.26.0" version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e3257a41f376aa23f237231971fee7e350e4d8353cfcf233aef34d6d6b638f0c" checksum = "935893c0e5b6ca6ef60d5225aab9182f97c8c5671df2fa9dee8f4ed72a90e6eb"
dependencies = [ dependencies = [
"flate2", "flate2",
"futures 0.3.11", "futures 0.3.11",
...@@ -2934,9 +2930,9 @@ dependencies = [ ...@@ -2934,9 +2930,9 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-dns" name = "libp2p-dns"
version = "0.26.0" version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "2e09bab25af01326b4ed9486d31325911437448edda30bc57681502542d49f20" checksum = "5153b6db68fd4baa3b304e377db744dd8fea8ff4e4504509ee636abcde88d3e3"
dependencies = [ dependencies = [
"futures 0.3.11", "futures 0.3.11",
"libp2p-core", "libp2p-core",
...@@ -2945,9 +2941,9 @@ dependencies = [ ...@@ -2945,9 +2941,9 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-floodsub" name = "libp2p-floodsub"
version = "0.26.0" version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "6fd8cdd5ef1dd0b7346975477216d752de976b92e43051bc8bd808c372ea6cec" checksum = "b3c63dfa06581b24b1d12bf9815b43689a784424be217d6545c800c7c75a207f"
dependencies = [ dependencies = [
"cuckoofilter", "cuckoofilter",
"fnv", "fnv",
...@@ -2963,35 +2959,35 @@ dependencies = [ ...@@ -2963,35 +2959,35 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-gossipsub" name = "libp2p-gossipsub"
version = "0.26.0" version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "d489531aa9d4ba8726a08b3b74e21c2e10a518ad266ebca98d79040123ab0036" checksum = "12451ba9493e87c91baf2a6dffce9ddf1fbc807a0861532d7cf477954f8ebbee"
dependencies = [ dependencies = [
"asynchronous-codec",
"base64 0.13.0", "base64 0.13.0",
"byteorder", "byteorder",
"bytes 0.5.6", "bytes 1.0.1",
"fnv", "fnv",
"futures 0.3.11", "futures 0.3.11",
"futures_codec",
"hex_fmt", "hex_fmt",
"libp2p-core", "libp2p-core",
"libp2p-swarm", "libp2p-swarm",
"log", "log",
"lru_time_cache",
"prost", "prost",
"prost-build", "prost-build",
"rand 0.7.3", "rand 0.7.3",
"regex",
"sha2 0.9.2", "sha2 0.9.2",
"smallvec 1.6.1", "smallvec 1.6.1",
"unsigned-varint", "unsigned-varint 0.6.0",
"wasm-timer", "wasm-timer",
] ]
[[package]] [[package]]
name = "libp2p-identify" name = "libp2p-identify"
version = "0.26.0" version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "c43bc51a9bc3780288c526615ba0f5f8216820ea6dcc02b89e8daee526c5fccb" checksum = "b40fb36a059b7a8cce1514bd8b546fa612e006c9937caa7f5950cb20021fe91e"
dependencies = [ dependencies = [
"futures 0.3.11", "futures 0.3.11",
"libp2p-core", "libp2p-core",
...@@ -3005,16 +3001,16 @@ dependencies = [ ...@@ -3005,16 +3001,16 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-kad" name = "libp2p-kad"
version = "0.27.0" version = "0.28.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "a226956b49438a10f3206480b8faf5e61fc445c349ea9d9cc37766a83745fa9a" checksum = "456f5de8e283d7800ca848b9b9a4e2a578b790bd8ae582b885e831353cf0e5df"
dependencies = [ dependencies = [
"arrayvec 0.5.2", "arrayvec 0.5.2",
"bytes 0.5.6", "asynchronous-codec",
"bytes 1.0.1",
"either", "either",
"fnv", "fnv",
"futures 0.3.11", "futures 0.3.11",
"futures_codec",
"libp2p-core", "libp2p-core",
"libp2p-swarm", "libp2p-swarm",
"log", "log",
...@@ -3023,17 +3019,17 @@ dependencies = [ ...@@ -3023,17 +3019,17 @@ dependencies = [
"rand 0.7.3", "rand 0.7.3",
"sha2 0.9.2", "sha2 0.9.2",
"smallvec 1.6.1", "smallvec 1.6.1",
"uint 0.8.3", "uint",
"unsigned-varint", "unsigned-varint 0.6.0",
"void", "void",
"wasm-timer", "wasm-timer",
] ]
[[package]] [[package]]
name = "libp2p-mdns" name = "libp2p-mdns"
version = "0.27.0" version = "0.28.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "8a9e12688e8f14008c950c1efde587cb44dbf316fa805f419cd4e524991236f5" checksum = "b974db63233fc0e199f4ede7794294aae285c96f4b6010f853eac4099ef08590"
dependencies = [ dependencies = [
"async-io", "async-io",
"data-encoding", "data-encoding",
...@@ -3052,29 +3048,29 @@ dependencies = [ ...@@ -3052,29 +3048,29 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-mplex" name = "libp2p-mplex"
version = "0.26.0" version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "ce3200fbe6608e623bd9efa459cc8bafa0e4efbb0a2dfcdd0e1387ff4181264b" checksum = "2705dc94b01ab9e3779b42a09bbf3712e637ed213e875c30face247291a85af0"
dependencies = [ dependencies = [
"bytes 0.5.6", "asynchronous-codec",
"bytes 1.0.1",
"futures 0.3.11", "futures 0.3.11",
"futures_codec",
"libp2p-core", "libp2p-core",
"log", "log",
"nohash-hasher", "nohash-hasher",
"parking_lot 0.11.1", "parking_lot 0.11.1",
"rand 0.7.3", "rand 0.7.3",
"smallvec 1.6.1", "smallvec 1.6.1",
"unsigned-varint", "unsigned-varint 0.6.0",
] ]
[[package]] [[package]]
name = "libp2p-noise" name = "libp2p-noise"
version = "0.28.0" version = "0.29.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "0580e0d18019d254c9c349c03ff7b22e564b6f2ada70c045fc39738e144f2139" checksum = "4aca322b52a0c5136142a7c3971446fb1e9964923a526c9cc6ef3b7c94e57778"
dependencies = [ dependencies = [
"bytes 0.5.6", "bytes 1.0.1",
"curve25519-dalek 3.0.0", "curve25519-dalek 3.0.0",
"futures 0.3.11", "futures 0.3.11",
"lazy_static", "lazy_static",
...@@ -3092,9 +3088,9 @@ dependencies = [ ...@@ -3092,9 +3088,9 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-ping" name = "libp2p-ping"
version = "0.26.0" version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "50b2ec86a18cbf09d7df440e7786a2409640c774e476e9a3b4d031382c3d7588" checksum = "6f3813276d0708c8db0f500d8beda1bda9ad955723b9cb272c41f4727256f73c"
dependencies = [ dependencies = [
"futures 0.3.11", "futures 0.3.11",
"libp2p-core", "libp2p-core",
...@@ -3107,18 +3103,18 @@ dependencies = [ ...@@ -3107,18 +3103,18 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-plaintext" name = "libp2p-plaintext"
version = "0.26.0" version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "6a7b1bdcbe46a3a2159c231601ed29645282653c0a96ce3a2ad8352c9fbe6800" checksum = "48e8c1ec305c9949351925cdc7196b9570f4330477f5e47fbf5bb340b57e26ed"
dependencies = [ dependencies = [
"bytes 0.5.6", "asynchronous-codec",
"bytes 1.0.1",
"futures 0.3.11", "futures 0.3.11",
"futures_codec",
"libp2p-core", "libp2p-core",
"log", "log",
"prost", "prost",
"prost-build", "prost-build",
"unsigned-varint", "unsigned-varint 0.6.0",
"void", "void",
] ]
...@@ -3138,12 +3134,12 @@ dependencies = [ ...@@ -3138,12 +3134,12 @@ dependencies = [
[[package]] [[package]]
name = "libp2p-request-response" name = "libp2p-request-response"
version = "0.8.0" version = "0.9.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "620e2950decbf77554b5aed3824f7d0e2c04923f28c70f9bff1a402c47ef6b1e" checksum = "d37637a4b33b5390322ccc068a33897d0aa541daf4fec99f6a7efbf37295346e"
dependencies = [ dependencies = [
"async-trait", "async-trait",
"bytes 0.5.6", "bytes 1.0.1",
"futures 0.3.11", "futures 0.3.11",
"libp2p-core", "libp2p-core",
"libp2p-swarm", "libp2p-swarm",
...@@ -3152,15 +3148,15 @@ dependencies = [ ...@@ -3152,15 +3148,15 @@ dependencies = [
"minicbor", "minicbor",
"rand 0.7.3", "rand 0.7.3",
"smallvec 1.6.1", "smallvec 1.6.1",
"unsigned-varint", "unsigned-varint 0.6.0",
"wasm-timer", "wasm-timer",
] ]
[[package]] [[package]]
name = "libp2p-swarm" name = "libp2p-swarm"
version = "0.26.0"