Unverified Commit 400ecc58 authored by Gavin Wood's avatar Gavin Wood Committed by GitHub
Browse files

Companion for #7363 (Account-providers ref-counting) (#2152)



* Fix

* Fix

* Bump Substrate
Co-authored-by: Shawn Tabrizi's avatarShawn Tabrizi <shawntabrizi@gmail.com>
parent 5649a8a1
Pipeline #120544 passed with stages
in 30 minutes and 46 seconds
......@@ -310,19 +310,6 @@ version = "4.0.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e91831deabf0d6d7ec49552e489aed63b7456a7a3c46cff62adad428110b0af0"
[[package]]
name = "async-tls"
version = "0.11.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "2f23d769dbf1838d5df5156e7b1ad404f4c463d1ac2c6aeb6cd943630f8a8400"
dependencies = [
"futures-core",
"futures-io",
"rustls 0.19.0",
"webpki",
"webpki-roots",
]
[[package]]
name = "async-trait"
version = "0.1.42"
......@@ -334,6 +321,19 @@ dependencies = [
"syn 1.0.58",
]
[[package]]
name = "asynchronous-codec"
version = "0.5.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "fb4401f0a3622dad2e0763fa79e0eb328bc70fb7dccfdd645341f00d671247d6"
dependencies = [
"bytes 1.0.1",
"futures-sink",
"futures-util",
"memchr",
"pin-project-lite 0.2.4",
]
[[package]]
name = "atomic"
version = "0.5.0"
......@@ -435,7 +435,7 @@ dependencies = [
"regex",
"rustc-hash",
"shlex",
"which",
"which 3.1.1",
]
[[package]]
......@@ -613,6 +613,12 @@ version = "0.5.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "0e4cec68f03f32e44924783795810fa50a7035d8c8ebe78580ad7e6c703fba38"
[[package]]
name = "bytes"
version = "1.0.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "b700ce4376041dcd0a327fd0097c41095743c4c8af8887265942faf1100bd040"
[[package]]
name = "cache-padded"
version = "1.1.1"
......@@ -1477,7 +1483,7 @@ checksum = "3f9eec918d3f24069decb9af1554cad7c880e2da24a9afd88aca000531ab82c1"
[[package]]
name = "fork-tree"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"parity-scale-codec",
]
......@@ -1495,7 +1501,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-support",
"frame-system",
......@@ -1513,7 +1519,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking-cli"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"Inflector",
"chrono",
......@@ -1536,7 +1542,7 @@ dependencies = [
[[package]]
name = "frame-executive"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-support",
"frame-system",
......@@ -1552,7 +1558,7 @@ dependencies = [
[[package]]
name = "frame-metadata"
version = "12.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"parity-scale-codec",
"serde",
......@@ -1563,7 +1569,7 @@ dependencies = [
[[package]]
name = "frame-support"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"bitflags",
"frame-metadata",
......@@ -1588,7 +1594,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"Inflector",
"frame-support-procedural-tools",
......@@ -1600,7 +1606,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-support-procedural-tools-derive",
"proc-macro-crate",
......@@ -1612,7 +1618,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools-derive"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"proc-macro2 1.0.24",
"quote 1.0.7",
......@@ -1622,7 +1628,7 @@ dependencies = [
[[package]]
name = "frame-system"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-support",
"impl-trait-for-tuples 0.2.0",
......@@ -1638,7 +1644,7 @@ dependencies = [
[[package]]
name = "frame-system-benchmarking"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -1652,7 +1658,7 @@ dependencies = [
[[package]]
name = "frame-system-rpc-runtime-api"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"parity-scale-codec",
"sp-api",
......@@ -1806,6 +1812,17 @@ dependencies = [
"syn 1.0.58",
]
[[package]]
name = "futures-rustls"
version = "0.21.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "3a1387e07917c711fb4ee4f48ea0adb04a3c9739e53ef85bf43ae1edc2937a8b"
dependencies = [
"futures-io",
"rustls 0.19.0",
"webpki",
]
[[package]]
name = "futures-sink"
version = "0.3.11"
......@@ -1858,18 +1875,6 @@ dependencies = [
"slab",
]
[[package]]
name = "futures_codec"
version = "0.4.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "ce54d63f8b0c75023ed920d46fd71d0cbbb830b0ee012726b5b4f506fb6dea5b"
dependencies = [
"bytes 0.5.6",
"futures 0.3.11",
"memchr",
"pin-project 0.4.23",
]
[[package]]
name = "gcc"
version = "0.3.55"
......@@ -2455,15 +2460,6 @@ version = "2.3.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "47be2f14c678be2fdcab04ab1171db51b2762ce6f0a8ee87c8dd4a04ed216135"
[[package]]
name = "itertools"
version = "0.8.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "f56a2d0bc861f9165be4eb3442afd3c236d8a98afd426f65d92324ae1091a484"
dependencies = [
"either",
]
[[package]]
name = "itertools"
version = "0.9.0"
......@@ -2841,12 +2837,12 @@ checksum = "c7d73b3f436185384286bd8098d17ec07c9a7d2388a6599f824d8502b529702a"
[[package]]
name = "libp2p"
version = "0.33.0"
version = "0.34.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "2e17c636b5fe5ff900ccc2840b643074bfac321551d821243a781d0d46f06588"
checksum = "d5133112ce42be9482f6a87be92a605dd6bbc9e93c297aee77d172ff06908f3a"
dependencies = [
"atomic",
"bytes 0.5.6",
"bytes 1.0.1",
"futures 0.3.11",
"lazy_static",
"libp2p-core",
......@@ -2879,9 +2875,9 @@ dependencies = [
[[package]]
name = "libp2p-core"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e1cb706da14c064dce54d8864ade6836b3486b51689300da74eeb7053aa4551e"
checksum = "dad04d3cef6c1df366a6ab58c9cf8b06497699e335d83ac2174783946ff847d6"
dependencies = [
"asn1_der",
"bs58",
......@@ -2906,7 +2902,7 @@ dependencies = [
"sha2 0.9.2",
"smallvec 1.6.1",
"thiserror",
"unsigned-varint",
"unsigned-varint 0.6.0",
"void",
"zeroize",
]
......@@ -2923,9 +2919,9 @@ dependencies = [
[[package]]
name = "libp2p-deflate"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e3257a41f376aa23f237231971fee7e350e4d8353cfcf233aef34d6d6b638f0c"
checksum = "935893c0e5b6ca6ef60d5225aab9182f97c8c5671df2fa9dee8f4ed72a90e6eb"
dependencies = [
"flate2",
"futures 0.3.11",
......@@ -2934,9 +2930,9 @@ dependencies = [
[[package]]
name = "libp2p-dns"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "2e09bab25af01326b4ed9486d31325911437448edda30bc57681502542d49f20"
checksum = "5153b6db68fd4baa3b304e377db744dd8fea8ff4e4504509ee636abcde88d3e3"
dependencies = [
"futures 0.3.11",
"libp2p-core",
......@@ -2945,9 +2941,9 @@ dependencies = [
[[package]]
name = "libp2p-floodsub"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "6fd8cdd5ef1dd0b7346975477216d752de976b92e43051bc8bd808c372ea6cec"
checksum = "b3c63dfa06581b24b1d12bf9815b43689a784424be217d6545c800c7c75a207f"
dependencies = [
"cuckoofilter",
"fnv",
......@@ -2963,35 +2959,35 @@ dependencies = [
[[package]]
name = "libp2p-gossipsub"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "d489531aa9d4ba8726a08b3b74e21c2e10a518ad266ebca98d79040123ab0036"
checksum = "12451ba9493e87c91baf2a6dffce9ddf1fbc807a0861532d7cf477954f8ebbee"
dependencies = [
"asynchronous-codec",
"base64 0.13.0",
"byteorder",
"bytes 0.5.6",
"bytes 1.0.1",
"fnv",
"futures 0.3.11",
"futures_codec",
"hex_fmt",
"libp2p-core",
"libp2p-swarm",
"log",
"lru_time_cache",
"prost",
"prost-build",
"rand 0.7.3",
"regex",
"sha2 0.9.2",
"smallvec 1.6.1",
"unsigned-varint",
"unsigned-varint 0.6.0",
"wasm-timer",
]
[[package]]
name = "libp2p-identify"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "c43bc51a9bc3780288c526615ba0f5f8216820ea6dcc02b89e8daee526c5fccb"
checksum = "b40fb36a059b7a8cce1514bd8b546fa612e006c9937caa7f5950cb20021fe91e"
dependencies = [
"futures 0.3.11",
"libp2p-core",
......@@ -3005,16 +3001,16 @@ dependencies = [
[[package]]
name = "libp2p-kad"
version = "0.27.0"
version = "0.28.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "a226956b49438a10f3206480b8faf5e61fc445c349ea9d9cc37766a83745fa9a"
checksum = "456f5de8e283d7800ca848b9b9a4e2a578b790bd8ae582b885e831353cf0e5df"
dependencies = [
"arrayvec 0.5.2",
"bytes 0.5.6",
"asynchronous-codec",
"bytes 1.0.1",
"either",
"fnv",
"futures 0.3.11",
"futures_codec",
"libp2p-core",
"libp2p-swarm",
"log",
......@@ -3023,17 +3019,17 @@ dependencies = [
"rand 0.7.3",
"sha2 0.9.2",
"smallvec 1.6.1",
"uint 0.8.3",
"unsigned-varint",
"uint",
"unsigned-varint 0.6.0",
"void",
"wasm-timer",
]
[[package]]
name = "libp2p-mdns"
version = "0.27.0"
version = "0.28.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "8a9e12688e8f14008c950c1efde587cb44dbf316fa805f419cd4e524991236f5"
checksum = "b974db63233fc0e199f4ede7794294aae285c96f4b6010f853eac4099ef08590"
dependencies = [
"async-io",
"data-encoding",
......@@ -3052,29 +3048,29 @@ dependencies = [
[[package]]
name = "libp2p-mplex"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "ce3200fbe6608e623bd9efa459cc8bafa0e4efbb0a2dfcdd0e1387ff4181264b"
checksum = "2705dc94b01ab9e3779b42a09bbf3712e637ed213e875c30face247291a85af0"
dependencies = [
"bytes 0.5.6",
"asynchronous-codec",
"bytes 1.0.1",
"futures 0.3.11",
"futures_codec",
"libp2p-core",
"log",
"nohash-hasher",
"parking_lot 0.11.1",
"rand 0.7.3",
"smallvec 1.6.1",
"unsigned-varint",
"unsigned-varint 0.6.0",
]
[[package]]
name = "libp2p-noise"
version = "0.28.0"
version = "0.29.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "0580e0d18019d254c9c349c03ff7b22e564b6f2ada70c045fc39738e144f2139"
checksum = "4aca322b52a0c5136142a7c3971446fb1e9964923a526c9cc6ef3b7c94e57778"
dependencies = [
"bytes 0.5.6",
"bytes 1.0.1",
"curve25519-dalek 3.0.0",
"futures 0.3.11",
"lazy_static",
......@@ -3092,9 +3088,9 @@ dependencies = [
[[package]]
name = "libp2p-ping"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "50b2ec86a18cbf09d7df440e7786a2409640c774e476e9a3b4d031382c3d7588"
checksum = "6f3813276d0708c8db0f500d8beda1bda9ad955723b9cb272c41f4727256f73c"
dependencies = [
"futures 0.3.11",
"libp2p-core",
......@@ -3107,18 +3103,18 @@ dependencies = [
[[package]]
name = "libp2p-plaintext"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "6a7b1bdcbe46a3a2159c231601ed29645282653c0a96ce3a2ad8352c9fbe6800"
checksum = "48e8c1ec305c9949351925cdc7196b9570f4330477f5e47fbf5bb340b57e26ed"
dependencies = [
"bytes 0.5.6",
"asynchronous-codec",
"bytes 1.0.1",
"futures 0.3.11",
"futures_codec",
"libp2p-core",
"log",
"prost",
"prost-build",
"unsigned-varint",
"unsigned-varint 0.6.0",
"void",
]
......@@ -3138,12 +3134,12 @@ dependencies = [
[[package]]
name = "libp2p-request-response"
version = "0.8.0"
version = "0.9.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "620e2950decbf77554b5aed3824f7d0e2c04923f28c70f9bff1a402c47ef6b1e"
checksum = "d37637a4b33b5390322ccc068a33897d0aa541daf4fec99f6a7efbf37295346e"
dependencies = [
"async-trait",
"bytes 0.5.6",
"bytes 1.0.1",
"futures 0.3.11",
"libp2p-core",
"libp2p-swarm",
......@@ -3152,15 +3148,15 @@ dependencies = [
"minicbor",
"rand 0.7.3",
"smallvec 1.6.1",
"unsigned-varint",
"unsigned-varint 0.6.0",
"wasm-timer",
]
[[package]]
name = "libp2p-swarm"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "fdf5894ee1ee63a38aa58d58a16e3dcf7ede6b59ea7b22302c00c1a41d7aec41"
checksum = "22ea8c69839a0e593c8c6a24282cb234d48ac37be4153183f4914e00f5303e75"
dependencies = [
"either",
"futures 0.3.11",
......@@ -3174,15 +3170,16 @@ dependencies = [
[[package]]
name = "libp2p-tcp"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "1d2113a7dab2b502c55fe290910cd7399a2aa04fe70a2f5a415a87a1db600c0e"
checksum = "3dbd3d7076a478ac5a6aca55e74bdc250ac539b95de09b9d09915e0b8d01a6b2"
dependencies = [
"async-std",
"async-io",
"futures 0.3.11",
"futures-timer 3.0.2",
"if-addrs",
"if-watch",
"ipnet",
"libc",
"libp2p-core",
"log",
"socket2",
......@@ -3190,9 +3187,9 @@ dependencies = [
[[package]]
name = "libp2p-uds"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "af05fe92c2a3aa320bc82a308ddb7b33bef3b060154c5a4b9fb0b01f15385fc0"
checksum = "80ac51ce419f60be966e02103c17f67ff5dc4422ba83ba54d251d6c62a4ed487"
dependencies = [
"async-std",
"futures 0.3.11",
......@@ -3202,9 +3199,9 @@ dependencies = [
[[package]]
name = "libp2p-wasm-ext"
version = "0.26.0"
version = "0.27.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "37cd44ea05a4523f40183f60ab6e6a80e400a5ddfc98b0df1c55edeb85576cd9"
checksum = "6149c46cb76935c80bc8be6ec6e3ebd5f5e1679765a255fb34331d54610f15dd"
dependencies = [
"futures 0.3.11",
"js-sys",
......@@ -3216,29 +3213,27 @@ dependencies = [
[[package]]
name = "libp2p-websocket"
version = "0.27.0"
version = "0.28.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "270c80528e21089ea25b41dd1ab8fd834bdf093ebee422fed3b68699a857a083"
checksum = "d3b1c6a3431045da8b925ed83384e4c5163e14b990572307fca9c507435d4d22"
dependencies = [
"async-tls",
"either",
"futures 0.3.11",
"futures-rustls",
"libp2p-core",
"log",
"quicksink",
"rustls 0.19.0",
"rw-stream-sink",
"soketto",
"url 2.2.0",
"webpki",
"webpki-roots",
]
[[package]]
name = "libp2p-yamux"
version = "0.29.0"
version = "0.30.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "36799de9092c35782f080032eddbc8de870f94a0def87cf9f8883efccd5cacf0"
checksum = "490b8b27fc40fe35212df1b6a3d14bffaa4117cbff956fdc2892168a371102ad"
dependencies = [
"futures 0.3.11",
"libp2p-core",
......@@ -3361,12 +3356,6 @@ dependencies = [
"hashbrown",
]
[[package]]
name = "lru_time_cache"
version = "0.11.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "ebac060fafad3adedd0c66a80741a92ff4bc8e94a273df2ba3770ab206f2e29a"
[[package]]
name = "mach"
version = "0.3.2"
......@@ -3616,7 +3605,7 @@ dependencies = [
"generic-array 0.14.4",
"multihash-derive",
"sha2 0.9.2",
"unsigned-varint",
"unsigned-varint 0.5.1",
]
[[package]]
......@@ -3641,16 +3630,16 @@ checksum = "d8883adfde9756c1d30b0f519c9b8c502a94b41ac62f696453c37c7fc0a958ce"
[[package]]
name = "multistream-select"
version = "0.9.1"
version = "0.10.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "dda822043bba2d6da31c4e14041f9794f8fb130a5959289038d0b809d8888614"
checksum = "10ddc0eb0117736f19d556355464fc87efc8ad98b29e3fd84f02531eb6e90840"
dependencies = [
"bytes 0.5.6",
"bytes 1.0.1",
"futures 0.3.11",
"log",
"pin-project 1.0.4",
"smallvec 1.6.1",
"unsigned-varint",
"unsigned-varint 0.6.0",
]
[[package]]
......@@ -3907,7 +3896,7 @@ checksum = "13370dae44474229701bb69b90b4f4dca6404cb0357a2d50d635f1171dc3aa7b"
[[package]]
name = "pallet-authority-discovery"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-support",
"frame-system",
......@@ -3923,7 +3912,7 @@ dependencies = [
[[package]]
name = "pallet-authorship"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-support",
"frame-system",
......@@ -3938,7 +3927,7 @@ dependencies = [
[[package]]
name = "pallet-babe"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3963,7 +3952,7 @@ dependencies = [
[[package]]
name = "pallet-balances"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3977,7 +3966,7 @@ dependencies = [
[[package]]
name = "pallet-bounties"
version = "2.0.0"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3992,7 +3981,7 @@ dependencies = [
[[package]]
name = "pallet-collective"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4008,7 +3997,7 @@ dependencies = [
[[package]]
name = "pallet-democracy"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4023,7 +4012,7 @@ dependencies = [
[[package]]
name = "pallet-elections-phragmen"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4038,7 +4027,7 @@ dependencies = [
[[package]]
name = "pallet-grandpa"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4059,7 +4048,7 @@ dependencies = [
[[package]]
name = "pallet-identity"
version = "2.0.1"
source = "git+https://github.com/paritytech/substrate#8ee55dde2eb62f85aa64b54a0814529ea2b8368d"
source = "git+https://github.com/paritytech/substrate#7a79f54a5d92cecba1d9c1e4da71df1e8a6ed91b"
dependencies = [