Unverified Commit 31fb8fed authored by Andronik Ordian's avatar Andronik Ordian Committed by GitHub
Browse files

update most of the dependencies (#1946)

* update tiny-keccak to 0.2

* update deps except bitvec and shared_memory

* fix some warning after futures upgrade

* remove useless package rename caused by bug in cargo-upgrade

* revert parity-util-mem *

* remove unused import

* cargo update

* remove all renames on parity-scale-codec

* remove the leftovers

* remove unused dep
parent 120d5dde
......@@ -5,9 +5,9 @@ authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
[dependencies]
futures = "0.3.5"
futures = "0.3.8"
log = "0.4.11"
codec = { package="parity-scale-codec", version = "1.3.4" }
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
polkadot-primitives = { path = "../../../primitives" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
polkadot-node-subsystem-util = { path = "../../subsystem-util" }
......@@ -21,6 +21,6 @@ sp-application-crypto = { git = "https://github.com/paritytech/substrate", branc
sp-keystore = { git = "https://github.com/paritytech/substrate", branch = "master" }
sc-keystore = { git = "https://github.com/paritytech/substrate", branch = "master" }
maplit = "1.0.2"
env_logger = "0.7.1"
assert_matches = "1.3.0"
env_logger = "0.8.1"
assert_matches = "1.4.0"
tempfile = "3.1.0"
......@@ -22,7 +22,7 @@
#![deny(unused_crate_dependencies)]
use codec::{Decode, Encode};
use parity_scale_codec::{Decode, Encode};
use futures::{channel::oneshot, FutureExt};
use log::{debug, trace, warn};
......@@ -167,7 +167,7 @@ impl BitfieldDistribution {
&mut ctx,
&mut state,
&self.metrics,
hash,
hash,
signed_availability,
).await {
warn!(target: LOG_TARGET, "Failed to reply to `DistributeBitfield` message: {}", err);
......
......@@ -5,11 +5,11 @@ authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
[dependencies]
async-trait = "0.1"
futures = "0.3.5"
async-trait = "0.1.41"
futures = "0.3.8"
log = "0.4.11"
polkadot-primitives = { path = "../../../primitives" }
parity-scale-codec = "1.3.4"
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
sc-authority-discovery = { git = "https://github.com/paritytech/substrate", branch = "master" }
sc-network = { git = "https://github.com/paritytech/substrate", branch = "master" }
sp-runtime = { git = "https://github.com/paritytech/substrate", branch = "master" }
......@@ -17,8 +17,8 @@ polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsys
polkadot-node-network-protocol = { path = "../protocol" }
[dev-dependencies]
assert_matches = "1.3.0"
parking_lot = "0.10.0"
assert_matches = "1.4.0"
parking_lot = "0.11.0"
polkadot-node-subsystem-test-helpers = { path = "../../subsystem-test-helpers" }
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
sp-keyring = { git = "https://github.com/paritytech/substrate", branch = "master" }
......@@ -5,9 +5,9 @@ authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
[dependencies]
futures = "0.3.5"
futures = "0.3.8"
log = "0.4.11"
thiserror = "1.0.21"
thiserror = "1.0.22"
polkadot-primitives = { path = "../../../primitives" }
......@@ -16,8 +16,8 @@ polkadot-node-subsystem-util = { path = "../../subsystem-util" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
[dev-dependencies]
env_logger = "0.7.1"
assert_matches = "1.3.0"
env_logger = "0.8.1"
assert_matches = "1.4.0"
smallvec = "1.4.2"
futures-timer = "3.0.2"
......
......@@ -5,7 +5,7 @@ authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
[dependencies]
futures = "0.3.5"
futures = "0.3.8"
log = "0.4.11"
polkadot-primitives = { path = "../../../primitives" }
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
......@@ -13,6 +13,6 @@ polkadot-node-subsystem-util = { path = "../../subsystem-util" }
polkadot-node-network-protocol = { path = "../../network/protocol" }
[dev-dependencies]
assert_matches = "1.3.0"
assert_matches = "1.4.0"
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
polkadot-node-subsystem-test-helpers = { path = "../../subsystem-test-helpers" }
......@@ -8,5 +8,5 @@ description = "Primitives types for the Node-side"
[dependencies]
polkadot-primitives = { path = "../../../primitives" }
polkadot-node-primitives = { path = "../../primitives" }
parity-scale-codec = { version = "1.3.4", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
sc-network = { git = "https://github.com/paritytech/substrate", branch = "master" }
......@@ -6,7 +6,7 @@ description = "Statement Distribution Subsystem"
edition = "2018"
[dependencies]
futures = "0.3.5"
futures = "0.3.8"
log = "0.4.11"
polkadot-primitives = { path = "../../../primitives" }
node-primitives = { package = "polkadot-node-primitives", path = "../../primitives" }
......@@ -14,12 +14,12 @@ sp-staking = { git = "https://github.com/paritytech/substrate", branch = "master
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../../subsystem" }
polkadot-node-subsystem-util = { path = "../../subsystem-util" }
polkadot-node-network-protocol = { path = "../../network/protocol" }
arrayvec = "0.5.1"
indexmap = "1.4.0"
arrayvec = "0.5.2"
indexmap = "1.6.0"
[dev-dependencies]
polkadot-node-subsystem-test-helpers = { path = "../../subsystem-test-helpers" }
assert_matches = "1.3.0"
assert_matches = "1.4.0"
sp-keyring = { git = "https://github.com/paritytech/substrate", branch = "master" }
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
sp-application-crypto = { git = "https://github.com/paritytech/substrate", branch = "master" }
......
......@@ -5,7 +5,7 @@ authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
[dependencies]
futures = "0.3.5"
futures = "0.3.8"
log = "0.4.11"
futures-timer = "3.0.2"
streamunordered = "0.5.1"
......@@ -14,12 +14,12 @@ client = { package = "sc-client-api", git = "https://github.com/paritytech/subst
polkadot-subsystem = { package = "polkadot-node-subsystem", path = "../subsystem" }
polkadot-node-subsystem-util = { path = "../subsystem-util" }
polkadot-node-primitives = { package = "polkadot-node-primitives", path = "../primitives" }
async-trait = "0.1"
async-trait = "0.1.41"
[dev-dependencies]
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
polkadot-node-network-protocol = { path = "../network/protocol" }
futures = { version = "0.3.5", features = ["thread-pool"] }
futures = { version = "0.3.8", features = ["thread-pool"] }
futures-timer = "3.0.2"
femme = "2.1.1"
log = "0.4.11"
......
......@@ -1275,7 +1275,7 @@ where
loop {
select! {
x = self.running_subsystems.next() => {
_ = self.running_subsystems.next() => {
if self.running_subsystems.is_empty() {
break;
}
......@@ -1765,7 +1765,7 @@ mod tests {
loop {
select! {
a = overseer_fut => break,
_ = overseer_fut => break,
s1_next = s1_rx.next() => {
match s1_next {
Some(msg) => {
......@@ -1779,7 +1779,7 @@ mod tests {
},
s2_next = s2_rx.next() => {
match s2_next {
Some(msg) => s2_results.push(s2_next),
Some(_) => s2_results.push(s2_next),
None => break,
}
},
......
......@@ -6,9 +6,9 @@ edition = "2018"
description = "Primitives types for the Node-side"
[dependencies]
futures = "0.3.5"
futures = "0.3.8"
polkadot-primitives = { path = "../../primitives" }
polkadot-statement-table = { path = "../../statement-table" }
parity-scale-codec = { version = "1.3.4", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
runtime_primitives = { package = "sp-runtime", git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
......@@ -52,13 +52,12 @@ frame-system-rpc-runtime-api = { git = "https://github.com/paritytech/substrate"
prometheus-endpoint = { package = "substrate-prometheus-endpoint", git = "https://github.com/paritytech/substrate", branch = "master" }
# External Crates
codec = { package = "parity-scale-codec", version = "1.3.4" }
futures = "0.3.4"
hex-literal = "0.2.1"
futures = "0.3.8"
hex-literal = "0.3.1"
lazy_static = "1.4.0"
log = "0.4.8"
parking_lot = "0.9.0"
serde = { version = "1.0.102", features = ["derive"] }
log = "0.4.11"
parking_lot = "0.11.0"
serde = { version = "1.0.117", features = ["derive"] }
slog = "2.5.2"
# Polkadot
......
......@@ -6,20 +6,20 @@ edition = "2018"
description = "Subsystem traits and message definitions"
[dependencies]
async-trait = "0.1"
futures = "0.3.5"
async-trait = "0.1.41"
futures = "0.3.8"
futures-timer = "3.0.2"
log = "0.4.8"
parity-scale-codec = "1.3.4"
parking_lot = "0.10.0"
pin-project = "0.4.23"
log = "0.4.11"
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
parking_lot = "0.11.0"
pin-project = "1.0.1"
polkadot-node-primitives = { path = "../primitives" }
polkadot-node-subsystem = { path = "../subsystem" }
polkadot-node-subsystem-util = { path = "../subsystem-util" }
polkadot-primitives = { path = "../../primitives" }
polkadot-statement-table = { path = "../../statement-table" }
sc-network = { git = "https://github.com/paritytech/substrate", branch = "master" }
smallvec = "1.4.1"
smallvec = "1.4.2"
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
[dev-dependencies]
......
......@@ -6,14 +6,14 @@ edition = "2018"
description = "Subsystem traits and message definitions"
[dependencies]
async-trait = "0.1"
futures = "0.3.5"
async-trait = "0.1.41"
futures = "0.3.8"
futures-timer = "3.0.2"
log = "0.4.11"
thiserror = "1.0.21"
parity-scale-codec = "1.3.4"
parking_lot = { version = "0.10.0", optional = true }
pin-project = "0.4.22"
thiserror = "1.0.22"
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
parking_lot = { version = "0.11.0", optional = true }
pin-project = "1.0.1"
streamunordered = "0.5.1"
polkadot-node-primitives = { path = "../primitives" }
......@@ -27,9 +27,9 @@ sp-keystore = { git = "https://github.com/paritytech/substrate", branch = "maste
substrate-prometheus-endpoint = { git = "https://github.com/paritytech/substrate", branch = "master" }
[dev-dependencies]
assert_matches = "1.3.0"
async-trait = "0.1"
futures = { version = "0.3.5", features = ["thread-pool"] }
parking_lot = "0.10.0"
assert_matches = "1.4.0"
async-trait = "0.1.41"
futures = { version = "0.3.8", features = ["thread-pool"] }
parking_lot = "0.11.0"
polkadot-node-subsystem-test-helpers = { path = "../subsystem-test-helpers" }
env_logger = "0.7.1"
env_logger = "0.8.1"
......@@ -6,27 +6,27 @@ edition = "2018"
description = "Subsystem traits and message definitions"
[dependencies]
async-trait = "0.1"
async-trait = "0.1.41"
derive_more = "0.99.11"
futures = "0.3.5"
futures = "0.3.8"
futures-timer = "3.0.2"
log = "0.4.8"
parity-scale-codec = "1.3.4"
parking_lot = { version = "0.10.0", optional = true }
pin-project = "0.4.22"
log = "0.4.11"
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
parking_lot = { version = "0.11.0", optional = true }
pin-project = "1.0.1"
polkadot-node-primitives = { path = "../primitives" }
polkadot-node-network-protocol = { path = "../network/protocol" }
polkadot-primitives = { path = "../../primitives" }
polkadot-statement-table = { path = "../../statement-table" }
sc-network = { git = "https://github.com/paritytech/substrate", branch = "master" }
smallvec = "1.4.1"
smallvec = "1.4.2"
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
substrate-prometheus-endpoint = { git = "https://github.com/paritytech/substrate", branch = "master" }
thiserror = "1.0.21"
thiserror = "1.0.22"
[dev-dependencies]
assert_matches = "1.3.0"
async-trait = "0.1"
futures = { version = "0.3.5", features = ["thread-pool"] }
parking_lot = "0.10.0"
assert_matches = "1.4.0"
async-trait = "0.1.41"
futures = { version = "0.3.8", features = ["thread-pool"] }
parking_lot = "0.11.0"
polkadot-node-subsystem-test-helpers = { path = "../subsystem-test-helpers" }
......@@ -5,7 +5,7 @@ authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
[dependencies]
codec = { package = "parity-scale-codec", version = "1.3.4", default-features = false, features = ["derive"] }
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
# Polkadot dependencies
polkadot-test-runtime = { path = "../../../runtime/test-runtime" }
......
......@@ -21,7 +21,7 @@ use sp_runtime::generic::BlockId;
use sp_api::ProvideRuntimeApi;
use sc_block_builder::{BlockBuilderProvider, BlockBuilder};
use sp_state_machine::BasicExternalities;
use codec::{Encode, Decode};
use parity_scale_codec::{Encode, Decode};
/// An extension for the test client to init a Polkadot specific block builder.
pub trait InitPolkadotBlockBuilder {
......
......@@ -5,10 +5,10 @@ authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
[dependencies]
futures = "0.3.4"
futures = "0.3.8"
futures01 = { package = "futures", version = "0.1.29" }
hex = "0.4"
log = "0.4.8"
hex = "0.4.2"
log = "0.4.11"
rand = "0.7.3"
tempfile = "3.1.0"
......@@ -56,6 +56,6 @@ substrate-test-client = { git = "https://github.com/paritytech/substrate", branc
[dev-dependencies]
pallet-balances = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
serde_json = "1.0"
serde_json = "1.0.59"
substrate-test-utils = { git = "https://github.com/paritytech/substrate", branch = "master" }
tokio = { version = "0.2", features = ["macros"] }
......@@ -9,23 +9,23 @@ edition = "2018"
# note: special care is taken to avoid inclusion of `sp-io` externals when compiling
# this crate for WASM. This is critical to avoid forcing all parachain WASM into implementing
# various unnecessary Substrate-specific endpoints.
codec = { package = "parity-scale-codec", version = "1.3.4", default-features = false, features = [ "derive" ] }
parity-scale-codec = { version = "1.3.5", default-features = false, features = [ "derive" ] }
sp-std = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-runtime = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
sp-wasm-interface = { git = "https://github.com/paritytech/substrate", branch = "master", default-features = false }
polkadot-core-primitives = { path = "../core-primitives", default-features = false }
derive_more = { version = "0.99.11" }
derive_more = "0.99.11"
# all optional crates.
thiserror = { version = "1.0.21", optional = true }
serde = { version = "1.0.102", default-features = false, features = [ "derive" ], optional = true }
thiserror = { version = "1.0.22", optional = true }
serde = { version = "1.0.117", default-features = false, features = [ "derive" ], optional = true }
sp-externalities = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
sc-executor = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
sp-io = { git = "https://github.com/paritytech/substrate", branch = "master", optional = true }
parking_lot = { version = "0.10.0", optional = true }
log = { version = "0.4.8", optional = true }
futures = { version = "0.3.4", optional = true }
parking_lot = { version = "0.11.0", optional = true }
log = { version = "0.4.11", optional = true }
futures = { version = "0.3.8", optional = true }
[target.'cfg(not(any(target_os = "android", target_os = "unknown")))'.dependencies]
shared_memory = { version = "0.10.0", optional = true }
......@@ -34,7 +34,7 @@ shared_memory = { version = "0.10.0", optional = true }
default = ["std"]
wasm-api = []
std = [
"codec/std",
"parity-scale-codec/std",
"thiserror",
"serde/std",
"sp-std/std",
......
......@@ -19,7 +19,7 @@
use sp_std::vec::Vec;
use codec::{Encode, Decode, CompactAs};
use parity_scale_codec::{Encode, Decode, CompactAs};
use sp_core::{RuntimeDebug, TypeId};
#[cfg(feature = "std")]
......@@ -147,12 +147,12 @@ pub trait AccountIdConversion<AccountId>: Sized {
// TODO: Remove all of this, move sp-runtime::AccountIdConversion to own crate and and use that.
// #360
struct TrailingZeroInput<'a>(&'a [u8]);
impl<'a> codec::Input for TrailingZeroInput<'a> {
fn remaining_len(&mut self) -> Result<Option<usize>, codec::Error> {
impl<'a> parity_scale_codec::Input for TrailingZeroInput<'a> {
fn remaining_len(&mut self) -> Result<Option<usize>, parity_scale_codec::Error> {
Ok(None)
}
fn read(&mut self, into: &mut [u8]) -> Result<(), codec::Error> {
fn read(&mut self, into: &mut [u8]) -> Result<(), parity_scale_codec::Error> {
let len = into.len().min(self.0.len());
into[..len].copy_from_slice(&self.0[..len]);
for i in &mut into[len..] {
......
......@@ -26,7 +26,7 @@ pub unsafe fn load_params(params: *const u8, len: usize)
{
let mut slice = sp_std::slice::from_raw_parts(params, len);
codec::Decode::decode(&mut slice).expect("Invalid input data")
parity_scale_codec::Decode::decode(&mut slice).expect("Invalid input data")
}
/// Allocate the validation result in memory, getting the return-pointer back.
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment