Commit 2d0d65fb authored by parity-processbot's avatar parity-processbot
Browse files

update Substrate

parent a3956386
Pipeline #134969 failed with stages
in 9 minutes and 20 seconds
......@@ -1782,7 +1782,7 @@ checksum = "3f9eec918d3f24069decb9af1554cad7c880e2da24a9afd88aca000531ab82c1"
[[package]]
name = "fork-tree"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"parity-scale-codec",
]
......@@ -1800,7 +1800,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking"
version = "3.1.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
......@@ -1819,7 +1819,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking-cli"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"Inflector",
"chrono",
......@@ -1842,7 +1842,7 @@ dependencies = [
[[package]]
name = "frame-election-provider-support"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
......@@ -1855,12 +1855,11 @@ dependencies = [
[[package]]
name = "frame-executive"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
"parity-scale-codec",
"serde",
"sp-core",
"sp-io",
"sp-runtime",
......@@ -1871,7 +1870,7 @@ dependencies = [
[[package]]
name = "frame-metadata"
version = "13.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"parity-scale-codec",
"serde",
......@@ -1882,7 +1881,7 @@ dependencies = [
[[package]]
name = "frame-support"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"bitflags",
"frame-metadata",
......@@ -1908,7 +1907,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"Inflector",
"frame-support-procedural-tools",
......@@ -1920,7 +1919,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support-procedural-tools-derive",
"proc-macro-crate 1.0.0",
......@@ -1932,7 +1931,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools-derive"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"proc-macro2",
"quote",
......@@ -1942,7 +1941,7 @@ dependencies = [
[[package]]
name = "frame-support-test"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-metadata",
"frame-support",
......@@ -1963,7 +1962,7 @@ dependencies = [
[[package]]
name = "frame-system"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"impl-trait-for-tuples",
......@@ -1980,7 +1979,7 @@ dependencies = [
[[package]]
name = "frame-system-benchmarking"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -1994,7 +1993,7 @@ dependencies = [
[[package]]
name = "frame-system-rpc-runtime-api"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"parity-scale-codec",
"sp-api",
......@@ -2003,7 +2002,7 @@ dependencies = [
[[package]]
name = "frame-try-runtime"
version = "0.9.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"parity-scale-codec",
......@@ -3295,9 +3294,9 @@ checksum = "c7d73b3f436185384286bd8098d17ec07c9a7d2388a6599f824d8502b529702a"
[[package]]
name = "libp2p"
version = "0.36.0"
version = "0.37.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "fe5759b526f75102829c15e4d8566603b4bf502ed19b5f35920d98113873470d"
checksum = "08053fbef67cd777049ef7a95ebaca2ece370b4ed7712c3fa404d69a88cb741b"
dependencies = [
"atomic",
"bytes 1.0.1",
......@@ -3393,9 +3392,9 @@ dependencies = [
[[package]]
name = "libp2p-floodsub"
version = "0.28.0"
version = "0.29.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "897645f99e9b396df256a6aa8ba8c4bc019ac6b7c62556f624b5feea9acc82bb"
checksum = "48a9b570f6766301d9c4aa00fce3554cad1598e2f466debbc4dde909028417cf"
dependencies = [
"cuckoofilter",
"fnv",
......@@ -3411,9 +3410,9 @@ dependencies = [
[[package]]
name = "libp2p-gossipsub"
version = "0.29.0"
version = "0.30.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "794b0c85f5df1acbc1fc38414d37272594811193b6325c76d3931c3e3f5df8c0"
checksum = "73cb9a89a301afde1e588c73f7e9131e12a5388725f290a9047b878862db1b53"
dependencies = [
"asynchronous-codec 0.6.0",
"base64 0.13.0",
......@@ -3437,9 +3436,9 @@ dependencies = [
[[package]]
name = "libp2p-identify"
version = "0.28.0"
version = "0.29.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "f88ebc841d744979176ab4b8b294a3e655a7ba4ef26a905d073a52b49ed4dff5"
checksum = "5f668f00efd9883e8b7bcc582eaf0164615792608f886f6577da18bcbeea0a46"
dependencies = [
"futures 0.3.13",
"libp2p-core",
......@@ -3453,9 +3452,9 @@ dependencies = [
[[package]]
name = "libp2p-kad"
version = "0.29.0"
version = "0.30.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "bbb5b90b6bda749023a85f60b49ea74b387c25f17d8df541ae72a3c75dd52e63"
checksum = "b07312ebe5ee4fd2404447a0609814574df55c65d4e20838b957bbd34907d820"
dependencies = [
"arrayvec 0.5.2",
"asynchronous-codec 0.6.0",
......@@ -3479,9 +3478,9 @@ dependencies = [
[[package]]
name = "libp2p-mdns"
version = "0.29.0"
version = "0.30.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "be28ca13bb648d249a9baebd750ebc64ce7040ddd5f0ce1035ff1f4549fb596d"
checksum = "c221897b3fd7f215de7ecfec215c5eba598e5b61c605b5f8b56fe8a4fb507724"
dependencies = [
"async-io",
"data-encoding",
......@@ -3540,9 +3539,9 @@ dependencies = [
[[package]]
name = "libp2p-ping"
version = "0.28.0"
version = "0.29.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "dea10fc5209260915ea65b78f612d7ff78a29ab288e7aa3250796866af861c45"
checksum = "bf4bfaffac63bf3c7ec11ed9d8879d455966ddea7e78ee14737f0b6dce0d1cd1"
dependencies = [
"futures 0.3.13",
"libp2p-core",
......@@ -3586,9 +3585,9 @@ dependencies = [
[[package]]
name = "libp2p-relay"
version = "0.1.0"
version = "0.2.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "3ff268be6a9d6f3c6cca3b81bbab597b15217f9ad8787c6c40fc548c1af7cd24"
checksum = "0b8786aca3f18671d8776289706a5521f6c9124a820f69e358de214b9939440d"
dependencies = [
"asynchronous-codec 0.6.0",
"bytes 1.0.1",
......@@ -3609,9 +3608,9 @@ dependencies = [
[[package]]
name = "libp2p-request-response"
version = "0.10.0"
version = "0.11.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "725367dd2318c54c5ab1a6418592e5b01c63b0dedfbbfb8389220b2bcf691899"
checksum = "1cdbe172f08e6d0f95fa8634e273d4c4268c4063de2e33e7435194b0130c62e3"
dependencies = [
"async-trait",
"bytes 1.0.1",
......@@ -3629,9 +3628,9 @@ dependencies = [
[[package]]
name = "libp2p-swarm"
version = "0.28.0"
version = "0.29.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "75c26980cadd7c25d89071cb23e1f7f5df4863128cc91d83c6ddc72338cecafa"
checksum = "1e04d8e1eef675029ec728ba14e8d0da7975d84b6679b699b4ae91a1de9c3a92"
dependencies = [
"either",
"futures 0.3.13",
......@@ -3645,9 +3644,9 @@ dependencies = [
[[package]]
name = "libp2p-swarm-derive"
version = "0.22.0"
version = "0.23.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "c564ebaa36a64839f51eaddb0243aaaa29ce64affb56129193cc3248b72af273"
checksum = "365b0a699fea5168676840567582a012ea297b1ca02eee467e58301b9c9c5eed"
dependencies = [
"quote",
"syn",
......@@ -3684,9 +3683,9 @@ dependencies = [
[[package]]
name = "libp2p-wasm-ext"
version = "0.28.0"
version = "0.28.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "6df65fc13f6188edf7e6927b086330448b3ca27af86b49748c6d299d7c8d9040"
checksum = "cef45d61e43c313531b5e903e4e8415212ff6338e0c54c47da5b9b412b5760de"
dependencies = [
"futures 0.3.13",
"js-sys",
......@@ -3716,9 +3715,9 @@ dependencies = [
[[package]]
name = "libp2p-yamux"
version = "0.31.0"
version = "0.32.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "96d6144cc94143fb0a8dd1e7c2fbcc32a2808168bcd1d69920635424d5993b7b"
checksum = "f35da42cfc6d5cb0dcf3ad6881bc68d146cdf38f98655e09e33fbba4d13eabc4"
dependencies = [
"futures 0.3.13",
"libp2p-core",
......@@ -4385,13 +4384,12 @@ checksum = "13370dae44474229701bb69b90b4f4dca6404cb0357a2d50d635f1171dc3aa7b"
[[package]]
name = "pallet-authority-discovery"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
"pallet-session",
"parity-scale-codec",
"serde",
"sp-application-crypto",
"sp-authority-discovery",
"sp-runtime",
......@@ -4401,7 +4399,7 @@ dependencies = [
[[package]]
name = "pallet-authorship"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
......@@ -4416,7 +4414,7 @@ dependencies = [
[[package]]
name = "pallet-babe"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4426,7 +4424,6 @@ dependencies = [
"pallet-session",
"pallet-timestamp",
"parity-scale-codec",
"serde",
"sp-application-crypto",
"sp-consensus-babe",
"sp-consensus-vrf",
......@@ -4440,14 +4437,13 @@ dependencies = [
[[package]]
name = "pallet-balances"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"log",
"parity-scale-codec",
"serde",
"sp-runtime",
"sp-std",
]
......@@ -4470,14 +4466,13 @@ dependencies = [
[[package]]
name = "pallet-bounties"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"pallet-treasury",
"parity-scale-codec",
"serde",
"sp-runtime",
"sp-std",
]
......@@ -4485,14 +4480,13 @@ dependencies = [
[[package]]
name = "pallet-collective"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"log",
"parity-scale-codec",
"serde",
"sp-core",
"sp-io",
"sp-runtime",
......@@ -4502,7 +4496,7 @@ dependencies = [
[[package]]
name = "pallet-democracy"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4517,7 +4511,7 @@ dependencies = [
[[package]]
name = "pallet-election-provider-multi-phase"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-election-provider-support",
......@@ -4526,7 +4520,6 @@ dependencies = [
"log",
"parity-scale-codec",
"rand 0.7.3",
"serde",
"sp-arithmetic",
"sp-io",
"sp-npos-elections",
......@@ -4538,14 +4531,13 @@ dependencies = [
[[package]]
name = "pallet-elections-phragmen"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"log",
"parity-scale-codec",
"serde",
"sp-npos-elections",
"sp-runtime",
"sp-std",
......@@ -4554,7 +4546,7 @@ dependencies = [
[[package]]
name = "pallet-grandpa"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4563,7 +4555,6 @@ dependencies = [
"pallet-authorship",
"pallet-session",
"parity-scale-codec",
"serde",
"sp-application-crypto",
"sp-core",
"sp-finality-grandpa",
......@@ -4576,14 +4567,13 @@ dependencies = [
[[package]]
name = "pallet-identity"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"enumflags2",
"frame-benchmarking",
"frame-support",
"frame-system",
"parity-scale-codec",
"serde",
"sp-io",
"sp-runtime",
"sp-std",
......@@ -4592,7 +4582,7 @@ dependencies = [
[[package]]
name = "pallet-im-online"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4600,7 +4590,6 @@ dependencies = [
"log",
"pallet-authorship",
"parity-scale-codec",
"serde",
"sp-application-crypto",
"sp-core",
"sp-io",
......@@ -4612,13 +4601,12 @@ dependencies = [
[[package]]
name = "pallet-indices"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"parity-scale-codec",
"serde",
"sp-core",
"sp-io",
"sp-keyring",
......@@ -4629,12 +4617,13 @@ dependencies = [
[[package]]
name = "pallet-membership"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"log",
"parity-scale-codec",
"serde",
"sp-io",
"sp-runtime",
"sp-std",
......@@ -4643,7 +4632,7 @@ dependencies = [
[[package]]
name = "pallet-mmr"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"ckb-merkle-mountain-range",
"frame-benchmarking",
......@@ -4651,7 +4640,6 @@ dependencies = [
"frame-system",
"pallet-mmr-primitives",
"parity-scale-codec",
"serde",
"sp-core",
"sp-io",
"sp-runtime",
......@@ -4661,7 +4649,7 @@ dependencies = [
[[package]]
name = "pallet-mmr-primitives"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
......@@ -4677,7 +4665,7 @@ dependencies = [
[[package]]
name = "pallet-mmr-rpc"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"jsonrpc-core",
"jsonrpc-core-client",
......@@ -4695,13 +4683,12 @@ dependencies = [
[[package]]
name = "pallet-multisig"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"parity-scale-codec",
"serde",
"sp-core",
"sp-io",
"sp-runtime",
......@@ -4711,12 +4698,11 @@ dependencies = [
[[package]]
name = "pallet-nicks"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
"parity-scale-codec",
"serde",
"sp-io",
"sp-runtime",
"sp-std",
......@@ -4725,7 +4711,7 @@ dependencies = [
[[package]]
name = "pallet-offences"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
......@@ -4741,7 +4727,7 @@ dependencies = [
[[package]]
name = "pallet-offences-benchmarking"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-election-provider-support",
......@@ -4763,13 +4749,12 @@ dependencies = [
[[package]]
name = "pallet-proxy"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"parity-scale-codec",
"serde",
"sp-core",
"sp-io",
"sp-runtime",
......@@ -4779,7 +4764,7 @@ dependencies = [
[[package]]
name = "pallet-randomness-collective-flip"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
......@@ -4792,13 +4777,12 @@ dependencies = [
[[package]]
name = "pallet-recovery"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"enumflags2",
"frame-support",
"frame-system",
"parity-scale-codec",
"serde",
"sp-io",
"sp-runtime",
"sp-std",
......@@ -4807,14 +4791,13 @@ dependencies = [
[[package]]
name = "pallet-scheduler"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
"frame-system",
"log",
"parity-scale-codec",
"serde",
"sp-io",
"sp-runtime",
"sp-std",
......@@ -4823,14 +4806,13 @@ dependencies = [
[[package]]
name = "pallet-session"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
"impl-trait-for-tuples",
"pallet-timestamp",
"parity-scale-codec",
"serde",
"sp-core",
"sp-io",
"sp-runtime",
......@@ -4843,7 +4825,7 @@ dependencies = [
[[package]]
name = "pallet-session-benchmarking"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4859,13 +4841,12 @@ dependencies = [
[[package]]
name = "pallet-society"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
"parity-scale-codec",
"rand_chacha 0.2.2",
"serde",
"sp-runtime",
"sp-std",
]
......@@ -4873,7 +4854,7 @@ dependencies = [
[[package]]
name = "pallet-staking"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-benchmarking",
"frame-election-provider-support",
......@@ -4897,7 +4878,7 @@ dependencies = [
[[package]]
name = "pallet-staking-reward-curve"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"proc-macro-crate 1.0.0",
"proc-macro2",
......@@ -4908,12 +4889,11 @@ dependencies = [
[[package]]
name = "pallet-sudo"
version = "3.0.0"
source = "git+https://github.com/paritytech/substrate#a76aadc4b28311418ee114e23b07da46ecccecfb"
source = "git+https://github.com/paritytech/substrate#4b9a6bb0b24fb202e97ffd7a9c02ed6793122a06"
dependencies = [
"frame-support",
"frame-system",
"parity-scale-codec",
"serde",
"sp-io",
"sp-runtime",
"sp-std",
......@@ -4922,7 +4902,7 @@ dependencies = [