Commit 1abd7823 authored by Cecile Tonglet's avatar Cecile Tonglet
Browse files

Merge commit ed2c4cab (no conflict)

Parent branch: origin/master
Forked at: 77de8b91
parents d41d65b1 ed2c4cab
......@@ -279,8 +279,6 @@ deploy-polkasync-kusama:
variables:
POLKADOT_CI_COMMIT_NAME: "${CI_COMMIT_REF_NAME}"
POLKADOT_CI_COMMIT_REF: "${CI_COMMIT_REF}"
only:
- ci-testnet-deployment
allow_failure: true
trigger: "parity/infrastructure/parity-testnet"
......@@ -10,34 +10,6 @@ dependencies = [
"regex",
]
[[package]]
name = "adder"
version = "0.7.29-pre1"
dependencies = [
"dlmalloc",
"parity-scale-codec",
"polkadot-parachain",
"sp-io",
"substrate-wasm-builder-runner 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"tiny-keccak 1.5.0",
]
[[package]]
name = "adder-collator"
version = "0.1.0"
dependencies = [
"adder",
"futures 0.3.4",
"parity-scale-codec",
"parking_lot 0.10.0",
"polkadot-collator",
"polkadot-parachain",
"polkadot-primitives",
"sc-client",
"sc-client-api",
"sp-core",
]
[[package]]
name = "adler32"
version = "1.0.4"
......@@ -1022,6 +994,17 @@ version = "1.5.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "bb1f6b1ce1c140482ea30ddd3335fc0024ac7ee112895426e0a629a6c20adfe3"
[[package]]
name = "enum-primitive-derive"
version = "0.1.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e2b90e520ec62c1864c8c78d637acbfe8baf5f63240f2fb8165b8325c07812dd"
dependencies = [
"num-traits 0.1.43",
"quote 0.3.15",
"syn 0.11.11",
]
[[package]]
name = "enum_primitive"
version = "0.1.1"
......@@ -1284,7 +1267,7 @@ checksum = "2fad85553e09a6f881f739c29f0b00b0f01357c743266d478b68951ce23285f3"
[[package]]
name = "fork-tree"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"parity-scale-codec",
]
......@@ -1292,7 +1275,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -1308,7 +1291,7 @@ dependencies = [
[[package]]
name = "frame-benchmarking-cli"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-benchmarking",
"parity-scale-codec",
......@@ -1327,7 +1310,7 @@ dependencies = [
[[package]]
name = "frame-executive"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -1340,7 +1323,7 @@ dependencies = [
[[package]]
name = "frame-metadata"
version = "11.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"parity-scale-codec",
"serde",
......@@ -1351,7 +1334,7 @@ dependencies = [
[[package]]
name = "frame-support"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"bitmask",
"frame-metadata",
......@@ -1375,7 +1358,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support-procedural-tools",
"proc-macro2 1.0.9",
......@@ -1386,7 +1369,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support-procedural-tools-derive",
"proc-macro-crate",
......@@ -1398,7 +1381,7 @@ dependencies = [
[[package]]
name = "frame-support-procedural-tools-derive"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"proc-macro2 1.0.9",
"quote 1.0.3",
......@@ -1408,7 +1391,7 @@ dependencies = [
[[package]]
name = "frame-system"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"impl-trait-for-tuples",
......@@ -1424,7 +1407,7 @@ dependencies = [
[[package]]
name = "frame-system-rpc-runtime-api"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"parity-scale-codec",
"sp-api",
......@@ -1767,13 +1750,6 @@ dependencies = [
"tokio-util",
]
[[package]]
name = "halt"
version = "0.7.29-pre1"
dependencies = [
"substrate-wasm-builder-runner 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "hash-db"
version = "0.15.2"
......@@ -2446,6 +2422,18 @@ version = "0.2.68"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "dea0c0405123bba743ee3f91f49b1c7cfb684eef0da0a50110f758ccf24cdff0"
[[package]]
name = "libflate"
version = "0.1.27"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "d9135df43b1f5d0e333385cb6e7897ecd1a43d7d11b91ac003f4d2c2d2401fdd"
dependencies = [
"adler32",
"crc32fast",
"rle-decode-fast",
"take_mut",
]
[[package]]
name = "libloading"
version = "0.5.2"
......@@ -3187,6 +3175,20 @@ dependencies = [
"winapi 0.3.8",
]
[[package]]
name = "netstat2"
version = "0.8.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "29449d242064c48d3057a194b049a2bdcccadda16faa18a91468677b44e8d422"
dependencies = [
"bitflags",
"byteorder 1.3.4",
"enum-primitive-derive",
"libc",
"num-traits 0.2.11",
"thiserror",
]
[[package]]
name = "nix"
version = "0.10.0"
......@@ -3374,7 +3376,7 @@ dependencies = [
[[package]]
name = "pallet-authority-discovery"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3392,7 +3394,7 @@ dependencies = [
[[package]]
name = "pallet-authorship"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3409,7 +3411,7 @@ dependencies = [
[[package]]
name = "pallet-babe"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3430,7 +3432,7 @@ dependencies = [
[[package]]
name = "pallet-balances"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3445,7 +3447,7 @@ dependencies = [
[[package]]
name = "pallet-collective"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3461,7 +3463,7 @@ dependencies = [
[[package]]
name = "pallet-democracy"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3476,7 +3478,7 @@ dependencies = [
[[package]]
name = "pallet-elections-phragmen"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3490,7 +3492,7 @@ dependencies = [
[[package]]
name = "pallet-finality-tracker"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3506,7 +3508,7 @@ dependencies = [
[[package]]
name = "pallet-grandpa"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3524,7 +3526,7 @@ dependencies = [
[[package]]
name = "pallet-identity"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"enumflags2",
"frame-benchmarking",
......@@ -3540,7 +3542,7 @@ dependencies = [
[[package]]
name = "pallet-im-online"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3559,7 +3561,7 @@ dependencies = [
[[package]]
name = "pallet-indices"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3575,7 +3577,7 @@ dependencies = [
[[package]]
name = "pallet-membership"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3589,7 +3591,7 @@ dependencies = [
[[package]]
name = "pallet-nicks"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3603,7 +3605,7 @@ dependencies = [
[[package]]
name = "pallet-offences"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3618,7 +3620,7 @@ dependencies = [
[[package]]
name = "pallet-randomness-collective-flip"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3631,7 +3633,7 @@ dependencies = [
[[package]]
name = "pallet-recovery"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"enumflags2",
"frame-support",
......@@ -3646,7 +3648,7 @@ dependencies = [
[[package]]
name = "pallet-scheduler"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3661,7 +3663,7 @@ dependencies = [
[[package]]
name = "pallet-session"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3679,7 +3681,7 @@ dependencies = [
[[package]]
name = "pallet-society"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3694,7 +3696,7 @@ dependencies = [
[[package]]
name = "pallet-staking"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3715,7 +3717,7 @@ dependencies = [
[[package]]
name = "pallet-staking-reward-curve"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"proc-macro-crate",
"proc-macro2 1.0.9",
......@@ -3726,7 +3728,7 @@ dependencies = [
[[package]]
name = "pallet-sudo"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3740,7 +3742,7 @@ dependencies = [
[[package]]
name = "pallet-timestamp"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -3757,7 +3759,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3770,7 +3772,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"jsonrpc-core",
"jsonrpc-core-client",
......@@ -3788,7 +3790,7 @@ dependencies = [
[[package]]
name = "pallet-transaction-payment-rpc-runtime-api"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"parity-scale-codec",
......@@ -3801,7 +3803,7 @@ dependencies = [
[[package]]
name = "pallet-treasury"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3815,7 +3817,7 @@ dependencies = [
[[package]]
name = "pallet-utility"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"frame-support",
"frame-system",
......@@ -3830,7 +3832,7 @@ dependencies = [
[[package]]
name = "pallet-vesting"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"enumflags2",
"frame-support",
......@@ -4112,6 +4114,7 @@ dependencies = [
"parity-util-mem",
"polkadot-cli",
"polkadot-service",
"vergen",
]
[[package]]
......@@ -4154,13 +4157,11 @@ dependencies = [
"sc-client-api",
"sc-client-db",
"sc-executor",
"sc-service",
"sp-api",
"sp-core",
"sp-runtime",
"structopt",
"substrate-browser-utils",
"substrate-build-script-utils",
"tokio 0.2.13",
"wasm-bindgen",
"wasm-bindgen-futures",
......@@ -4258,10 +4259,7 @@ dependencies = [
name = "polkadot-parachain"
version = "0.7.29-pre1"
dependencies = [
"adder",
"derive_more 0.99.3",
"halt",
"lazy_static",
"log 0.4.8",
"parity-scale-codec",
"parking_lot 0.10.0",
......@@ -4274,7 +4272,6 @@ dependencies = [
"sp-runtime-interface",
"sp-std",
"sp-wasm-interface",
"tiny-keccak 1.5.0",
]
[[package]]
......@@ -4282,7 +4279,6 @@ name = "polkadot-primitives"
version = "0.7.29-pre1"
dependencies = [
"bitvec",
"pallet-babe",
"parity-scale-codec",
"polkadot-parachain",
"pretty_assertions",
......@@ -4718,18 +4714,33 @@ dependencies = [
"unicode-xid 0.2.0",
]
[[package]]
name = "procfs"
version = "0.7.8"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "fe50036aa1b71e553a4a0c48ab7baabf8aa8c7a5a61aae06bf38c2eab7430475"
dependencies = [
"bitflags",
"byteorder 1.3.4",
"chrono",
"hex",
"lazy_static",
"libc",
"libflate",
]
[[package]]
name = "prometheus"
version = "0.7.0"
version = "0.8.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "5567486d5778e2c6455b1b90ff1c558f29e751fc018130fa182e15828e728af1"
checksum = "b0575e258dab62268e7236d7307caa38848acbda7ec7ab87bd9093791e999d20"
dependencies = [
"cfg-if",
"fnv",
"lazy_static",
"protobuf",
"quick-error",
"spin",
"thiserror",
]
[[package]]
......@@ -4806,6 +4817,12 @@ dependencies = [
"pin-project-lite",
]
[[package]]
name = "quote"
version = "0.3.15"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "7a6e920b65c65f10b2ae65c831a81a073a89edd28c7cce89475bff467ab4167a"
[[package]]
name = "quote"
version = "0.6.13"
......@@ -5143,6 +5160,12 @@ dependencies = [
"winapi 0.3.8",
]
[[package]]
name = "rle-decode-fast"
version = "1.0.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "cabe4fa914dec5870285fa7f71f602645da47c486e68486d2b4ceb4a343e90ac"
[[package]]
name = "rlp"
version = "0.4.5"
......@@ -5304,7 +5327,7 @@ dependencies = [
[[package]]
name = "sc-authority-discovery"
version = "0.8.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"bytes 0.5.4",
"derive_more 0.99.3",
......@@ -5331,7 +5354,7 @@ dependencies = [
[[package]]
name = "sc-block-builder"
version = "0.8.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"parity-scale-codec",
"sc-client-api",
......@@ -5347,7 +5370,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"impl-trait-for-tuples",
"sc-chain-spec-derive",
......@@ -5362,7 +5385,7 @@ dependencies = [
[[package]]
name = "sc-chain-spec-derive"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"proc-macro-crate",
"proc-macro2 1.0.9",
......@@ -5373,7 +5396,7 @@ dependencies = [
[[package]]
name = "sc-cli"
version = "0.8.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"ansi_term 0.12.1",
"app_dirs",
......@@ -5404,6 +5427,7 @@ dependencies = [
"sp-panic-handler",
"sp-runtime",
"sp-state-machine",
"sp-utils",
"structopt",
"substrate-prometheus-endpoint",
"time",
......@@ -5413,7 +5437,7 @@ dependencies = [
[[package]]
name = "sc-client"
version = "0.8.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"derive_more 0.99.3",
"fnv",
......@@ -5439,6 +5463,7 @@ dependencies = [
"sp-state-machine",
"sp-std",
"sp-trie",
"sp-utils",
"sp-version",
"substrate-prometheus-endpoint",
"tracing",
......@@ -5447,7 +5472,7 @@ dependencies = [
[[package]]
name = "sc-client-api"
version = "2.0.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"derive_more 0.99.3",
"fnv",
......@@ -5455,6 +5480,7 @@ dependencies = [
"hash-db",
"hex-literal",
"kvdb",
"lazy_static",
"log 0.4.8",
"parity-scale-codec",
"parking_lot 0.10.0",
......@@ -5473,13 +5499,14 @@ dependencies = [
"sp-storage",
"sp-transaction-pool",
"sp-trie",
"sp-utils",
"sp-version",
]
[[package]]
name = "sc-client-db"
version = "0.8.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"hash-db",
"kvdb",
......@@ -5507,7 +5534,7 @@ dependencies = [
[[package]]
name = "sc-consensus-babe"
version = "0.8.0-alpha.5"
source = "git+https://github.com/paritytech/substrate#41ded05195e6422746d6efbf433eaa65bf0557d7"
source = "git+https://github.com/paritytech/substrate#f1d7d1d4d4f648536eefce6eefda6d0d2d1abb63"
dependencies = [
"derive_more 0.99.3",
"fork-tree",
......@@ -5549,7 +5576,7 @@ dependencies = [
[[package]]
name = "sc-consensus-epochs"
version = "0.8.0-alpha.5"