Commit 0f7f2187 authored by Gavin Wood's avatar Gavin Wood Committed by Bastian Köcher
Browse files

Bump versions (#655)

* Bump version

* Update Cargo lock and bump runtime version

* Remove balance transfer disabler.
parent 900b2c4c
Pipeline #70935 canceled with stages
in 9 minutes and 12 seconds
...@@ -11,11 +11,11 @@ dependencies = [ ...@@ -11,11 +11,11 @@ dependencies = [
[[package]] [[package]]
name = "adder" name = "adder"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"dlmalloc 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)", "dlmalloc 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.6", "polkadot-parachain 0.7.7",
"sp-io 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sp-io 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)", "substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
"tiny-keccak 1.5.0 (registry+https://github.com/rust-lang/crates.io-index)", "tiny-keccak 1.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -25,14 +25,14 @@ dependencies = [ ...@@ -25,14 +25,14 @@ dependencies = [
name = "adder-collator" name = "adder-collator"
version = "0.1.0" version = "0.1.0"
dependencies = [ dependencies = [
"adder 0.7.6", "adder 0.7.7",
"ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)", "ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)", "exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)", "futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)", "parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-collator 0.7.6", "polkadot-collator 0.7.7",
"polkadot-parachain 0.7.6", "polkadot-parachain 0.7.7",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -1521,7 +1521,7 @@ dependencies = [ ...@@ -1521,7 +1521,7 @@ dependencies = [
[[package]] [[package]]
name = "halt" name = "halt"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)", "substrate-wasm-builder-runner 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
] ]
...@@ -3455,18 +3455,18 @@ source = "registry+https://github.com/rust-lang/crates.io-index" ...@@ -3455,18 +3455,18 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]] [[package]]
name = "polkadot" name = "polkadot"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)", "ctrlc 3.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)", "futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.6", "polkadot-cli 0.7.7",
"polkadot-service 0.7.6", "polkadot-service 0.7.7",
"vergen 3.0.4 (registry+https://github.com/rust-lang/crates.io-index)", "vergen 3.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
] ]
[[package]] [[package]]
name = "polkadot-availability-store" name = "polkadot-availability-store"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)", "derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)", "exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3478,9 +3478,9 @@ dependencies = [ ...@@ -3478,9 +3478,9 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)", "log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)", "parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-erasure-coding 0.7.6", "polkadot-erasure-coding 0.7.7",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"polkadot-runtime 0.7.6", "polkadot-runtime 0.7.7",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-keystore 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-keystore 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -3495,12 +3495,12 @@ dependencies = [ ...@@ -3495,12 +3495,12 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-cli" name = "polkadot-cli"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)", "futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)", "futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)", "log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-service 0.7.6", "polkadot-service 0.7.7",
"sc-cli 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-cli 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"structopt 0.3.5 (registry+https://github.com/rust-lang/crates.io-index)", "structopt 0.3.5 (registry+https://github.com/rust-lang/crates.io-index)",
"tokio 0.1.22 (registry+https://github.com/rust-lang/crates.io-index)", "tokio 0.1.22 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3508,18 +3508,18 @@ dependencies = [ ...@@ -3508,18 +3508,18 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-collator" name = "polkadot-collator"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)", "futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)", "futures 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-timer 1.0.3 (registry+https://github.com/rust-lang/crates.io-index)", "futures-timer 1.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)", "log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.6", "polkadot-cli 0.7.7",
"polkadot-network 0.7.6", "polkadot-network 0.7.7",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"polkadot-runtime 0.7.6", "polkadot-runtime 0.7.7",
"polkadot-service 0.7.6", "polkadot-service 0.7.7",
"polkadot-validation 0.7.6", "polkadot-validation 0.7.7",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-network 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -3531,11 +3531,11 @@ dependencies = [ ...@@ -3531,11 +3531,11 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-erasure-coding" name = "polkadot-erasure-coding"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"derive_more 0.15.0 (registry+https://github.com/rust-lang/crates.io-index)", "derive_more 0.15.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"reed-solomon-erasure 4.0.0 (git+https://github.com/paritytech/reed-solomon-erasure)", "reed-solomon-erasure 4.0.0 (git+https://github.com/paritytech/reed-solomon-erasure)",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-trie 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sp-trie 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -3543,15 +3543,15 @@ dependencies = [ ...@@ -3543,15 +3543,15 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-executor" name = "polkadot-executor"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"polkadot-runtime 0.7.6", "polkadot-runtime 0.7.7",
"sc-executor 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-executor 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
] ]
[[package]] [[package]]
name = "polkadot-network" name = "polkadot-network"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"arrayvec 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)", "arrayvec 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)", "exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3560,10 +3560,10 @@ dependencies = [ ...@@ -3560,10 +3560,10 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)", "log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)", "parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.6", "polkadot-availability-store 0.7.7",
"polkadot-erasure-coding 0.7.6", "polkadot-erasure-coding 0.7.7",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"polkadot-validation 0.7.6", "polkadot-validation 0.7.7",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-network 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-network 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sp-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -3575,11 +3575,11 @@ dependencies = [ ...@@ -3575,11 +3575,11 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-parachain" name = "polkadot-parachain"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"adder 0.7.6", "adder 0.7.7",
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)", "derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
"halt 0.7.6", "halt 0.7.7",
"lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)", "lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)", "log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3594,12 +3594,12 @@ dependencies = [ ...@@ -3594,12 +3594,12 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-primitives" name = "polkadot-primitives"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)", "bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.6", "polkadot-parachain 0.7.7",
"pretty_assertions 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)", "pretty_assertions 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
"sc-application-crypto 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-application-crypto 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3614,12 +3614,12 @@ dependencies = [ ...@@ -3614,12 +3614,12 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-rpc" name = "polkadot-rpc"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"jsonrpc-core 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)", "jsonrpc-core 14.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-transaction-payment-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "pallet-transaction-payment-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"polkadot-runtime 0.7.6", "polkadot-runtime 0.7.7",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-rpc 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sp-runtime 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sp-runtime 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -3629,7 +3629,7 @@ dependencies = [ ...@@ -3629,7 +3629,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-runtime" name = "polkadot-runtime"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)", "bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-executive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "frame-executive 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -3662,8 +3662,8 @@ dependencies = [ ...@@ -3662,8 +3662,8 @@ dependencies = [
"pallet-transaction-payment-rpc-runtime-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "pallet-transaction-payment-rpc-runtime-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-treasury 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "pallet-treasury 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.6", "polkadot-parachain 0.7.7",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"rustc-hex 2.0.1 (registry+https://github.com/rust-lang/crates.io-index)", "rustc-hex 2.0.1 (registry+https://github.com/rust-lang/crates.io-index)",
"safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)", "safe-mix 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)", "serde 1.0.102 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3693,7 +3693,7 @@ dependencies = [ ...@@ -3693,7 +3693,7 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-service" name = "polkadot-service"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)", "exit-future 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)", "futures 0.1.29 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3705,13 +3705,13 @@ dependencies = [ ...@@ -3705,13 +3705,13 @@ dependencies = [
"pallet-im-online 0.1.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "pallet-im-online 0.1.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"pallet-staking 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "pallet-staking 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)", "parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.6", "polkadot-availability-store 0.7.7",
"polkadot-executor 0.7.6", "polkadot-executor 0.7.7",
"polkadot-network 0.7.6", "polkadot-network 0.7.7",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"polkadot-rpc 0.7.6", "polkadot-rpc 0.7.7",
"polkadot-runtime 0.7.6", "polkadot-runtime 0.7.7",
"polkadot-validation 0.7.6", "polkadot-validation 0.7.7",
"sc-authority-discovery 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-authority-discovery 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
...@@ -3739,16 +3739,16 @@ dependencies = [ ...@@ -3739,16 +3739,16 @@ dependencies = [
[[package]] [[package]]
name = "polkadot-statement-table" name = "polkadot-statement-table"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sp-core 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
] ]
[[package]] [[package]]
name = "polkadot-validation" name = "polkadot-validation"
version = "0.7.6" version = "0.7.7"
dependencies = [ dependencies = [
"async-std 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "async-std 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)", "bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
...@@ -3761,12 +3761,12 @@ dependencies = [ ...@@ -3761,12 +3761,12 @@ dependencies = [
"pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "pallet-babe 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)", "parity-scale-codec 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)", "parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.6", "polkadot-availability-store 0.7.7",
"polkadot-erasure-coding 0.7.6", "polkadot-erasure-coding 0.7.7",
"polkadot-parachain 0.7.6", "polkadot-parachain 0.7.7",
"polkadot-primitives 0.7.6", "polkadot-primitives 0.7.7",
"polkadot-runtime 0.7.6", "polkadot-runtime 0.7.7",
"polkadot-statement-table 0.7.6", "polkadot-statement-table 0.7.7",
"sc-block-builder 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-block-builder 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-client-api 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
"sc-finality-grandpa 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)", "sc-finality-grandpa 2.0.0 (git+https://github.com/paritytech/substrate?branch=polkadot-master)",
......
...@@ -4,7 +4,7 @@ path = "src/main.rs" ...@@ -4,7 +4,7 @@ path = "src/main.rs"
[package] [package]
name = "polkadot" name = "polkadot"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
build = "build.rs" build = "build.rs"
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-availability-store" name = "polkadot-availability-store"
description = "Persistent database for parachain data" description = "Persistent database for parachain data"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-cli" name = "polkadot-cli"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Polkadot node implementation in Rust." description = "Polkadot node implementation in Rust."
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-collator" name = "polkadot-collator"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Collator node implementation" description = "Collator node implementation"
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-erasure-coding" name = "polkadot-erasure-coding"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-executor" name = "polkadot-executor"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Polkadot node implementation in Rust." description = "Polkadot node implementation in Rust."
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-network" name = "polkadot-network"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Polkadot-specific networking protocol" description = "Polkadot-specific networking protocol"
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-parachain" name = "polkadot-parachain"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Types and utilities for creating and working with parachains" description = "Types and utilities for creating and working with parachains"
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-primitives" name = "polkadot-primitives"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-rpc" name = "polkadot-rpc"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-runtime" name = "polkadot-runtime"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
build = "build.rs" build = "build.rs"
......
...@@ -97,7 +97,7 @@ pub const VERSION: RuntimeVersion = RuntimeVersion { ...@@ -97,7 +97,7 @@ pub const VERSION: RuntimeVersion = RuntimeVersion {
spec_name: create_runtime_str!("kusama"), spec_name: create_runtime_str!("kusama"),
impl_name: create_runtime_str!("parity-kusama"), impl_name: create_runtime_str!("parity-kusama"),
authoring_version: 2, authoring_version: 2,
spec_version: 1026, spec_version: 1027,
impl_version: 0, impl_version: 0,
apis: RUNTIME_API_VERSIONS, apis: RUNTIME_API_VERSIONS,
}; };
...@@ -130,7 +130,7 @@ impl SignedExtension for OnlyStakingAndClaims { ...@@ -130,7 +130,7 @@ impl SignedExtension for OnlyStakingAndClaims {
-> TransactionValidity -> TransactionValidity
{ {
match call { match call {
Call::Balances(_) | Call::Slots(_) | Call::Registrar(_) Call::Slots(_) | Call::Registrar(_)
=> Err(InvalidTransaction::Custom(ValidityError::NoPermission.into()).into()), => Err(InvalidTransaction::Custom(ValidityError::NoPermission.into()).into()),
_ => Ok(Default::default()), _ => Ok(Default::default()),
} }
......
[package] [package]
name = "polkadot-service" name = "polkadot-service"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-statement-table" name = "polkadot-statement-table"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018" edition = "2018"
......
[package] [package]
name = "adder" name = "adder"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Test parachain which adds to a number as its state transition" description = "Test parachain which adds to a number as its state transition"
edition = "2018" edition = "2018"
......
[package] [package]
name = "halt" name = "halt"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]
description = "Test parachain which executes forever" description = "Test parachain which executes forever"
edition = "2018" edition = "2018"
......
[package] [package]
name = "polkadot-validation" name = "polkadot-validation"
version = "0.7.6" version = "0.7.7"
authors = ["Parity Technologies <admin@parity.io>"] authors = ["Parity Technologies <admin@parity.io>"]