Unverified Commit 075d0eda authored by Gav Wood's avatar Gav Wood
Browse files

Version bump

parent 0fcb776a
......@@ -11,11 +11,11 @@ dependencies = [
[[package]]
name = "adder"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"dlmalloc 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.28-pre1",
"polkadot-parachain 0.7.28",
"sp-io 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"substrate-wasm-builder-runner 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"tiny-keccak 1.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -25,13 +25,13 @@ dependencies = [
name = "adder-collator"
version = "0.1.0"
dependencies = [
"adder 0.7.28-pre1",
"adder 0.7.28",
"futures 0.3.4 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.10.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-collator 0.7.28-pre1",
"polkadot-parachain 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-collator 0.7.28",
"polkadot-parachain 0.7.28",
"polkadot-primitives 0.7.28",
"sc-client 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-client-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sp-core 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -1598,7 +1598,7 @@ dependencies = [
[[package]]
name = "halt"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"substrate-wasm-builder-runner 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
]
......@@ -2060,7 +2060,7 @@ dependencies = [
[[package]]
name = "kusama-runtime"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-benchmarking 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -2099,9 +2099,9 @@ dependencies = [
"pallet-utility 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"pallet-vesting 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-runtime-common 0.7.28-pre1",
"polkadot-parachain 0.7.28",
"polkadot-primitives 0.7.28",
"polkadot-runtime-common 0.7.28",
"rustc-hex 2.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.104 (registry+https://github.com/rust-lang/crates.io-index)",
"serde_derive 1.0.104 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3697,20 +3697,20 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "polkadot"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"assert_cmd 0.12.0 (registry+https://github.com/rust-lang/crates.io-index)",
"futures 0.3.4 (registry+https://github.com/rust-lang/crates.io-index)",
"nix 0.17.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-util-mem 0.6.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.28-pre1",
"polkadot-service 0.7.28-pre1",
"polkadot-cli 0.7.28",
"polkadot-service 0.7.28",
"vergen 3.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "polkadot-availability-store"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"exit-future 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3721,8 +3721,8 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-erasure-coding 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-erasure-coding 0.7.28",
"polkadot-primitives 0.7.28",
"sc-client 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-client-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-keystore 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -3737,12 +3737,12 @@ dependencies = [
[[package]]
name = "polkadot-cli"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"frame-benchmarking-cli 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"futures 0.3.4 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-service 0.7.28-pre1",
"polkadot-service 0.7.28",
"sc-cli 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-client 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-client-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -3760,17 +3760,17 @@ dependencies = [
[[package]]
name = "polkadot-collator"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"futures 0.3.4 (registry+https://github.com/rust-lang/crates.io-index)",
"futures-timer 2.0.2 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-cli 0.7.28-pre1",
"polkadot-network 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-service 0.7.28-pre1",
"polkadot-validation 0.7.28-pre1",
"polkadot-cli 0.7.28",
"polkadot-network 0.7.28",
"polkadot-primitives 0.7.28",
"polkadot-service 0.7.28",
"polkadot-validation 0.7.28",
"sc-cli 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-client 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-client-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -3786,11 +3786,11 @@ dependencies = [
[[package]]
name = "polkadot-erasure-coding"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"derive_more 0.15.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.28-pre1",
"polkadot-primitives 0.7.28",
"reed-solomon-erasure 4.0.0 (git+https://github.com/paritytech/reed-solomon-erasure)",
"sp-core 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sp-trie 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -3798,7 +3798,7 @@ dependencies = [
[[package]]
name = "polkadot-network"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"arrayvec 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
"bytes 0.5.4 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3809,10 +3809,10 @@ dependencies = [
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.28-pre1",
"polkadot-erasure-coding 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-validation 0.7.28-pre1",
"polkadot-availability-store 0.7.28",
"polkadot-erasure-coding 0.7.28",
"polkadot-primitives 0.7.28",
"polkadot-validation 0.7.28",
"sc-client 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-network 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-network-gossip 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -3849,11 +3849,11 @@ dependencies = [
[[package]]
name = "polkadot-parachain"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"adder 0.7.28-pre1",
"adder 0.7.28",
"derive_more 0.99.2 (registry+https://github.com/rust-lang/crates.io-index)",
"halt 0.7.28-pre1",
"halt 0.7.28",
"lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3872,12 +3872,12 @@ dependencies = [
[[package]]
name = "polkadot-primitives"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-babe 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.28-pre1",
"polkadot-parachain 0.7.28",
"pretty_assertions 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.104 (registry+https://github.com/rust-lang/crates.io-index)",
"sp-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -3893,12 +3893,12 @@ dependencies = [
[[package]]
name = "polkadot-rpc"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"jsonrpc-core 14.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-transaction-payment-rpc 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.28-pre1",
"polkadot-primitives 0.7.28",
"sc-client 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-rpc 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sp-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -3909,7 +3909,7 @@ dependencies = [
[[package]]
name = "polkadot-runtime"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-benchmarking 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -3946,9 +3946,9 @@ dependencies = [
"pallet-treasury 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"pallet-vesting 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-runtime-common 0.7.28-pre1",
"polkadot-parachain 0.7.28",
"polkadot-primitives 0.7.28",
"polkadot-runtime-common 0.7.28",
"rustc-hex 2.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.104 (registry+https://github.com/rust-lang/crates.io-index)",
"serde_derive 1.0.104 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -3975,7 +3975,7 @@ dependencies = [
[[package]]
name = "polkadot-runtime-common"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-benchmarking 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -3996,8 +3996,8 @@ dependencies = [
"pallet-treasury 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"pallet-vesting 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-parachain 0.7.28",
"polkadot-primitives 0.7.28",
"rustc-hex 2.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.104 (registry+https://github.com/rust-lang/crates.io-index)",
"serde_derive 1.0.104 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4016,13 +4016,13 @@ dependencies = [
[[package]]
name = "polkadot-service"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"frame-benchmarking 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"frame-system-rpc-runtime-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"futures 0.3.4 (registry+https://github.com/rust-lang/crates.io-index)",
"hex-literal 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
"kusama-runtime 0.7.28-pre1",
"kusama-runtime 0.7.28",
"lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.8 (registry+https://github.com/rust-lang/crates.io-index)",
"pallet-babe 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -4031,13 +4031,13 @@ dependencies = [
"pallet-transaction-payment-rpc-runtime-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.28-pre1",
"polkadot-network 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-rpc 0.7.28-pre1",
"polkadot-runtime 0.7.28-pre1",
"polkadot-availability-store 0.7.28",
"polkadot-network 0.7.28",
"polkadot-primitives 0.7.28",
"polkadot-rpc 0.7.28",
"polkadot-runtime 0.7.28",
"polkadot-test-runtime-client 2.0.0",
"polkadot-validation 0.7.28-pre1",
"polkadot-validation 0.7.28",
"sc-authority-discovery 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-block-builder 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-chain-spec 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -4073,16 +4073,16 @@ dependencies = [
[[package]]
name = "polkadot-statement-table"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-primitives 0.7.28-pre1",
"polkadot-primitives 0.7.28",
"sp-core 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
]
[[package]]
name = "polkadot-test-runtime"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"frame-executive 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -4109,9 +4109,9 @@ dependencies = [
"pallet-transaction-payment-rpc-runtime-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"pallet-vesting 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-parachain 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-runtime-common 0.7.28-pre1",
"polkadot-parachain 0.7.28",
"polkadot-primitives 0.7.28",
"polkadot-runtime-common 0.7.28",
"rustc-hex 2.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"serde 1.0.104 (registry+https://github.com/rust-lang/crates.io-index)",
"serde_derive 1.0.104 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4141,7 +4141,7 @@ version = "2.0.0"
dependencies = [
"futures 0.3.4 (registry+https://github.com/rust-lang/crates.io-index)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-test-runtime 0.7.28-pre1",
"polkadot-test-runtime 0.7.28",
"sc-block-builder 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-client 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-client-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......@@ -4155,7 +4155,7 @@ dependencies = [
[[package]]
name = "polkadot-validation"
version = "0.7.28-pre1"
version = "0.7.28"
dependencies = [
"bitvec 0.15.2 (registry+https://github.com/rust-lang/crates.io-index)",
"derive_more 0.14.1 (registry+https://github.com/rust-lang/crates.io-index)",
......@@ -4166,11 +4166,11 @@ dependencies = [
"pallet-babe 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"parity-scale-codec 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"parking_lot 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
"polkadot-availability-store 0.7.28-pre1",
"polkadot-erasure-coding 0.7.28-pre1",
"polkadot-parachain 0.7.28-pre1",
"polkadot-primitives 0.7.28-pre1",
"polkadot-statement-table 0.7.28-pre1",
"polkadot-availability-store 0.7.28",
"polkadot-erasure-coding 0.7.28",
"polkadot-parachain 0.7.28",
"polkadot-primitives 0.7.28",
"polkadot-statement-table 0.7.28",
"sc-block-builder 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-client-api 2.0.0-alpha.4 (git+https://github.com/paritytech/substrate)",
"sc-finality-grandpa 0.8.0-alpha.4 (git+https://github.com/paritytech/substrate)",
......
......@@ -4,7 +4,7 @@ path = "src/main.rs"
[package]
name = "polkadot"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
build = "build.rs"
edition = "2018"
......
[package]
name = "polkadot-availability-store"
description = "Persistent database for parachain data"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-cli"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Polkadot node implementation in Rust."
edition = "2018"
......
[package]
name = "polkadot-collator"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Collator node implementation"
edition = "2018"
......
[package]
name = "polkadot-erasure-coding"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-network"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Polkadot-specific networking protocol"
edition = "2018"
......
[package]
name = "polkadot-parachain"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Types and utilities for creating and working with parachains"
edition = "2018"
......
[package]
name = "polkadot-primitives"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-rpc"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-runtime-common"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "kusama-runtime"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
build = "build.rs"
......
[package]
name = "polkadot-runtime"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
build = "build.rs"
......
[package]
name = "polkadot-test-runtime"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
build = "build.rs"
......
[package]
name = "polkadot-service"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "polkadot-statement-table"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
[package]
name = "adder"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Test parachain which adds to a number as its state transition"
edition = "2018"
......
[package]
name = "halt"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
description = "Test parachain which executes forever"
edition = "2018"
......
[package]
name = "polkadot-validation"
version = "0.7.28-pre1"
version = "0.7.28"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment