Cargo.toml 1.31 KB
Newer Older
1
[package]
2
name = "polkadot-node-subsystem"
3
4
5
version = "0.1.0"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
6
description = "Subsystem traits and message definitions"
7
8

[dependencies]
9
async-std = "1.8.0"
10
async-trait = "0.1.42"
11
derive_more = "0.99.11"
12
futures = "0.3.8"
13
futures-timer = "3.0.2"
14
mick-jaeger = "0.1.2"
15
lazy_static = "1.4"
16
tracing = "0.1.22"
17
tracing-futures = "0.2.4"
18
parity-scale-codec = { version = "1.3.5", default-features = false, features = ["derive"] }
19
parking_lot = "0.11.1"
20
pin-project = "1.0.3"
21
polkadot-node-primitives = { path = "../primitives" }
22
polkadot-node-network-protocol = { path = "../network/protocol" }
23
polkadot-primitives = { path = "../../primitives" }
24
polkadot-statement-table = { path = "../../statement-table" }
25
polkadot-node-jaeger = { path = "../jaeger" }
26
sc-network = { git = "https://github.com/paritytech/substrate", branch = "master" }
27
smallvec = "1.6.1"
28
sp-core = { git = "https://github.com/paritytech/substrate", branch = "master" }
29
substrate-prometheus-endpoint = { git = "https://github.com/paritytech/substrate", branch = "master" }
30
thiserror = "1.0.23"
31
log = "0.4.11"
32
33

[dev-dependencies]
34
assert_matches = "1.4.0"
35
async-trait = "0.1.42"
36
futures = { version = "0.3.8", features = ["thread-pool"] }
37
polkadot-node-subsystem-test-helpers = { path = "../subsystem-test-helpers" }