Cargo.toml 882 Bytes
Newer Older
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
[package]
name = "bp-kusama"
description = "Primitives of Kusama runtime."
version = "0.1.0"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
license = "GPL-3.0-or-later WITH Classpath-exception-2.0"

[dependencies]

# Bridge Dependencies
bp-messages = { path = "../messages", default-features = false }
bp-polkadot-core = { path = "../polkadot-core", default-features = false }
bp-runtime = { path = "../runtime", default-features = false }

# Substrate Based Dependencies
David's avatar
David committed
17
18
sp-api = { git = "https://github.com/paritytech/substrate", default-features = false , branch = "dp-update-jsonrpsee-client" }
sp-std = { git = "https://github.com/paritytech/substrate", default-features = false , branch = "dp-update-jsonrpsee-client" }
19
20
21
22
23
24
25
26
27
28

[features]
default = ["std"]
std = [
	"bp-messages/std",
	"bp-polkadot-core/std",
	"bp-runtime/std",
	"sp-api/std",
	"sp-std/std",
]