Commit 91c662bd authored by YJ's avatar YJ
Browse files

fix: upgrade gradle and react native camera, add missing dimension strategy

parent 0294ee69
...@@ -158,7 +158,7 @@ android { ...@@ -158,7 +158,7 @@ android {
dependencies { dependencies {
implementation fileTree(dir: "libs", include: ["*.jar"]) implementation fileTree(dir: "libs", include: ["*.jar"])
implementation "com.android.support:appcompat-v7:${rootProject.ext.supportLibVersion}" implementation "com.android.support:appcompat-v7:${rootProject.ext.supportLibVersion}"
implementation "com.facebook.react:react-native:0.60.0" // From node_modules implementation "com.facebook.react:react-native:0.60.3"
} }
// Run this once to be able to run the application with BUCK // Run this once to be able to run the application with BUCK
......
...@@ -13,7 +13,7 @@ ...@@ -13,7 +13,7 @@
android:name=".MainApplication" android:name=".MainApplication"
android:label="@string/app_name" android:label="@string/app_name"
android:icon="@mipmap/ic_launcher" android:icon="@mipmap/ic_launcher"
android:roundIcon="@mipmap/ic_launcher_round" android:roundIcon="@mipmap/ic_launcher"
android:allowBackup="true" android:allowBackup="true"
android:testOnly="false" android:testOnly="false"
android:theme="@style/AppTheme"> android:theme="@style/AppTheme">
......
...@@ -14,8 +14,7 @@ buildscript { ...@@ -14,8 +14,7 @@ buildscript {
jcenter() jcenter()
} }
dependencies { dependencies {
classpath("com.android.tools.build:gradle:3.4.0") classpath('com.android.tools.build:gradle:3.4.2')
// NOTE: Do not place your application dependencies here; they belong // NOTE: Do not place your application dependencies here; they belong
// in the individual module build.gradle files // in the individual module build.gradle files
} }
...@@ -39,7 +38,7 @@ subprojects { ...@@ -39,7 +38,7 @@ subprojects {
resolutionStrategy.eachDependency { details -> resolutionStrategy.eachDependency { details ->
if (details.requested.group == 'com.android.support' if (details.requested.group == 'com.android.support'
&& !details.requested.name.contains('multidex') ) { && !details.requested.name.contains('multidex') ) {
details.useVersion "26.1.0" details.useVersion "28.0.0"
} }
} }
} }
......
#Fri Jul 12 11:07:18 CEST 2019
distributionBase=GRADLE_USER_HOME distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists distributionPath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-5.4.1-all.zip distributionUrl=https\://services.gradle.org/distributions/gradle-5.5.1-all.zip
zipStoreBase=GRADLE_USER_HOME zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists zipStorePath=wrapper/dists
\ No newline at end of file
This diff is collapsed.
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment