Unverified Commit 6db2ee15 authored by Niklas Adolfsson's avatar Niklas Adolfsson Committed by GitHub
Browse files

deps(hyper): require 0.14.10 (#427)

To make sure that we are not affected by:
	- https://github.com/hyperium/hyper/security/advisories/GHSA-f3pg-qwvg-p99c
	- https://github.com/hyperium/hyper/security/advisories/GHSA-5h46-h7hh-c6x9

However, `hyper 13` is not fixed but I think we should remove that support anyway?!
parent 430dcfaf
......@@ -14,7 +14,7 @@ async-trait = "0.1"
futures = { version = "0.3.14", default-features = false, features = ["std"] }
hyper13-rustls = { package = "hyper-rustls", version = "0.21", optional = true }
hyper14-rustls = { package = "hyper-rustls", version = "0.22", optional = true }
hyper14 = { package = "hyper", version = "0.14", features = ["client", "http1", "http2", "tcp"], optional = true }
hyper14 = { package = "hyper", version = "0.14.10", features = ["client", "http1", "http2", "tcp"], optional = true }
hyper13 = { package = "hyper", version = "0.13", optional = true }
jsonrpsee-types = { path = "../types", version = "0.3.0" }
jsonrpsee-utils = { path = "../utils", version = "0.3.0", optional = true }
......
......@@ -11,7 +11,7 @@ documentation = "https://docs.rs/jsonrpsee-http-server"
[dependencies]
thiserror = "1"
hyper = { version = "0.14", features = ["server", "http1", "http2", "tcp"] }
hyper = { version = "0.14.10", features = ["server", "http1", "http2", "tcp"] }
futures-channel = "0.3.14"
futures-util = { version = "0.3.14", default-features = false }
jsonrpsee-types = { path = "../types", version = "0.3.0" }
......
......@@ -11,7 +11,7 @@ edition = "2018"
anyhow = "1"
futures-channel = "0.3.14"
futures-util = "0.3.14"
hyper = { version = "0.14", features = ["full"] }
hyper = { version = "0.14.10", features = ["full"] }
log = "0.4"
serde = { version = "1", default-features = false, features = ["derive"] }
serde_json = "1"
......
......@@ -19,4 +19,4 @@ serde = { version = "1", default-features = false, features = ["derive"] }
serde_json = { version = "1", default-features = false, features = ["alloc", "raw_value", "std"] }
thiserror = "1.0"
soketto = "0.6"
hyper = "0.14"
hyper = "0.14.10"
......@@ -12,7 +12,7 @@ thiserror = { version = "1", optional = true }
futures-channel = { version = "0.3.14", default-features = false, optional = true }
futures-util = { version = "0.3.14", default-features = false, optional = true }
hyper13 = { package = "hyper", version = "0.13", default-features = false, features = ["stream"], optional = true }
hyper14 = { package = "hyper", version = "0.14", default-features = false, features = ["stream"], optional = true }
hyper14 = { package = "hyper", version = "0.14.10", default-features = false, features = ["stream"], optional = true }
jsonrpsee-types = { path = "../types", version = "0.3.0", optional = true }
log = { version = "0.4", optional = true }
rustc-hash = { version = "1", optional = true }
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment