Unverified Commit af1ab521 authored by Andrew Jones's avatar Andrew Jones Committed by GitHub
Browse files

[abi] update to scale-info v0.2 (#454)

* Update to latest scale-info

* scale-info 0.2

* Merge branch 'master' into aj-update-scale-info

# Conflicts:
#	primitives/src/key.rs

* Fmt
parent d095dd07
Pipeline #97182 failed with stages
in 11 minutes and 17 seconds
......@@ -11,7 +11,7 @@ ink_core = { version = "2.1.0", path = "../../../core", default-features = false
ink_lang = { version = "2.1.0", path = "../../../lang", default-features = false }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "accumulator"
......
......@@ -13,7 +13,7 @@ ink_lang = { version = "2.1.0", path = "../../../lang", default-features = false
accumulator = { version = "2.1.0", path = "../accumulator", default-features = false, features = ["ink-as-dependency"] }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "adder"
......
......@@ -49,7 +49,7 @@ mod delegator {
)]
#[cfg_attr(
feature = "std",
derive(::scale_info::Metadata, ::ink_core::storage2::traits::StorageLayout)
derive(::scale_info::TypeInfo, ::ink_core::storage2::traits::StorageLayout)
)]
pub enum Which {
Adder,
......
......@@ -13,7 +13,7 @@ ink_lang = { version = "2.1.0", path = "../../../lang", default-features = false
accumulator = { version = "2.1.0", path = "../accumulator", default-features = false, features = ["ink-as-dependency"] }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "subber"
......
......@@ -11,7 +11,7 @@ ink_core = { version = "2.1.0", path = "../../core", default-features = false }
ink_lang = { version = "2.1.0", path = "../../lang", default-features = false }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "dns"
......
......@@ -86,7 +86,7 @@ mod dns {
/// Errors that can occur upon calling this contract.
#[derive(Debug, PartialEq, Eq, scale::Encode, scale::Decode)]
#[cfg_attr(feature = "std", derive(::scale_info::Metadata))]
#[cfg_attr(feature = "std", derive(::scale_info::TypeInfo))]
pub enum Error {
/// Returned if the name already exists upon registration.
NameAlreadyExists,
......
......@@ -11,7 +11,7 @@ ink_core = { version = "2.1.0", path = "../../core", default-features = false }
ink_lang = { version = "2.1.0", path = "../../lang", default-features = false }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "erc20"
......
......@@ -11,7 +11,7 @@ ink_core = { version = "2.1.0", path = "../../core", default-features = false }
ink_lang = { version = "2.1.0", path = "../../lang", default-features = false }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "erc721"
......
......@@ -93,7 +93,7 @@ mod erc721 {
}
#[derive(Encode, Decode, Debug, PartialEq, Eq, Copy, Clone)]
#[cfg_attr(feature = "std", derive(scale_info::Metadata))]
#[cfg_attr(feature = "std", derive(scale_info::TypeInfo))]
pub enum Error {
NotOwner,
NotApproved,
......
......@@ -11,7 +11,7 @@ ink_core = { version = "2.1.0", path = "../../core", default-features = false }
ink_lang = { version = "2.1.0", path = "../../lang", default-features = false }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "flipper"
......
......@@ -11,7 +11,7 @@ ink_core = { version = "2.1.0", path = "../../core", default-features = false }
ink_lang = { version = "2.1.0", path = "../../lang", default-features = false }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "incrementer"
......
......@@ -12,7 +12,7 @@ ink_lang = { version = "2.1.0", path = "../../lang", default-features = false }
ink_prelude = { version = "2.1.0", path = "../../prelude", default-features = false }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "multisig_plain"
......
......@@ -121,7 +121,7 @@ mod multisig_plain {
#[derive(scale::Encode, scale::Decode, Clone, Copy, SpreadLayout, PackedLayout)]
#[cfg_attr(
feature = "std",
derive(scale_info::Metadata, ink_core::storage2::traits::StorageLayout)
derive(scale_info::TypeInfo, ink_core::storage2::traits::StorageLayout)
)]
pub enum ConfirmationStatus {
/// The transaction is already confirmed.
......@@ -139,7 +139,7 @@ mod multisig_plain {
Debug,
PartialEq,
Eq,
scale_info::Metadata,
scale_info::TypeInfo,
ink_core::storage2::traits::StorageLayout
)
)]
......
......@@ -12,7 +12,7 @@ ink_core = { version = "2.1.0", path = "../../core", default-features = false }
ink_lang = { version = "2.1.0", path = "../../lang", default-features = false }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[lib]
name = "runtime_storage"
......
......@@ -37,7 +37,7 @@ ink_lang = { version = "2.1.0", path = ".." }
trybuild = "1.0.24"
pretty_assertions = "0.6.1"
scale-info = { version = "0.1", default-features = false, features = ["derive"] }
scale-info = { version = "0.2", default-features = false, features = ["derive"] }
[lib]
name = "ink_lang_macro"
......
......@@ -148,7 +148,7 @@ impl CrossCalling<'_> {
#[cfg_attr(
feature = "std",
derive(
::scale_info::Metadata,
::scale_info::TypeInfo,
::ink_core::storage2::traits::StorageLayout,
)
)]
......
......@@ -8,7 +8,7 @@ mod erc721 {
pub type TokenId = u32;
#[derive(scale::Encode, scale::Decode)]
#[cfg_attr(feature = "std", derive(scale_info::Metadata))]
#[cfg_attr(feature = "std", derive(scale_info::TypeInfo))]
pub enum Error {
SpecifiedTokenHasNoOwner,
ApprovalToCurrentOwner,
......
......@@ -21,7 +21,7 @@ include = ["/Cargo.toml", "src/**/*.rs", "/README.md", "/LICENSE"]
ink_prelude = { version = "2.1.0", path = "../prelude/", default-features = false }
tiny-keccak = { version = "2.0", features = ["keccak"] }
scale = { package = "parity-scale-codec", version = "1.3", default-features = false, features = ["derive", "full"] }
scale-info = { version = "0.1", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "0.2", default-features = false, features = ["derive"], optional = true }
[dev-dependencies]
criterion = "0.3.1"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment