Unverified Commit e6aff715 authored by Michael Müller's avatar Michael Müller Committed by GitHub
Browse files

Release `cargo-contract` v0.18.0 and `contract-metadata` v0.6.0 (#461)



* Bump versions

* Update release notes

* Update CHANGELOG.md
Co-authored-by: Andrew Jones's avatarAndrew Jones <ascjones@gmail.com>
Co-authored-by: Andrew Jones's avatarAndrew Jones <ascjones@gmail.com>
parent 63b870de
Pipeline #183943 canceled with stages
......@@ -6,6 +6,16 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
## [Unreleased]
## [0.18.0] - 2022-03-14
### Interact with contracts: upload, instantiate and call commands
We added commands to upload, instantiate and call contracts!
This allows interacting with contracts on live chains with a compatible
[`pallet-contracts`](https://github.com/paritytech/substrate/tree/master/frame/contracts).
For command-line examples on how to use these commands see [#79](https://github.com/paritytech/cargo-contract/pull/79).
### Linting rules for smart contracts
We are introducing a linter for ink! smart contracts in this release!
......@@ -20,10 +30,12 @@ In order for the linting to work with your smart contract, the contract has to b
written in at least ink! 3.0.0-rc9. If it's older the linting will just always succeed.
### Added
- Interact with contracts: upload, instantiate and call commands - [#79](https://github.com/paritytech/cargo-contract/pull/79)
- Add linting to assert correct initialization of [`ink_storage::Mapping`](https://paritytech.github.io/ink/ink_storage/struct.Mapping.html) - [#431](https://github.com/paritytech/cargo-contract/pull/431)
### Changed
- Upgrade `subxt`, SCALE crates, and substrate primitive `sp-*` crates [#451](https://github.com/paritytech/cargo-contract/pull/451).
- Updated `cargo contract new` template dependencies to ink! `3.0.0-rc9` - [#443](https://github.com/paritytech/cargo-contract/pull/443)
## [0.17.0] - 2022-01-19
......
......@@ -474,7 +474,7 @@ dependencies = [
[[package]]
name = "cargo-contract"
version = "0.17.0"
version = "0.18.0"
dependencies = [
"anyhow",
"assert_cmd",
......@@ -657,7 +657,7 @@ checksum = "245097e9a4535ee1e3e3931fcfcd55a796a44c643e8596ff6566d68f09b87bbc"
[[package]]
name = "contract-metadata"
version = "0.5.1"
version = "0.6.0"
dependencies = [
"impl-serde",
"pretty_assertions",
......
......@@ -3,7 +3,7 @@ members = [".", "metadata"]
[package]
name = "cargo-contract"
version = "0.17.0"
version = "0.18.0"
authors = ["Parity Technologies <admin@parity.io>"]
build = "build.rs"
edition = "2021"
......@@ -38,7 +38,7 @@ colored = "2.0.0"
toml = "0.5.8"
rustc_version = "0.4.0"
blake2 = "0.10.4"
contract-metadata = { version = "0.5.0", path = "./metadata" }
contract-metadata = { version = "0.6.0", path = "./metadata" }
semver = { version = "1.0.6", features = ["serde"] }
serde = { version = "1.0.136", default-features = false, features = ["derive"] }
serde_json = "1.0.79"
......
[package]
name = "contract-metadata"
version = "0.5.1"
version = "0.6.0"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2021"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment