Unverified Commit 934dafc1 authored by dependabot[bot]'s avatar dependabot[bot] Committed by GitHub
Browse files

Bump parity-wasm from 0.42.2 to 0.45.0 (#590)

* Bump parity-wasm from 0.42.2 to 0.45.0

Bumps [parity-wasm](https://github.com/paritytech/parity-wasm) from 0.42.2 to 0.45.0.
- [Release notes](https://github.com/paritytech/parity-wasm/releases)
- [Commits](https://github.com/paritytech/parity-wasm/compare/v0.42.2...v0.45.0

)

---
updated-dependencies:
- dependency-name: parity-wasm
  dependency-type: direct:production
  update-type: version-update:semver-minor
...
Signed-off-by: default avatardependabot[bot] <support@github.com>

* Fix error
Co-authored-by: default avatardependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: Andrew Jones's avatarascjones <ascjones@gmail.com>
parent d3fc06cd
Pipeline #196395 canceled with stages
in 5 minutes and 8 seconds
...@@ -495,7 +495,7 @@ dependencies = [ ...@@ -495,7 +495,7 @@ dependencies = [
"nom-supreme", "nom-supreme",
"pallet-contracts-primitives", "pallet-contracts-primitives",
"parity-scale-codec", "parity-scale-codec",
"parity-wasm", "parity-wasm 0.45.0",
"predicates", "predicates",
"pretty_assertions", "pretty_assertions",
"regex", "regex",
...@@ -2196,6 +2196,12 @@ version = "0.42.2" ...@@ -2196,6 +2196,12 @@ version = "0.42.2"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "be5e13c266502aadf83426d87d81a0f5d1ef45b8027f5a471c360abfe4bfae92" checksum = "be5e13c266502aadf83426d87d81a0f5d1ef45b8027f5a471c360abfe4bfae92"
[[package]]
name = "parity-wasm"
version = "0.45.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "e1ad0aff30c1da14b1254fcb2af73e1fa9a28670e584a626f53a369d0e157304"
[[package]] [[package]]
name = "parking" name = "parking"
version = "2.0.0" version = "2.0.0"
...@@ -3966,7 +3972,7 @@ dependencies = [ ...@@ -3966,7 +3972,7 @@ dependencies = [
"memory_units", "memory_units",
"num-rational", "num-rational",
"num-traits", "num-traits",
"parity-wasm", "parity-wasm 0.42.2",
"wasmi-validation", "wasmi-validation",
] ]
...@@ -3976,7 +3982,7 @@ version = "0.4.1" ...@@ -3976,7 +3982,7 @@ version = "0.4.1"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "165343ecd6c018fc09ebcae280752702c9a2ef3e6f8d02f1cfcbdb53ef6d7937" checksum = "165343ecd6c018fc09ebcae280752702c9a2ef3e6f8d02f1cfcbdb53ef6d7937"
dependencies = [ dependencies = [
"parity-wasm", "parity-wasm 0.42.2",
] ]
[[package]] [[package]]
......
...@@ -30,7 +30,7 @@ clap = { version = "3.1.18", features = ["derive", "env"] } ...@@ -30,7 +30,7 @@ clap = { version = "3.1.18", features = ["derive", "env"] }
log = "0.4.17" log = "0.4.17"
heck = "0.4.0" heck = "0.4.0"
zip = { version = "0.6.2", default-features = false } zip = { version = "0.6.2", default-features = false }
parity-wasm = "0.42.2" parity-wasm = "0.45.0"
cargo_metadata = "0.14.2" cargo_metadata = "0.14.2"
scale = { package = "parity-scale-codec", version = "3.0.0", features = ["derive"] } scale = { package = "parity-scale-codec", version = "3.0.0", features = ["derive"] }
which = "4.2.5" which = "4.2.5"
......
...@@ -528,7 +528,7 @@ fn post_process_wasm(crate_metadata: &CrateMetadata) -> Result<()> { ...@@ -528,7 +528,7 @@ fn post_process_wasm(crate_metadata: &CrateMetadata) -> Result<()> {
validate_wasm::validate_import_section(&module)?; validate_wasm::validate_import_section(&module)?;
debug_assert!( debug_assert!(
!module.clone().to_bytes().unwrap().is_empty(), !module.clone().into_bytes().unwrap().is_empty(),
"resulting wasm size of post processing must be > 0" "resulting wasm size of post processing must be > 0"
); );
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment