Unverified Commit 6fc0277f authored by Michael Müller's avatar Michael Müller Committed by GitHub
Browse files

Release `cargo-contract` and `contract-metadata` 1.0 (#466)

* Change dependencies to ink! 3.0

* Bump `cargo-contract` and `contract-metadata` to `1.0`

* Update changelog

* Update `Cargo.lock`

* Hotfix to make publishing work
parent 9362c045
Pipeline #184193 passed with stages
in 10 minutes and 5 seconds
......@@ -6,6 +6,11 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
## [Unreleased]
## [1.0.0] - 2022-03-17
### Changed
- Updated `cargo contract new` template dependencies to ink! `3.0` - [#466](https://github.com/paritytech/cargo-contract/pull/466)
## [0.18.0] - 2022-03-14
### Interact with contracts: upload, instantiate and call commands
......
This diff is collapsed.
......@@ -3,7 +3,7 @@ members = [".", "metadata"]
[package]
name = "cargo-contract"
version = "0.18.0"
version = "1.0.0"
authors = ["Parity Technologies <admin@parity.io>"]
build = "build.rs"
edition = "2021"
......@@ -49,8 +49,8 @@ regex = "1.5.5"
# dependencies for extrinsics (deploying and calling a contract)
async-std = { version = "1.10.0", features = ["attributes", "tokio1"] }
ink_metadata = { version = "3.0.0-rc9", features = ["derive"] }
ink_env = "3.0.0-rc9"
ink_metadata = { version = "3.0", features = ["derive"] }
ink_env = "3.0"
scale-info = { version = "2.0.1", default-features = false, features = ["derive"] }
sp-core = "6.0.0"
sp-runtime = "6.0.0"
......@@ -82,10 +82,10 @@ wabt = "0.10.0"
regex = "1.5.5"
predicates = "2.1.1"
ink_primitives = "3.0.0-rc9"
ink_storage = "3.0.0-rc9"
ink_lang = "3.0.0-rc9"
ink_lang_codegen = "3.0.0-rc9"
ink_primitives = "3.0"
ink_storage = "3.0"
ink_lang = "3.0"
ink_lang_codegen = "3.0"
[features]
# This `std` feature is required for testing using an inline contract's metadata, because `ink!` annotates the metadata
......
......@@ -5,11 +5,11 @@ authors = ["[your_name] <[your_email]>"]
edition = "2021"
[dependencies]
ink_primitives = { version = "3.0.0-rc9", default-features = false }
ink_metadata = { version = "3.0.0-rc9", default-features = false, features = ["derive"], optional = true }
ink_env = { version = "3.0.0-rc9", default-features = false }
ink_storage = { version = "3.0.0-rc9", default-features = false }
ink_lang = { version = "3.0.0-rc9", default-features = false }
ink_primitives = { version = "3.0", default-features = false }
ink_metadata = { version = "3.0", default-features = false, features = ["derive"], optional = true }
ink_env = { version = "3.0", default-features = false }
ink_storage = { version = "3.0", default-features = false }
ink_lang = { version = "3.0", default-features = false }
scale = { package = "parity-scale-codec", version = "3", default-features = false, features = ["derive"] }
scale-info = { version = "2", default-features = false, features = ["derive"], optional = true }
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment