Cargo.toml 3.25 KB
Newer Older
1
2
3
[workspace]
members = [".", "metadata"]

4
[package]
5
name = "cargo-contract"
Andrew Jones's avatar
Andrew Jones committed
6
version = "1.3.0"
7
authors = ["Parity Technologies <admin@parity.io>"]
8
build = "build.rs"
Dan Shields's avatar
Dan Shields committed
9
edition = "2021"
10
11
12

license = "GPL-3.0"
readme = "README.md"
13
repository = "https://github.com/paritytech/cargo-contract"
14
documentation = "https://docs.substrate.io/tutorials/v3/ink-workshop/pt1/"
Hero Bird's avatar
Hero Bird committed
15
homepage = "https://www.parity.io/"
16
description = "Setup and deployment tool for developing Wasm based smart contracts via ink!"
17
keywords = ["wasm", "parity", "webassembly", "blockchain", "edsl"]
Andrew Jones's avatar
Andrew Jones committed
18
categories = ["command-line-utilities", "development-tools::build-utils", "development-tools::cargo-plugins"]
19
20
21
22
23
24
include = [
    "Cargo.toml", "src/**/*.rs", "README.md", "LICENSE", "build.rs", "templates", "src/**/*.scale",
    # We need to include `ink_linting` in the releases, so that the dylint driver which
    # is contained in that crate is build locally as part of the installation.
    "ink_linting", "!ink_linting/target/", "!ink_linting/ui/"
]
25
26

[dependencies]
27
env_logger = "0.9.0"
28
anyhow = "1.0.57"
29
clap = { version = "3.1.18", features = ["derive", "env"] }
30
log = "0.4.17"
31
heck = "0.4.0"
dependabot[bot]'s avatar
dependabot[bot] committed
32
zip = { version = "0.6.2", default-features = false }
33
parity-wasm = "0.42.2"
34
cargo_metadata = "0.14.2"
35
scale = { package = "parity-scale-codec", version = "3.0.0", features = ["derive"] }
36
which = "4.2.5"
37
colored = "2.0.0"
38
toml = "0.5.9"
39
rustc_version = "0.4.0"
40
blake2 = "0.10.4"
41
contract-metadata = { version = "0.6.0", path = "./metadata" }
42
semver = { version = "1.0.9", features = ["serde"] }
43
serde = { version = "1.0.137", default-features = false, features = ["derive"] }
44
serde_json = "1.0.81"
45
tempfile = "3.3.0"
46
url = { version = "2.2.2", features = ["serde"] }
47
impl-serde = "0.3.2"
48
regex = "1.5.5"
Qinxuan Chen's avatar
Qinxuan Chen committed
49

50
# dependencies for extrinsics (deploying and calling a contract)
51
async-std = { version = "1.11.0", features = ["attributes", "tokio1"] }
52
53
ink_metadata = { version = "3", features = ["derive"] }
ink_env = "3"
54
scale-info = { version = "2.1.2", default-features = false, features = ["derive"] }
55
56
57
sp-core = "6.0.0"
sp-runtime = "6.0.0"
pallet-contracts-primitives = "6.0.0"
58
subxt = "0.21.0"
59
60
futures = "0.3.19"
hex = "0.4.3"
61
jsonrpsee = { version = "0.13.1", features = ["ws-client"] }
dependabot[bot]'s avatar
dependabot[bot] committed
62
nom = "7.1.1"
63
nom-supreme = { version = "0.7.0", features = ["error"] }
64
indexmap = "1.8.1"
65
thiserror = "1.0.31"
66
67
escape8259 = "0.5.1"
itertools = "0.10.3"
68

69
[build-dependencies]
70
anyhow = "1.0.57"
dependabot[bot]'s avatar
dependabot[bot] committed
71
zip = { version = "0.6.2", default-features = false }
72
walkdir = "2.3.2"
73
substrate-build-script-utils = "3.0.0"
74
current_platform = "0.2.0"
75
which = "4.2.5"
76
regex = "1.5.5"
77
78

[dev-dependencies]
79
assert_cmd = "2.0.4"
80
assert_matches = "1.5.0"
81
pretty_assertions = "1.2.1"
82
wabt = "0.10.0"
83
regex = "1.5.5"
84
predicates = "2.1.1"
85

86
87
88
89
ink_primitives = "3"
ink_storage = "3"
ink_lang = "3"
ink_lang_codegen = "3"
90

91
92
93
94
95
[features]
# This `std` feature is required for testing using an inline contract's metadata, because `ink!` annotates the metadata
# generation code with `#[cfg(feature = "std")]`.
default = ["std"]
std = []
96
97
98
99

# Enable this to execute long running tests, which usually are only run on the CI server
#
# Disabled by default
100
test-ci-only = []
101
102
103
104

# Enable this to execute tests which depend on a locally running contracts enabed chain
# e.g.https://github.com/paritytech/canvas-node
integration-tests = []