Commit 2111eb06 authored by Hero Bird's avatar Hero Bird Committed by GitHub

Update to derive_more v0.99 (#229)

* [*] update to derive_more 0.99

* [scripts] use `#!/usr/bin/env bash` instead of `#!/bin/bash`

* [*] update to derive_more 0.99.1
parent 507834d7
Pipeline #56843 failed with stages
in 24 seconds
......@@ -15,7 +15,7 @@ include = ["/Cargo.toml", "src/**/*.rs", "/README.md", "/LICENSE"]
[dependencies]
serde = { version = "1.0", default-features = false, features = ["derive", "alloc"] }
derive_more = { version = "0.15", default-features = false, features = ["no_std"] }
derive_more = { version = "0.99.1", default-features = false, features = ["from"] }
ink_abi_derive = { version = "0.1.0", path = "derive", default-features = false, optional = true }
type-metadata = { git = "https://github.com/type-metadata/type-metadata.git", default-features = false, features = ["derive"] }
......
......@@ -16,7 +16,7 @@ include = ["/Cargo.toml", "src/**/*.rs", "/README.md", "/LICENSE"]
[dependencies]
env_logger = "0.6"
derive_more = "0.14.0"
derive_more = { version = "0.99.1", default-features = false, features = ["from", "display"] }
structopt = "0.2.15"
itertools = "0.8"
log = "0.4"
......
......@@ -24,7 +24,7 @@ ink_utils = { path = "../utils/", default-features = false }
scale = { package = "parity-scale-codec", version = "1.0", default-features = false, features = ["derive", "full"] }
type-metadata = { git = "https://github.com/type-metadata/type-metadata.git", default-features = false, features = ["derive"], optional = true }
derive_more = { version = "0.15", default-features = false, features = ["no_std"] }
derive_more = { version = "0.99.1", default-features = false, features = ["from"] }
smallvec = { version = "0.6.10", default-features = false, features = ["union"] }
cfg-if = "0.1"
......
......@@ -19,7 +19,7 @@ ink_abi = { version = "0.1", path = "../abi", default-features = false, optional
ink_lang2_macro = { version = "0.1.0", path = "macro", default-features = false }
scale = { package = "parity-scale-codec", version = "1.0", default-features = false, features = ["derive", "full"] }
derive_more = { version = "0.15", default-features = false, features = ["no_std"] }
derive_more = { version = "0.99.1", default-features = false, features = ["from"] }
[features]
default = ["std", "test-env"]
......
......@@ -25,7 +25,7 @@ itertools = { version = "0.8", default-features = false }
either = { version = "1.5", default-features = false }
serde = { version = "1.0", default-features = false, features = ["derive"] }
serde_json = "1.0"
derive_more = { version = "0.15", default-features = false }
derive_more = { version = "0.99.1", default-features = false, features = ["from"] }
regex = "1.3"
[dev-dependencies]
......
#!/bin/bash
#!/usr/bin/env bash
# Run this script from the workspace root!
#
......
#!/bin/bash
#!/usr/bin/env bash
# Run this script from the workspace root!
#
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment