Use kind-of >=6.0.3 everywhere (#590)

* Use kind-of >=6.0.3 everywhere

This repo's dependencies currently use [older versions](https://github.com/paritytech/fether/blob/3c0363079e1148ae0dc0595523905f9bee7b9a84/yarn.lock#L10218) of kind-of which have a possibly exploitable vulnerability ([original issue](https://github.com/jonschlinkert/kind-of/issues/30), [PR](https://github.com/jonschlinkert/kind-of/pull/31)).

* Update yarn.lock
4 jobs for v0.4.3-beta in 10 minutes and 5 seconds (queued for 6 seconds)
latest